aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2001-02-14 22:22:35 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2001-02-14 22:22:35 +0000
commit34837ec97bd6dbf2951a22c455401b8e5aac3cc6 (patch)
tree22105518cf441618570b1ff314693e76ebbfe17e
parent9a2276ab69712fb881f987023026de71930a7183 (diff)
downloadports-34837ec97bd6dbf2951a22c455401b8e5aac3cc6.tar.gz
ports-34837ec97bd6dbf2951a22c455401b8e5aac3cc6.zip
Notes
-rw-r--r--chinese/rxvt/Makefile24
-rw-r--r--chinese/rxvt/distinfo3
-rw-r--r--chinese/rxvt/files/patch-Makefile.in11
-rw-r--r--chinese/rxvt/files/patch-aa52
-rw-r--r--chinese/rxvt/files/patch-ab157
-rw-r--r--chinese/rxvt/files/patch-autoconf::config.h.in22
-rw-r--r--chinese/rxvt/files/patch-doc::Makefile.in30
-rw-r--r--chinese/rxvt/files/patch-src::Makefile.in11
-rw-r--r--chinese/rxvt/pkg-plist3
9 files changed, 91 insertions, 222 deletions
diff --git a/chinese/rxvt/Makefile b/chinese/rxvt/Makefile
index c35ca9e6e987..5ca172a115e7 100644
--- a/chinese/rxvt/Makefile
+++ b/chinese/rxvt/Makefile
@@ -6,31 +6,33 @@
#
PORTNAME= rxvt
-PORTVERSION= 2.7.3
-PORTREVISION= 1
+PORTVERSION= 2.7.5
CATEGORIES= chinese x11
MASTER_SITES= ftp://ftp.rxvt.org/pub/rxvt/ \
ftp://mason.primenet.com.au/pub/rxvt/ \
ftp://ftp.ics.es.osaka-u.ac.jp/pub/mirrors/rxvt/ \
ftp://ftp.fu-berlin.de/unix/X11/terms/rxvt/ \
${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= X11/terms
+MASTER_SITE_SUBDIR= X11/terms
DISTNAME= rxvt-${PORTVERSION}
-PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= rxvt-2.7.3.patch1.gz
-PATCH_DIST_STRIP+= -p1
-
-MAINTAINER= frankch@waru.life.nthu.edu.tw
+MAINTAINER= keichii@iteration.net
USE_X_PREFIX= yes
USE_XPM= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
USE_BZIP2= yes
-CONFIGURE_ARGS= --enable-xpm-background --enable-transparency \
+CONFIGURE_ARGS= --enable-xpm-background --enable-transparency \
--enable-menubar --enable-graphics --enable-xim \
- --enable-languages --with-encoding=big5
+ --disable-backspace-key --disable-delete-key \
+ --enable-rxvt-scroll --enable-next-scroll \
+ --enable-languages --with-encoding=big5 \
+ --enable-utmp --enable-wtmp --enable-shared
MAN1= crxvt.1
+post-install:
+ @${CHMOD} 4711 ${PREFIX}/bin/crxvt
+
.include <bsd.port.mk>
diff --git a/chinese/rxvt/distinfo b/chinese/rxvt/distinfo
index efc13796de38..1902bd27c4d2 100644
--- a/chinese/rxvt/distinfo
+++ b/chinese/rxvt/distinfo
@@ -1,2 +1 @@
-MD5 (rxvt-2.7.3.tar.bz2) = 4f22d749152ba717c5b716df43801800
-MD5 (rxvt-2.7.3.patch1.gz) = 348fca4eb5e7bc41d070745e3655d184
+MD5 (rxvt-2.7.5.tar.bz2) = dd9d2b6c3887c674f484c480d4419a19
diff --git a/chinese/rxvt/files/patch-Makefile.in b/chinese/rxvt/files/patch-Makefile.in
new file mode 100644
index 000000000000..1fd9b1f1aab6
--- /dev/null
+++ b/chinese/rxvt/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Mon Feb 5 22:39:51 2001
++++ Makefile.in Mon Feb 5 22:40:19 2001
+@@ -9,7 +9,7 @@
+ first_rule: all
+ dummy:
+
+-subdirs = src doc rclock src/graphics src/test
++subdirs = src doc src/graphics
+
+ DIST = INSTALL README.configure configure Makefile Makefile.in ChangeLog
+
diff --git a/chinese/rxvt/files/patch-aa b/chinese/rxvt/files/patch-aa
deleted file mode 100644
index c6fc8d13e4ed..000000000000
--- a/chinese/rxvt/files/patch-aa
+++ /dev/null
@@ -1,52 +0,0 @@
---- Makefile.in.orig Mon Mar 27 19:38:42 2000
-+++ Makefile.in Mon Mar 27 19:39:21 2000
-@@ -9,7 +9,7 @@
- first_rule: all
- dummy:
-
--subdirs = src doc rclock src/graphics src/test
-+subdirs = src doc src/graphics
-
- DIST = INSTALL README.configure configure Makefile Makefile.in ChangeLog
-
---- doc/Makefile.in.orig Mon Mar 27 19:39:40 2000
-+++ doc/Makefile.in Mon Mar 27 19:44:16 2000
-@@ -40,9 +40,6 @@
-
- all: rxvt.1
-
--rxvt.1: rxvt.tbl Makefile
-- @if test x$(TBL) = x; then : ; else echo "$(TBL) $(srcdir)/rxvt.tbl | grep -v '^.lf' > rxvt.1"; $(TBL) $(srcdir)/rxvt.tbl | grep -v '^.lf' > rxvt.1 ; fi
--
- SEDREPLACE = -e 's%@RXVT_VERSION@%$(VERSION)%g;'\
- -e 's%@RXVT_LSMDATE@%$(LSMDATE)%g;'\
- -e 's%@RXVT_DATE@%$(DATE)%g;'\
-@@ -56,7 +53,7 @@
-
- tags allbin:
-
--alldoc: $(basedir)/$(VERNAME).lsm rxvt.1 rxvt.html rxvtRef.html rxvtRef.txt
-+alldoc: rxvt.1
-
- yodl/versioninfo.yo: yodl/versioninfo.yo.in ../src/version.h
- $(SED) $(SEDREPLACE) < $(srcdir)/yodl/versioninfo.yo.in > $@
-@@ -85,7 +82,7 @@
- distclean:
-
- install:
-- $(INSTALL_DATA) rxvt.1 $(DESTDIR)$(mandir)/$(RXVTNAME).$(manext)
-+ $(INSTALL_DATA) rxvt.1 $(PREFIX)/man/man1/crxvt.1
-
- uninstall:
- -(cd $(mandir); $(RMF) $(RXVTNAME).$(manext) )
---- src/Makefile.in.orig Mon Mar 27 19:41:21 2000
-+++ src/Makefile.in Mon Mar 27 19:41:38 2000
-@@ -98,7 +98,7 @@
- (cd $(srcdir); $(RMF) Makefile)
-
- install: allbin alldoc
-- $(INSTALL_PROGRAM) rxvt $(DESTDIR)$(bindir)/$(RXVTNAME)
-+ $(INSTALL_PROGRAM) rxvt $(PREFIX)/bin/crxvt
-
- uninstall:
- -(cd $(bindir); $(RMF) $(RXVTNAME) )
diff --git a/chinese/rxvt/files/patch-ab b/chinese/rxvt/files/patch-ab
deleted file mode 100644
index 04f723e96936..000000000000
--- a/chinese/rxvt/files/patch-ab
+++ /dev/null
@@ -1,157 +0,0 @@
---- src/init.c.orig Mon Mar 27 19:50:56 2000
-+++ src/init.c Mon Mar 27 19:51:44 2000
-@@ -866,6 +866,16 @@
- GCForeground | GCBackground |
- GCFont | GCGraphicsExposures,
- &gcvalue);
-+#ifdef FIX_ALIGNMENT
-+ TermWin.ngc = TermWin.gc;
-+#ifdef MULTICHAR_SET
-+ gcvalue.font = TermWin.mfont->fid;
-+ TermWin.mgc = XCreateGC(Xdisplay, TermWin.vt,
-+ GCForeground | GCBackground |
-+ GCFont | GCGraphicsExposures,
-+ &gcvalue);
-+#endif
-+#endif
- }
- }
- /*----------------------------------------------------------------------*/
---- src/main.c.orig Mon Mar 27 19:53:37 2000
-+++ src/main.c Mon Mar 27 19:54:04 2000
-@@ -546,7 +546,11 @@
-
- /* alter existing GC */
- if (!init) {
-+#ifdef FIX_ALIGNMENT
-+ XSetFont(Xdisplay, TermWin.ngc, TermWin.font->fid);
-+#else
- XSetFont(Xdisplay, TermWin.gc, TermWin.font->fid);
-+#endif
- menubar_expose();
- }
-
---- src/rxvt.h.orig Mon Mar 27 19:54:20 2000
-+++ src/rxvt.h Mon Mar 27 19:55:36 2000
-@@ -172,12 +172,19 @@
- Window parent[KNOW_PARENTS], /* parent[0] is our window */
- vt; /* vt100 window */
- GC gc; /* GC for drawing text */
-+#ifdef FIX_ALIGNMENT
-+ GC ngc;
-+ int vascent;
-+#endif
- XFontStruct *font; /* main font structure */
- #ifndef NO_BOLDFONT
- XFontStruct *boldFont; /* bold font */
- #endif
- #ifdef MULTICHAR_SET
- XFontStruct *mfont; /* Multichar font structure */
-+#endif
-+#ifdef FIX_ALIGNMENT
-+ GC mgc;
- #endif
- XFontSet fontset;
- #ifdef XPM_BACKGROUND
---- src/screen.c.orig Mon Mar 27 19:56:10 2000
-+++ src/screen.c Mon Mar 27 20:00:03 2000
-@@ -2162,7 +2162,12 @@
- * always go back to the base font - it's much safer
- */
- wbyte = 0;
-- XSetFont(Xdisplay, TermWin.gc, TermWin.font->fid);
-+#ifdef FIX_ALIGNMENT
-+ TermWin.gc = TermWin.ngc;
-+ TermWin.vascent = TermWin.font->ascent;
-+#else
-+ XSetFont(Xdisplay, TermWin.gc, TermWin.font->fid);
-+#endif
- draw_string = XDrawString;
- draw_image_string = XDrawImageString;
- clearfirst = clearlast = 0;
-@@ -2371,7 +2376,11 @@
- len = 0;
- buffer[len++] = stp[col];
- ypixelc = Row2Pixel(row);
-+#ifdef FIX_ALIGNMENT
-+ ypixel = ypixelc + TermWin.vascent;
-+#else
- ypixel = ypixelc + TermWin.font->ascent;
-+#endif
- xpixel = Col2Pixel(col);
- fontdiff = 0;
- wlen = 1;
-@@ -2392,7 +2401,13 @@
- fprop = TermWin.mprop;
- if (!wbyte && TermWin.mfont) {
- wbyte = 1;
-+#ifdef FIX_ALIGNMENT
-+ TermWin.gc = TermWin.mgc;
-+ ypixel += TermWin.mfont->ascent - TermWin.vascent;
-+ TermWin.vascent = TermWin.mfont->ascent;
-+#else
- XSetFont(Xdisplay, TermWin.gc, TermWin.mfont->fid);
-+#endif
- fontdiff = TermWin.mprop;
- draw_string = XDrawString16;
- draw_image_string = XDrawImageString16;
-@@ -2439,7 +2454,13 @@
- }
- if (wbyte) {
- wbyte = 0;
-+#ifdef FIX_ALIGNMENT
-+ TermWin.gc = TermWin.ngc;
-+ ypixel += TermWin.font->ascent - TermWin.vascent;
-+ TermWin.vascent = TermWin.font->ascent;
-+#else
- XSetFont(Xdisplay, TermWin.gc, TermWin.font->fid);
-+#endif
- draw_string = XDrawString;
- draw_image_string = XDrawImageString;
- }
-@@ -2537,7 +2558,11 @@
- rend &= ~RS_Bold; /* we've taken care of it */
- } else if (bfont) {
- bfont = 0;
-+#ifdef FIX_ALIGNMENT
-+ XSetFont(Xdisplay, TermWin.ngc, TermWin.font->fid);
-+#else
- XSetFont(Xdisplay, TermWin.gc, TermWin.font->fid);
-+#endif
- }
- #endif
- /*
-@@ -2672,6 +2697,9 @@
- end_row = TermWin.saveLines - TermWin.view_start;
- if (selection.op && current_screen == selection.screen) {
- i = selection.beg.row + TermWin.saveLines;
-+#ifdef FIX_ALIGNMENT
-+ TermWin.gc = TermWin.ngc;
-+#endif
- row = selection.end.row + TermWin.saveLines;
- if (i >= end_row)
- col = selection.beg.col;
---- src/feature.h.orig Mon Mar 27 20:06:40 2000
-+++ src/feature.h Mon Mar 27 20:07:27 2000
-@@ -55,18 +55,18 @@
- * overstrike just for multi char fonts
- * Note: NO_BOLDOVERSTRIKE implies NO_BOLDOVERSTRIKE_MULTI
- */
--/* #define NO_BOLDOVERSTRIKE */
-+#define NO_BOLDOVERSTRIKE
- /* #define NO_BOLDOVERSTRIKE_MULTI */
-
- /*
- * Also use bold font or overstrike even if we use colour for bold
- */
--#define VERYBOLD
-+/* #define VERYBOLD */
-
- /*
- * Compile without support for real bold fonts
- */
--/* #define NO_BOLDFONT */
-+#define NO_BOLDFONT
-
- /*
- * If the screen has 24 bit mode, use that even if the default is 8 bit.
diff --git a/chinese/rxvt/files/patch-autoconf::config.h.in b/chinese/rxvt/files/patch-autoconf::config.h.in
new file mode 100644
index 000000000000..961285e85025
--- /dev/null
+++ b/chinese/rxvt/files/patch-autoconf::config.h.in
@@ -0,0 +1,22 @@
+--- autoconf/config.h.in.orig Mon Feb 5 22:46:11 2001
++++ autoconf/config.h.in Mon Feb 5 22:48:13 2001
+@@ -168,7 +168,8 @@
+ #undef HAVE_UTMP_HOST
+
+ /* Define location of utmp */
+-#undef RXVT_UTMP_FILE
++/* #undef RXVT_UTMP_FILE */
++#define RXVT_UTMP_FILE "/var/run/utmp"
+
+ /* Define in utmpx.h has struct utmpx */
+ #undef HAVE_STRUCT_UTMPX
+@@ -180,7 +181,8 @@
+ #undef RXVT_UTMPX_FILE
+
+ /* Define location of wtmp */
+-#undef RXVT_WTMP_FILE
++/* #undef RXVT_WTMP_FILE */
++#define RXVT_WTMP_FILE "/var/log/wtmp"
+
+ /* Define location of wtmpx */
+ #undef RXVT_WTMPX_FILE
diff --git a/chinese/rxvt/files/patch-doc::Makefile.in b/chinese/rxvt/files/patch-doc::Makefile.in
new file mode 100644
index 000000000000..17de807f1ede
--- /dev/null
+++ b/chinese/rxvt/files/patch-doc::Makefile.in
@@ -0,0 +1,30 @@
+--- doc/Makefile.in.orig Mon Feb 5 22:40:26 2001
++++ doc/Makefile.in Mon Feb 5 22:50:03 2001
+@@ -40,9 +40,6 @@
+
+ all: rxvt.1
+
+-rxvt.1: rxvt.tbl Makefile
+- @if test x$(TBL) = x; then : ; else echo "$(TBL) $(srcdir)/rxvt.tbl | grep -v '^.lf' > rxvt.1"; $(TBL) $(srcdir)/rxvt.tbl | grep -v '^.lf' > rxvt.1 ; fi
+-
+ SEDREPLACE = -e 's%@RXVT_VERSION@%$(VERSION)%g;'\
+ -e 's%@RXVT_LSMDATE@%$(LSMDATE)%g;'\
+ -e 's%@RXVT_DATE@%$(DATE)%g;'\
+@@ -56,7 +53,7 @@
+
+ tags allbin:
+
+-alldoc: $(basedir)/$(VERNAME).lsm yodl/versioninfo.yo rxvt.1 rxvt.html rxvtRef.html rxvtRef.txt
++alldoc: rxvt.1
+
+ yodl/versioninfo.yo: yodl/versioninfo.yo.in ../src/version.h
+ $(SED) $(SEDREPLACE) < $(srcdir)/yodl/versioninfo.yo.in > $@
+@@ -87,7 +84,7 @@
+ distclean:
+
+ install:
+- $(INSTALL_DATA) rxvt.1 $(DESTDIR)$(mandir)/$(RXVTNAME).$(manext)
++ $(INSTALL_DATA) rxvt.1 $(PREFIX)/man/man1/crxvt.1
+
+ uninstall:
+ -(cd $(mandir); $(RMF) $(RXVTNAME).$(manext) )
diff --git a/chinese/rxvt/files/patch-src::Makefile.in b/chinese/rxvt/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..43a016099bd8
--- /dev/null
+++ b/chinese/rxvt/files/patch-src::Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Mon Feb 5 22:41:53 2001
++++ src/Makefile.in Mon Feb 5 22:42:41 2001
+@@ -115,7 +115,7 @@
+
+ install: allbin alldoc
+ @$(LIBTOOL) --mode=install $(INSTALL_PROGRAM) librxvt.la $(libdir)
+- @$(LIBTOOL) --mode=install $(INSTALL_PROGRAM) rxvt $(DESTDIR)$(bindir)/`$(ECHO) $$p|$(SED) 's/$(EXEEXT)$$//'|$(SED) '$(transform)'|$(SED) 's/$$/$(EXEEXT)/'`;
++ @$(LIBTOOL) --mode=install $(INSTALL_PROGRAM) rxvt $(PREFIX)/bin/crxvt
+
+ uninstall:
+ @$(LIBTOOL) --mode=uninstall $(RMF) $(DESTDIR)$(bindir)/`$(ECHO) rxvt|$(SED) 's/$(EXEEXT)$$//'|$(SED) '$(transform)'|$(SED) 's/$$/$(EXEEXT)/'`
diff --git a/chinese/rxvt/pkg-plist b/chinese/rxvt/pkg-plist
index 7d65af3921dd..d277fb79e9bd 100644
--- a/chinese/rxvt/pkg-plist
+++ b/chinese/rxvt/pkg-plist
@@ -1 +1,4 @@
bin/crxvt
+lib/librxvt.a
+lib/librxvt.so
+lib/librxvt.so.0