aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-08-31 22:07:04 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-08-31 22:07:04 +0000
commit349acdc90d615b2e5239a211eacdbd9d67a7293a (patch)
treea4d3398f6ff98935cd09fa0f3ffe29e23c03717f
parent519df5d9213d98a1de372999bb47851f33c74dc6 (diff)
downloadports-349acdc90d615b2e5239a211eacdbd9d67a7293a.tar.gz
ports-349acdc90d615b2e5239a211eacdbd9d67a7293a.zip
Notes
-rw-r--r--japanese/scim-anthy/Makefile6
-rw-r--r--japanese/scim-anthy/files/patch-src_scim__anthy__prefs.cpp56
2 files changed, 59 insertions, 3 deletions
diff --git a/japanese/scim-anthy/Makefile b/japanese/scim-anthy/Makefile
index dea6e8d3b8a6..8e7a41221d6d 100644
--- a/japanese/scim-anthy/Makefile
+++ b/japanese/scim-anthy/Makefile
@@ -10,6 +10,9 @@ MASTER_SITES= OSDN/scim-imengine/37309
MAINTAINER= ports@FreeBSD.org
COMMENT= SCIM IMEngine module using Anthy
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= scim:textproc/scim
LIB_DEPENDS= libanthy.so:japanese/anthy
RUN_DEPENDS:= ${BUILD_DEPENDS} \
@@ -18,7 +21,4 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
USES= gmake iconv libtool:keepla pkgconfig
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include -D__STDC_ISO_10646__
-LDFLAGS+= -L${LOCALBASE}/lib
-
.include <bsd.port.mk>
diff --git a/japanese/scim-anthy/files/patch-src_scim__anthy__prefs.cpp b/japanese/scim-anthy/files/patch-src_scim__anthy__prefs.cpp
new file mode 100644
index 000000000000..54a3ceef657a
--- /dev/null
+++ b/japanese/scim-anthy/files/patch-src_scim__anthy__prefs.cpp
@@ -0,0 +1,56 @@
+Add missing initializers
+
+scim_anthy_prefs.cpp:98:9: error: cannot initialize a member subobject of type 'void *' with an rvalue of type 'bool'
+ false,
+ ^~~~~
+
+--- src/scim_anthy_prefs.cpp.orig 2008-04-24 03:49:53 UTC
++++ src/scim_anthy_prefs.cpp
+@@ -95,6 +95,7 @@ BoolConfigData config_bool_common [] =
+ N_("A_llow spliting romaji on editing preedit string"),
+ NULL,
+ N_("If this check is enabled, you can delete each letter."),
++ NULL,
+ false,
+ },
+ {
+@@ -104,6 +105,7 @@ BoolConfigData config_bool_common [] =
+ N_("_Entering the pseudo ASCII input mode with capital letters."),
+ NULL,
+ N_("If this check is enabled, capital letters will becomes a trigger to enter the pseudo ASCII input mode."),
++ NULL,
+ false,
+ },
+ {
+@@ -113,6 +115,7 @@ BoolConfigData config_bool_common [] =
+ N_("Insert a _blank with a blank key."),
+ NULL,
+ N_("If this check is enabled, a blank key will works to insert a blank when entering the pseudo ASCII input mode."),
++ NULL,
+ false,
+ },
+ {
+@@ -122,6 +125,7 @@ BoolConfigData config_bool_common [] =
+ N_("_Show predicted candidates while inputting letters"),
+ NULL,
+ NULL,
++ NULL,
+ false,
+ },
+ {
+@@ -131,6 +135,7 @@ BoolConfigData config_bool_common [] =
+ N_("Use _direct select keys while predicting"),
+ NULL,
+ NULL,
++ NULL,
+ false,
+ },
+ {
+@@ -269,6 +274,7 @@ IntConfigData config_int_common [] =
+ 0,
+ 0,
+ 0, 0, 0,
++ NULL,
+ NULL,
+ NULL,
+ NULL,