aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2014-02-09 20:49:23 +0000
committerJohan van Selst <johans@FreeBSD.org>2014-02-09 20:49:23 +0000
commit34dcec433d780c9dfeadec5b37baaf8247fc5da9 (patch)
tree4b7cee5744696c3fe425884ebc092bd7073ffd55
parentd5b4436057d513871d3d914ffd4ca87d57da58da (diff)
downloadports-34dcec433d780c9dfeadec5b37baaf8247fc5da9.tar.gz
ports-34dcec433d780c9dfeadec5b37baaf8247fc5da9.zip
Notes
-rw-r--r--www/lynx-current/Makefile28
-rw-r--r--www/lynx-current/distinfo4
-rw-r--r--www/lynx-current/files/patch-aa3
-rw-r--r--www/lynx-current/pkg-plist180
4 files changed, 104 insertions, 111 deletions
diff --git a/www/lynx-current/Makefile b/www/lynx-current/Makefile
index b6c40a0b8c1a..9c5dc84086d4 100644
--- a/www/lynx-current/Makefile
+++ b/www/lynx-current/Makefile
@@ -2,21 +2,20 @@
# $FreeBSD$
PORTNAME= lynx
-PORTVERSION= 2.8.8d16
+PORTVERSION= 2.8.8p4
PKGNAMESUFFIX= -current
CATEGORIES= www ipv6
MASTER_SITES= http://lynx.isc.org/current/
-DISTNAME= ${PORTNAME}${PORTVERSION:C/d.*//}dev.${PORTVERSION:C/.*d//}
+DISTNAME= ${PORTNAME}${PORTVERSION:S/p/pre./}
MAINTAINER= johans@FreeBSD.org
COMMENT= Non-graphical, text-based World-Wide Web client
-LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn
RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
CONFLICTS_INSTALL= lynx-2.8.[0-7].* ja-lynx-[0-9]*
-WRKSRC= ${WRKDIR}/${DISTNAME:S/./-/g:C/d.*//}
+WRKSRC= ${WRKDIR}/${DISTNAME:S/./-/g:C/p.*//}
USE_BZIP2= yes
USES= iconv shebangfix
USE_OPENSSL= yes
@@ -45,21 +44,14 @@ L_DOC= ${PREFIX}/share/doc/lynx
L_HELP= ${PREFIX}/share/lynx_help
DOCSDIR= ${L_DOC}
-post-install:
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}/${L_DOC}
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}/${L_HELP}
- ${CHOWN} ${SHAREOWN}:${SHAREGRP} \
- ${STAGEDIR}/${L_LIB}/lynx.cfg* ${STAGEDIR}/${L_LIB}/lynx.lss*
+OPTIONS_DEFINE= IDN NLS
+OPTIONS_DEFAULT=IDN NLS
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-CONFIGURE_ARGS+= --enable-nls
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+IDN_LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn
+IDN_CONFIGURE_ENABLE= idna
.include <bsd.port.mk>
diff --git a/www/lynx-current/distinfo b/www/lynx-current/distinfo
index cf5fcd2ec464..6cc60947e750 100644
--- a/www/lynx-current/distinfo
+++ b/www/lynx-current/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lynx2.8.8dev.16.tar.bz2) = 826ddbc3fb346daf2c564103400493b9ce2c02e932f3aceaf7195b60098ba808
-SIZE (lynx2.8.8dev.16.tar.bz2) = 2560812
+SHA256 (lynx2.8.8pre.4.tar.bz2) = 896f3ab19a5b3644acc7d745f2a019e3535a545f630020eb490f96db00dd2a2b
+SIZE (lynx2.8.8pre.4.tar.bz2) = 2584088
diff --git a/www/lynx-current/files/patch-aa b/www/lynx-current/files/patch-aa
index de8c5ac586ce..f9249d82bb8c 100644
--- a/www/lynx-current/files/patch-aa
+++ b/www/lynx-current/files/patch-aa
@@ -1,6 +1,6 @@
--- makefile.in.orig 2009-11-25 13:56:48.000000000 +0300
+++ makefile.in 2010-03-26 11:13:46.000000000 +0300
-@@ -384,14 +384,9 @@
+@@ -384,14 +384,10 @@
if test "$(COMPRESS_PROG)" != "" ; then \
(cd $(HELPDIR) && $(COMPRESS_PROG) $$files ) \
fi'
@@ -14,6 +14,7 @@
- @echo Updating $(sysconfdir)/lynx.cfg to point to installed help-files
+ @echo Updating $(sysconfdir)/lynx.cfg.default
+ cp $(srcdir)/lynx.cfg $(SYSCONFDIR)/lynx.tmp
++ rm -f $(SYSCONFDIR)/lynx.cfg.default
+ @echo Updating $(sysconfdir)/lynx.cfg.default to point to installed help-files
@ECHO_CC@sed -e '/^HELPFILE:http/s!^!#!' \
-e '/^#HELPFILE:file/s!#!!' \
diff --git a/www/lynx-current/pkg-plist b/www/lynx-current/pkg-plist
index c141b46e7634..3cf8d14e2e66 100644
--- a/www/lynx-current/pkg-plist
+++ b/www/lynx-current/pkg-plist
@@ -7,92 +7,92 @@ etc/lynx.cfg.default
etc/lynx.lss.default
@exec if [ ! -f %D/etc/lynx.lss ] ; then cp -p %D/%F %B/lynx.lss; fi
@exec mkdir -p %D/share/lynx_help
-%%DOCSDIR%%/CHANGES
-%%DOCSDIR%%/COPYHEADER
-@exec ln -sf %D/%F %D/share/lynx_help/%f
-@unexec rm -f %D/share/lynx_help/%f
-%%DOCSDIR%%/COPYHEADER.asc
-%%DOCSDIR%%/COPYING
-@exec ln -sf %D/%F %D/share/lynx_help/%f
-@unexec rm -f %D/share/lynx_help/%f
-%%DOCSDIR%%/COPYING.asc
-%%DOCSDIR%%/PROBLEMS
-%%DOCSDIR%%/README
-%%DOCSDIR%%/docs/CHANGES2.3.gz
-%%DOCSDIR%%/docs/CHANGES2.4.gz
-%%DOCSDIR%%/docs/CHANGES2.5.gz
-%%DOCSDIR%%/docs/CHANGES2.6.gz
-%%DOCSDIR%%/docs/CHANGES2.7.gz
-%%DOCSDIR%%/docs/CHANGES2.8.gz
-%%DOCSDIR%%/docs/CRAWL.announce.gz
-%%DOCSDIR%%/docs/FM.announce.gz
-%%DOCSDIR%%/docs/IBMPC-charsets.announce.gz
-%%DOCSDIR%%/docs/OS-390.announce.gz
-%%DOCSDIR%%/docs/README.TRST
-%%DOCSDIR%%/docs/README.chartrans
-%%DOCSDIR%%/docs/README.cookies
-%%DOCSDIR%%/docs/README.defines
-%%DOCSDIR%%/docs/README.jp
-%%DOCSDIR%%/docs/README.metrics
-%%DOCSDIR%%/docs/README.options
-%%DOCSDIR%%/docs/README.release
-%%DOCSDIR%%/docs/README.rootcerts
-%%DOCSDIR%%/docs/README.ssl
-%%DOCSDIR%%/docs/README.sslcerts
-%%DOCSDIR%%/docs/SOCKETSHR.announce.gz
-%%DOCSDIR%%/docs/TCPWARE.announce.gz
-%%DOCSDIR%%/docs/VMSWAIS.announce.gz
-%%DOCSDIR%%/docs/djgpp.key
-%%DOCSDIR%%/docs/pdcurses.key
-%%DOCSDIR%%/docs/slang.key
-%%DOCSDIR%%/docs/win-386.announce.gz
-%%DOCSDIR%%/samples/blue-background.lss
-%%DOCSDIR%%/samples/bright-blue.lss
-%%DOCSDIR%%/samples/cernrules.txt
-%%DOCSDIR%%/samples/home.htm
-%%DOCSDIR%%/samples/installdirs.html
-%%DOCSDIR%%/samples/jumps.htm
-%%DOCSDIR%%/samples/jumpsUnix.html
-%%DOCSDIR%%/samples/jumpsVMS.html
-%%DOCSDIR%%/samples/keepviewer
-%%DOCSDIR%%/samples/lynx-demo.cfg
-%%DOCSDIR%%/samples/lynx-keymaps
-%%DOCSDIR%%/samples/lynx.bat
-%%DOCSDIR%%/samples/lynx.com
-%%DOCSDIR%%/samples/lynx.ico
-%%DOCSDIR%%/samples/lynx.lss
-%%DOCSDIR%%/samples/lynx_bookmarks.htm
-%%DOCSDIR%%/samples/lynxdump
-%%DOCSDIR%%/samples/mailcap
-%%DOCSDIR%%/samples/mailto-form.pl
-%%DOCSDIR%%/samples/midnight.lss
-%%DOCSDIR%%/samples/mild-colors.lss
-%%DOCSDIR%%/samples/mime.types
-%%DOCSDIR%%/samples/oldlynx
-%%DOCSDIR%%/samples/opaque.lss
-%%DOCSDIR%%/test/ALT88592.html
-%%DOCSDIR%%/test/ISO_LATIN1_test.html
-%%DOCSDIR%%/test/README.txt
-%%DOCSDIR%%/test/TestComment.html
-%%DOCSDIR%%/test/bad-html.html
-%%DOCSDIR%%/test/c1.html
-%%DOCSDIR%%/test/cp-1252.html
-%%DOCSDIR%%/test/cp-1252a.html
-%%DOCSDIR%%/test/iso-8859-1.html
-%%DOCSDIR%%/test/iso-8859-1a.html
-%%DOCSDIR%%/test/iso-8859-2.html
-%%DOCSDIR%%/test/iso-8859-2a.html
-%%DOCSDIR%%/test/koi8-r.html
-%%DOCSDIR%%/test/quickbrown.html
-%%DOCSDIR%%/test/raw8bit.html
-%%DOCSDIR%%/test/sgml.html
-%%DOCSDIR%%/test/spaces.html
-%%DOCSDIR%%/test/special_urls.html
-%%DOCSDIR%%/test/tabtest.html
-%%DOCSDIR%%/test/tags.html
-%%DOCSDIR%%/test/test-styles.html
-%%DOCSDIR%%/test/unicode.html
-%%DOCSDIR%%/test/utf-8-demo.html
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/COPYHEADER
+%%PORTDOCS%%%%DOCSDIR%%/COPYHEADER.asc
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/COPYING.asc
+%%PORTDOCS%%%%DOCSDIR%%/PROBLEMS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/docs/CHANGES2.3.gz
+%%PORTDOCS%%%%DOCSDIR%%/docs/CHANGES2.4.gz
+%%PORTDOCS%%%%DOCSDIR%%/docs/CHANGES2.5.gz
+%%PORTDOCS%%%%DOCSDIR%%/docs/CHANGES2.6.gz
+%%PORTDOCS%%%%DOCSDIR%%/docs/CHANGES2.7.gz
+%%PORTDOCS%%%%DOCSDIR%%/docs/CHANGES2.8.gz
+%%PORTDOCS%%%%DOCSDIR%%/docs/CRAWL.announce.gz
+%%PORTDOCS%%%%DOCSDIR%%/docs/FM.announce.gz
+%%PORTDOCS%%%%DOCSDIR%%/docs/IBMPC-charsets.announce.gz
+%%PORTDOCS%%%%DOCSDIR%%/docs/OS-390.announce.gz
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.TRST
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.chartrans
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.cookies
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.defines
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.jp
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.metrics
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.options
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.release
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.rootcerts
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.ssl
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.sslcerts
+%%PORTDOCS%%%%DOCSDIR%%/docs/SOCKETSHR.announce.gz
+%%PORTDOCS%%%%DOCSDIR%%/docs/TCPWARE.announce.gz
+%%PORTDOCS%%%%DOCSDIR%%/docs/VMSWAIS.announce.gz
+%%PORTDOCS%%%%DOCSDIR%%/docs/djgpp.key
+%%PORTDOCS%%%%DOCSDIR%%/docs/pdcurses.key
+%%PORTDOCS%%%%DOCSDIR%%/docs/slang.key
+%%PORTDOCS%%%%DOCSDIR%%/docs/win-386.announce.gz
+%%PORTDOCS%%%%DOCSDIR%%/samples/blue-background.lss
+%%PORTDOCS%%%%DOCSDIR%%/samples/bright-blue.lss
+%%PORTDOCS%%%%DOCSDIR%%/samples/cernrules.txt
+%%PORTDOCS%%%%DOCSDIR%%/samples/home.htm
+%%PORTDOCS%%%%DOCSDIR%%/samples/installdirs.html
+%%PORTDOCS%%%%DOCSDIR%%/samples/jumps.htm
+%%PORTDOCS%%%%DOCSDIR%%/samples/jumpsUnix.html
+%%PORTDOCS%%%%DOCSDIR%%/samples/jumpsVMS.html
+%%PORTDOCS%%%%DOCSDIR%%/samples/keepviewer
+%%PORTDOCS%%%%DOCSDIR%%/samples/lynx-demo.cfg
+%%PORTDOCS%%%%DOCSDIR%%/samples/lynx-keymaps
+%%PORTDOCS%%%%DOCSDIR%%/samples/lynx.bat
+%%PORTDOCS%%%%DOCSDIR%%/samples/lynx.com
+%%PORTDOCS%%%%DOCSDIR%%/samples/lynx.ico
+%%PORTDOCS%%%%DOCSDIR%%/samples/lynx.lss
+%%PORTDOCS%%%%DOCSDIR%%/samples/lynx_bookmarks.htm
+%%PORTDOCS%%%%DOCSDIR%%/samples/lynxdump
+%%PORTDOCS%%%%DOCSDIR%%/samples/mailcap
+%%PORTDOCS%%%%DOCSDIR%%/samples/mailto-form.pl
+%%PORTDOCS%%%%DOCSDIR%%/samples/midnight.lss
+%%PORTDOCS%%%%DOCSDIR%%/samples/mild-colors.lss
+%%PORTDOCS%%%%DOCSDIR%%/samples/mime.types
+%%PORTDOCS%%%%DOCSDIR%%/samples/oldlynx
+%%PORTDOCS%%%%DOCSDIR%%/samples/oldlynx.bat
+%%PORTDOCS%%%%DOCSDIR%%/samples/opaque.lss
+%%PORTDOCS%%%%DOCSDIR%%/test/ALT88592.html
+%%PORTDOCS%%%%DOCSDIR%%/test/ISO_LATIN1_test.html
+%%PORTDOCS%%%%DOCSDIR%%/test/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/test/TestComment.html
+%%PORTDOCS%%%%DOCSDIR%%/test/bad-html.html
+%%PORTDOCS%%%%DOCSDIR%%/test/c1.html
+%%PORTDOCS%%%%DOCSDIR%%/test/circle.html
+%%PORTDOCS%%%%DOCSDIR%%/test/cp-1252.html
+%%PORTDOCS%%%%DOCSDIR%%/test/cp-1252a.html
+%%PORTDOCS%%%%DOCSDIR%%/test/iso-8859-1.html
+%%PORTDOCS%%%%DOCSDIR%%/test/iso-8859-1a.html
+%%PORTDOCS%%%%DOCSDIR%%/test/iso-8859-2.html
+%%PORTDOCS%%%%DOCSDIR%%/test/iso-8859-2a.html
+%%PORTDOCS%%%%DOCSDIR%%/test/koi8-r.html
+%%PORTDOCS%%%%DOCSDIR%%/test/quickbrown.html
+%%PORTDOCS%%%%DOCSDIR%%/test/raw8bit.html
+%%PORTDOCS%%%%DOCSDIR%%/test/sgml.html
+%%PORTDOCS%%%%DOCSDIR%%/test/spaces.html
+%%PORTDOCS%%%%DOCSDIR%%/test/special_urls.html
+%%PORTDOCS%%%%DOCSDIR%%/test/square.html
+%%PORTDOCS%%%%DOCSDIR%%/test/tabtest.html
+%%PORTDOCS%%%%DOCSDIR%%/test/tags.html
+%%PORTDOCS%%%%DOCSDIR%%/test/test-styles.html
+%%PORTDOCS%%%%DOCSDIR%%/test/triangle.html
+%%PORTDOCS%%%%DOCSDIR%%/test/unicode.html
+%%PORTDOCS%%%%DOCSDIR%%/test/utf-8-demo.html
%%NLS%%share/locale/ca/LC_MESSAGES/lynx.mo
%%NLS%%share/locale/cs/LC_MESSAGES/lynx.mo
%%NLS%%share/locale/da/LC_MESSAGES/lynx.mo
@@ -140,10 +140,10 @@ share/lynx_help/keystrokes/xterm_help.html.gz
share/lynx_help/lynx-dev.html.gz
share/lynx_help/lynx_help_main.html.gz
share/lynx_help/lynx_url_support.html.gz
-@dirrm %%DOCSDIR%%/samples
-@dirrm %%DOCSDIR%%/test
-@dirrm %%DOCSDIR%%/docs
-@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/samples
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/test
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm share/lynx_help/keystrokes
@dirrm share/lynx_help
%%NLS%%@dirrmtry share/locale/fi/LC_MESSAGES