aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-05-20 05:13:38 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-05-20 05:13:38 +0000
commit34eeaab8ba41a4f9a3f878ed2134c7e21ac59424 (patch)
treee92ed331410c1c8d284f6343fc5943d9f85e11c9
parent9b686acb9f876925f4e7b46076f0cc77ca277508 (diff)
downloadports-34eeaab8ba41a4f9a3f878ed2134c7e21ac59424.tar.gz
ports-34eeaab8ba41a4f9a3f878ed2134c7e21ac59424.zip
Notes
-rw-r--r--games/Makefile1
-rw-r--r--games/libretro-fmsx/Makefile29
-rw-r--r--games/libretro-fmsx/distinfo3
-rw-r--r--games/libretro-fmsx/pkg-descr3
4 files changed, 36 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index d6bdfb52c890..620995086917 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -491,6 +491,7 @@
SUBDIR += libretro-emux
SUBDIR += libretro-fbalpha
SUBDIR += libretro-fceumm
+ SUBDIR += libretro-fmsx
SUBDIR += libretro-fuse
SUBDIR += libretro-gambatte
SUBDIR += libretro-genesis_plus_gx
diff --git a/games/libretro-fmsx/Makefile b/games/libretro-fmsx/Makefile
new file mode 100644
index 000000000000..7c5aaa0b9fc8
--- /dev/null
+++ b/games/libretro-fmsx/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= libretro-fmsx
+PORTVERSION= 0.20200504
+CATEGORIES= games
+
+MAINTAINER= menelkir@itroll.org
+COMMENT= Port of fMSX to the libretro API
+
+LICENSE= FMSX
+LICENSE_NAME= FMSX
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
+USES= compiler:c++11-lib gmake
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= libretro
+GH_PROJECT= fmsx-libretro
+GH_TAGNAME= c76e1dc
+
+PLIST_FILES= lib/libretro/fmsx_libretro.so
+
+do-install:
+ ${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro;
+ ${INSTALL_LIB} ${WRKSRC}/fmsx_libretro.so ${STAGEDIR}/${PREFIX}/lib/libretro;
+
+.include <bsd.port.mk>
diff --git a/games/libretro-fmsx/distinfo b/games/libretro-fmsx/distinfo
new file mode 100644
index 000000000000..fe3186ccebb5
--- /dev/null
+++ b/games/libretro-fmsx/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1588720298
+SHA256 (libretro-fmsx-libretro-0.20200504-c76e1dc_GH0.tar.gz) = 3b6d96d9ce8783ee72ca4e750b4666eafbf2ae142e1040cf0eeed0d7cc364e09
+SIZE (libretro-fmsx-libretro-0.20200504-c76e1dc_GH0.tar.gz) = 621026
diff --git a/games/libretro-fmsx/pkg-descr b/games/libretro-fmsx/pkg-descr
new file mode 100644
index 000000000000..3ecbe6ce3e39
--- /dev/null
+++ b/games/libretro-fmsx/pkg-descr
@@ -0,0 +1,3 @@
+Port of fMSX to the libretro API.
+
+WWW: https://github.com/libretro/fmsx-libretro