aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-20 03:28:15 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-20 03:28:15 +0000
commit357265a6e5cd8c55a6e126e8e506714ca3e0e057 (patch)
treed8797b256d69f8f5aa10f1bccb12513ff02132d7
parent8ef42ce549b63d2d571c104fa72af474e27369ed (diff)
downloadports-357265a6e5cd8c55a6e126e8e506714ca3e0e057.tar.gz
ports-357265a6e5cd8c55a6e126e8e506714ca3e0e057.zip
add mp3asm
MP3 frame level editor
Notes
Notes: svn path=/head/; revision=45261
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mp3asm/Makefile20
-rw-r--r--audio/mp3asm/distinfo1
-rw-r--r--audio/mp3asm/files/patch-src::mp3asm.h10
-rw-r--r--audio/mp3asm/files/patch-src::utils.c10
-rw-r--r--audio/mp3asm/pkg-comment1
-rw-r--r--audio/mp3asm/pkg-descr13
-rw-r--r--audio/mp3asm/pkg-plist1
8 files changed, 57 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 8a3c2513f173..5fbc94d016ab 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -111,6 +111,7 @@
SUBDIR += mikmod
SUBDIR += mixer.app
SUBDIR += mp3_check
+ SUBDIR += mp3asm
SUBDIR += mp3blaster
SUBDIR += mp3butler
SUBDIR += mp3check
diff --git a/audio/mp3asm/Makefile b/audio/mp3asm/Makefile
new file mode 100644
index 000000000000..1f619d9058e3
--- /dev/null
+++ b/audio/mp3asm/Makefile
@@ -0,0 +1,20 @@
+# ex:ts=8
+# New ports collection makefile for: mp3asm
+# Date created: Jul 20, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3asm
+PORTVERSION= 0.1.2
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/audio/mp3asm/distinfo b/audio/mp3asm/distinfo
new file mode 100644
index 000000000000..848e298cef6b
--- /dev/null
+++ b/audio/mp3asm/distinfo
@@ -0,0 +1 @@
+MD5 (mp3asm-0.1.2.tar.gz) = ee4dfa1ec36f46ad5f2286dd685e5d79
diff --git a/audio/mp3asm/files/patch-src::mp3asm.h b/audio/mp3asm/files/patch-src::mp3asm.h
new file mode 100644
index 000000000000..aabba2f6f270
--- /dev/null
+++ b/audio/mp3asm/files/patch-src::mp3asm.h
@@ -0,0 +1,10 @@
+--- src/mp3asm.h.orig Fri Jul 20 11:17:05 2001
++++ src/mp3asm.h Fri Jul 20 11:17:58 2001
+@@ -30,7 +30,6 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <sysexits.h>
+-#include <argz.h>
+ #include <ctype.h>
+
+ #define LOGBUFSIZE 4096
diff --git a/audio/mp3asm/files/patch-src::utils.c b/audio/mp3asm/files/patch-src::utils.c
new file mode 100644
index 000000000000..a4be43497def
--- /dev/null
+++ b/audio/mp3asm/files/patch-src::utils.c
@@ -0,0 +1,10 @@
+--- src/utils.c.orig Fri Jul 20 11:14:59 2001
++++ src/utils.c Fri Jul 20 11:15:37 2001
+@@ -25,6 +25,7 @@
+ #include "utils.h"
+ #include <unistd.h>
+ #include <stdio.h>
++#include <errno.h>
+
+ /*
+ * tmalloc: mallocs cleanly
diff --git a/audio/mp3asm/pkg-comment b/audio/mp3asm/pkg-comment
new file mode 100644
index 000000000000..d7d1b2d22a00
--- /dev/null
+++ b/audio/mp3asm/pkg-comment
@@ -0,0 +1 @@
+MP3 frame level editor
diff --git a/audio/mp3asm/pkg-descr b/audio/mp3asm/pkg-descr
new file mode 100644
index 000000000000..738587cabc57
--- /dev/null
+++ b/audio/mp3asm/pkg-descr
@@ -0,0 +1,13 @@
+An mp3 frame level editor. Allows you to work with individual frames of an
+mp3 stream. Supports mpeg audio 1/2/2.5 layer 1,2,3 cbr/vbr.
+
+Feature:
+ - Removing bad frames and blips.
+ - Correcting certain errors in the stream.
+ - Working with individual frames, like one would with individual samples
+ in a wave editor
+ - Removing or adding of empty frames (for id3v2)
+ - Setting header flags, gain values
+ - ...
+
+WWW: http://mp3asm.sourceforge.net/
diff --git a/audio/mp3asm/pkg-plist b/audio/mp3asm/pkg-plist
new file mode 100644
index 000000000000..f30d2d76d074
--- /dev/null
+++ b/audio/mp3asm/pkg-plist
@@ -0,0 +1 @@
+bin/mp3asm