aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-08-14 16:21:30 +0000
committerSteve Wills <swills@FreeBSD.org>2011-08-14 16:21:30 +0000
commit358b9d259e5ea5ca3b4954ab60c88814c436e975 (patch)
treeed845c1fa63053dfc75a3784714201bdb97b315b
parentac7e0ee7ad0f6ad463387bd0bd1bde93fe573f89 (diff)
downloadports-358b9d259e5ea5ca3b4954ab60c88814c436e975.tar.gz
ports-358b9d259e5ea5ca3b4954ab60c88814c436e975.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-POE-Component-Hailo/Makefile29
-rw-r--r--devel/p5-POE-Component-Hailo/distinfo2
-rw-r--r--devel/p5-POE-Component-Hailo/files/patch-Makefile.PL.in16
-rw-r--r--devel/p5-POE-Component-Hailo/pkg-descr5
-rw-r--r--devel/p5-POE-Component-Hailo/pkg-plist7
6 files changed, 60 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e9560681b860..af00df0e3b2d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2082,6 +2082,7 @@
SUBDIR += p5-POE-Component-Daemon
SUBDIR += p5-POE-Component-DebugShell
SUBDIR += p5-POE-Component-DirWatch
+ SUBDIR += p5-POE-Component-Hailo
SUBDIR += p5-POE-Component-IKC
SUBDIR += p5-POE-Component-JobQueue
SUBDIR += p5-POE-Component-Logger
diff --git a/devel/p5-POE-Component-Hailo/Makefile b/devel/p5-POE-Component-Hailo/Makefile
new file mode 100644
index 000000000000..d8382d1ff24a
--- /dev/null
+++ b/devel/p5-POE-Component-Hailo/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: POE-Componenet-Hailo
+# Date created: 2011-07-19
+# Whom: milki <milki@rescomp.berkeley.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Hailo
+PORTVERSION= 0.10
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:HINRIK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= milki@rescomp.berkeley.edu
+COMMENT= A non-blocking wrapper around Hailo
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-Hailo>=0:${PORTSDIR}/textproc/p5-Hailo
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Hailo.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-POE-Component-Hailo/distinfo b/devel/p5-POE-Component-Hailo/distinfo
new file mode 100644
index 000000000000..c244fb24634c
--- /dev/null
+++ b/devel/p5-POE-Component-Hailo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (POE-Component-Hailo-0.10.tar.gz) = 2fb1a36b2bf4ed1b055be0427be95fad441f5c9bbc42dbc0f216d01d3f558edc
+SIZE (POE-Component-Hailo-0.10.tar.gz) = 12258
diff --git a/devel/p5-POE-Component-Hailo/files/patch-Makefile.PL.in b/devel/p5-POE-Component-Hailo/files/patch-Makefile.PL.in
new file mode 100644
index 000000000000..443861cf9f7b
--- /dev/null
+++ b/devel/p5-POE-Component-Hailo/files/patch-Makefile.PL.in
@@ -0,0 +1,16 @@
+--- Makefile.PL.new 2011-07-29 07:05:19.000000000 -0700
++++ Makefile.PL 2011-07-29 07:06:44.000000000 -0700
+@@ -48,5 +48,12 @@
+
+ WriteMakefile(%WriteMakefileArgs);
+
++package MY;
+
+-
++sub init_PM {
++ my $self = shift;
++ $self->SUPER::init_PM(@_);
++ # Do not install the README and README.pod
++ delete $self->{PM}{"README.pod"};
++ delete $self->{PM}{"README"};
++}
diff --git a/devel/p5-POE-Component-Hailo/pkg-descr b/devel/p5-POE-Component-Hailo/pkg-descr
new file mode 100644
index 000000000000..b5c882c113ca
--- /dev/null
+++ b/devel/p5-POE-Component-Hailo/pkg-descr
@@ -0,0 +1,5 @@
+POE::Component::Hailo is a POE component that provides a non-blocking wrapper
+around Hailo. It accepts the events listed under "INPUT" and emits the events
+listed under "OUTPUT".
+
+WWW: http://search.cpan.org/dist/POE-Component-Hailo/
diff --git a/devel/p5-POE-Component-Hailo/pkg-plist b/devel/p5-POE-Component-Hailo/pkg-plist
new file mode 100644
index 000000000000..6103a50d4c93
--- /dev/null
+++ b/devel/p5-POE-Component-Hailo/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/POE/Component/Hailo.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Hailo/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Hailo
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/POE/Component
+@dirrmtry %%SITE_PERL%%/POE