aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2004-05-02 19:12:23 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2004-05-02 19:12:23 +0000
commit3718d819cf8717d981484f085926d309801e526c (patch)
tree1299124b82dfa91a37ef3e4e211adf97ea149ee4
parent98acb6f8656c6a1e17fa37c01103f9230ce3e55f (diff)
downloadports-3718d819cf8717d981484f085926d309801e526c.tar.gz
ports-3718d819cf8717d981484f085926d309801e526c.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/sixxs-heartbeatd/Makefile36
-rw-r--r--net/sixxs-heartbeatd/distinfo2
-rw-r--r--net/sixxs-heartbeatd/files/Makefile13
-rw-r--r--net/sixxs-heartbeatd/files/patch-client_heartbeat-client.c14
-rw-r--r--net/sixxs-heartbeatd/files/patch-client_heartbeat.conf28
-rw-r--r--net/sixxs-heartbeatd/files/sixxs-heartbeatd.sh29
-rw-r--r--net/sixxs-heartbeatd/pkg-descr4
-rw-r--r--net/sixxs-heartbeatd/pkg-plist8
9 files changed, 135 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 034c9e335bdb..a96f69c9df2a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -600,6 +600,7 @@
SUBDIR += silky
SUBDIR += simicq
SUBDIR += sipsak
+ SUBDIR += sixxs-heartbeatd
SUBDIR += slirp
SUBDIR += slurm
SUBDIR += smbfs
diff --git a/net/sixxs-heartbeatd/Makefile b/net/sixxs-heartbeatd/Makefile
new file mode 100644
index 000000000000..263930a553cc
--- /dev/null
+++ b/net/sixxs-heartbeatd/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: sixxs-heartbeatd
+# Date created: 2004-04-23
+# Whom: Christian Weisgerber <naddy@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sixxs-heartbeatd
+PORTVERSION= 20031026
+CATEGORIES= net ipv6
+MASTER_SITES= http://www.sixxs.net/archive/sixxs/heartbeat/unix/
+DISTNAME= heartbeat-unix-2003-10-26
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= naddy@FreeBSD.org
+COMMENT= SixXS IPv6 tunnel broker heartbeat client
+
+USE_RC_SUBR= yes
+WRKSRC= ${WRKDIR}/heartbeat
+
+pre-build:
+ @${CP} ${FILESDIR}/Makefile ${WRKSRC}
+ @${SED} -e 's:%%PREFIX%%:${PREFIX}:g' \
+ -e 's:%%RC_SUBR%%:${RC_SUBR}:g' \
+ ${FILESDIR}/sixxs-heartbeatd.sh >${WRKDIR}/sixxs-heartbeatd.sh
+
+do-install:
+ @${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/client/heartbeat.conf ${EXAMPLESDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/sixxs-heartbeatd ${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/doc/draft-massar-v6ops-heartbeat-00.txt \
+ ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/README ${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/sixxs-heartbeatd.sh ${PREFIX}/etc/rc.d
+
+.include <bsd.port.mk>
diff --git a/net/sixxs-heartbeatd/distinfo b/net/sixxs-heartbeatd/distinfo
new file mode 100644
index 000000000000..799d119af920
--- /dev/null
+++ b/net/sixxs-heartbeatd/distinfo
@@ -0,0 +1,2 @@
+MD5 (heartbeat-unix-2003-10-26.tgz) = acd8354e0cfdf20a215d86abc44e2fdb
+SIZE (heartbeat-unix-2003-10-26.tgz) = 23786
diff --git a/net/sixxs-heartbeatd/files/Makefile b/net/sixxs-heartbeatd/files/Makefile
new file mode 100644
index 000000000000..1543d6d08524
--- /dev/null
+++ b/net/sixxs-heartbeatd/files/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+.PATH: client common
+
+PROG= sixxs-heartbeatd
+SRCS= heartbeat-client.c hb.c common.c
+
+DPADD= ${LIBMD}
+LDADD= -lmd
+
+NOMAN= yes
+
+.include <bsd.prog.mk>
diff --git a/net/sixxs-heartbeatd/files/patch-client_heartbeat-client.c b/net/sixxs-heartbeatd/files/patch-client_heartbeat-client.c
new file mode 100644
index 000000000000..c2bb49457685
--- /dev/null
+++ b/net/sixxs-heartbeatd/files/patch-client_heartbeat-client.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- client/heartbeat-client.c.orig Fri Apr 23 22:00:57 2004
++++ client/heartbeat-client.c Fri Apr 23 22:01:14 2004
+@@ -277,7 +277,7 @@
+ if (argc != 2)
+ {
+ fprintf(stderr,
+- "heartbeat-client <configfile>\n");
++ "sixxs-heartbeatd <configfile>\n");
+ return -1;
+ }
+
diff --git a/net/sixxs-heartbeatd/files/patch-client_heartbeat.conf b/net/sixxs-heartbeatd/files/patch-client_heartbeat.conf
new file mode 100644
index 000000000000..5721ca966fe0
--- /dev/null
+++ b/net/sixxs-heartbeatd/files/patch-client_heartbeat.conf
@@ -0,0 +1,28 @@
+
+$FreeBSD$
+
+--- client/heartbeat.conf.orig Fri Apr 23 22:02:02 2004
++++ client/heartbeat.conf Fri Apr 23 22:02:31 2004
+@@ -12,11 +12,11 @@
+ # os 'linux'
+
+ # Operating System (linux/freebsd/openbsd/netbsd/winxp)
+-os "linux"
++os "freebsd"
+
+ # Interface the tunnel should go over
+ # used for detecting the local IPv4 endpoint
+-ipv4_interface "eth0"
++ipv4_interface "tun0"
+
+ # IPv4 address of the POP (nlams01/nlams02/nlams04/demun01/iedub01/dkcop01)
+ # This is also the address to where heartbeats are sent
+@@ -39,7 +39,7 @@
+
+ # Interface to be used for the tunnel
+ # will be created on the OS's that need that
+-ipv6_interface "sixxs"
++ipv6_interface "gif0"
+
+ # The local and remote sides of the tunnel
+ ipv6_pop "2001:db8::1"
diff --git a/net/sixxs-heartbeatd/files/sixxs-heartbeatd.sh b/net/sixxs-heartbeatd/files/sixxs-heartbeatd.sh
new file mode 100644
index 000000000000..4d3c29ba95db
--- /dev/null
+++ b/net/sixxs-heartbeatd/files/sixxs-heartbeatd.sh
@@ -0,0 +1,29 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: sixxs-heartbeatd
+# REQUIRE: NETWORKING
+# KEYWORD: FreeBSD
+
+#
+# Add the following lines to /etc/rc.conf to enable sixxs-heartbeatd:
+#
+#sixxs_heartbeatd_enable="YES"
+#
+
+. %%RC_SUBR%%
+
+name=sixxs_heartbeatd
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/sixxs-heartbeatd
+command_args=%%PREFIX%%/etc/heartbeat.conf
+required_files=%%PREFIX%%/etc/heartbeat.conf
+
+# set default
+sixxs_heartbeatd_enable=${sixxs_heartbeatd_enable:-"NO"}
+
+load_rc_config ${name}
+run_rc_command "$1"
diff --git a/net/sixxs-heartbeatd/pkg-descr b/net/sixxs-heartbeatd/pkg-descr
new file mode 100644
index 000000000000..8c127b7059bc
--- /dev/null
+++ b/net/sixxs-heartbeatd/pkg-descr
@@ -0,0 +1,4 @@
+This is the heartbeart client for the public dynamic-IPv4
+IPv6 tunnel beta test from the SixXS tunnel service provider.
+
+WWW: http://www.sixxs.net/tools/heartbeat/
diff --git a/net/sixxs-heartbeatd/pkg-plist b/net/sixxs-heartbeatd/pkg-plist
new file mode 100644
index 000000000000..70ceb11c1006
--- /dev/null
+++ b/net/sixxs-heartbeatd/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+etc/rc.d/sixxs-heartbeatd.sh
+sbin/sixxs-heartbeatd
+%%DOCSDIR%%/README
+%%DOCSDIR%%/draft-massar-v6ops-heartbeat-00.txt
+%%EXAMPLESDIR%%/heartbeat.conf
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%DOCSDIR%%