aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-07-26 20:16:11 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-07-26 20:16:11 +0000
commit373fe72e76809a1494d016026d445cf548a50178 (patch)
tree11c012ddfa8df895b35e23c9bb3aa26a6a25cecb
parentf72b2ac08095124e41ea662c3f79eded0d35d4b3 (diff)
downloadports-373fe72e76809a1494d016026d445cf548a50178.tar.gz
ports-373fe72e76809a1494d016026d445cf548a50178.zip
Notes
-rw-r--r--cad/alliance/Makefile6
-rw-r--r--cad/alliance/files/patch-nero_src_MDRGrid.cpp21
2 files changed, 24 insertions, 3 deletions
diff --git a/cad/alliance/Makefile b/cad/alliance/Makefile
index fb5466edc10d..67d5001890a9 100644
--- a/cad/alliance/Makefile
+++ b/cad/alliance/Makefile
@@ -22,9 +22,8 @@ BROKEN_aarch64= fails to link: collect2: error: ld returned 1 exit status
BUILD_DEPENDS= convert:graphics/ImageMagick7 \
fig2dev:print/transfig
-USES= autoreconf:build compiler:c++0x gmake libtool motif \
- tar:bz2 xorg
-USE_GCC= any
+USES= autoreconf:build gmake libtool motif tar:bz2 xorg
+USE_GCC= yes
USE_TEX= dvipsk:build latex:build
USE_XORG= ice sm x11 xext xt
@@ -35,6 +34,7 @@ CONFIGURE_ARGS+=--mandir=${MANPREFIX}/man \
MAKE_JOBS_UNSAFE= yes
INSTALL_TARGET= install-strip
+CFLAGS+= -fcommon
CONFLICTS_INSTALL= fspclient-*
diff --git a/cad/alliance/files/patch-nero_src_MDRGrid.cpp b/cad/alliance/files/patch-nero_src_MDRGrid.cpp
new file mode 100644
index 000000000000..80868b12e0d2
--- /dev/null
+++ b/cad/alliance/files/patch-nero_src_MDRGrid.cpp
@@ -0,0 +1,21 @@
+/usr/local/bin/ld: ./libU.a(MPri.o): in function `CMatrixPri::findfree(int, CNet&)':
+src/nero/src/MPri.cpp:78: undefined reference to `TMatrix<char>::operator[](int)'
+/usr/local/bin/ld: src/nero/src/MPri.cpp:79: undefined reference to `TMatrix<char>::operator[](int)'
+/usr/local/bin/ld: ./libU.a(MPri.o): in function `CMatrixPri::take(int, int)':
+src/nero/src/MPri.cpp:284: undefined reference to `TMatrix<char>::operator[](int)'
+/usr/local/bin/ld: ./libU.a(MPri.o): in function `operator<<(std::ostream&, CMatrixPri&)':
+src/nero/src/MPri.cpp:317: undefined reference to `TMatrix<char>::operator[](int)'
+/usr/local/bin/ld: ./libU.a(MPri.o): in function `CMatrixPri::load(CNet&, bool, int)':
+src/nero/src/MPri.cpp:175: undefined reference to `TMatrix<char>::operator[](int)'
+/usr/local/bin/ld: ./libU.a(MPri.o):src/nero/src/MPri.cpp:186: more undefined references to `TMatrix<char>::operator[](int)' follow
+
+--- nero/src/MDRGrid.cpp.orig 2014-08-02 23:38:00 UTC
++++ nero/src/MDRGrid.cpp
+@@ -17,6 +17,7 @@
+
+
+ # include "MDefs.h"
++template class TMatrix<char>;
+
+
+