aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2018-06-24 04:06:02 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2018-06-24 04:06:02 +0000
commit376c305df48a8c1e41aeb5738194c28f29a4be83 (patch)
treead62127d39767383553bb633d28b7699f4a17f04
parentf57ce64a3a188d95625c7c7c96a51ec4dfeda958 (diff)
downloadports-376c305df48a8c1e41aeb5738194c28f29a4be83.tar.gz
ports-376c305df48a8c1e41aeb5738194c28f29a4be83.zip
Notes
-rw-r--r--audio/mp3blaster/Makefile3
-rw-r--r--audio/mp3blaster/files/patch-mpegsound_huffmantable.cc75
2 files changed, 75 insertions, 3 deletions
diff --git a/audio/mp3blaster/Makefile b/audio/mp3blaster/Makefile
index 0b473ef17a2f..d67e2551d68f 100644
--- a/audio/mp3blaster/Makefile
+++ b/audio/mp3blaster/Makefile
@@ -13,11 +13,8 @@ COMMENT= MP3 console ncurses-based player
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to configure: checking for main in -lm... no
-
USES= gmake localbase:ldflags ncurses
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -Wno-narrowing"
OPTIONS_DEFINE= DOCS ESOUND LIRC NAS SDL SIDPLAY VORBIS
OPTIONS_DEFAULT= SIDPLAY VORBIS
diff --git a/audio/mp3blaster/files/patch-mpegsound_huffmantable.cc b/audio/mp3blaster/files/patch-mpegsound_huffmantable.cc
new file mode 100644
index 000000000000..ba7e24820d6e
--- /dev/null
+++ b/audio/mp3blaster/files/patch-mpegsound_huffmantable.cc
@@ -0,0 +1,75 @@
+--- mpegsound/huffmantable.cc.orig 2018-06-23 16:00:52 UTC
++++ mpegsound/huffmantable.cc
+@@ -550,38 +550,38 @@ htd33[ 31][2]={{ 16, 1},{ 8, 1},{ 4, 1},{ 2, 1}
+
+ const HUFFMANCODETABLE Mpegtoraw::ht[HTN]=
+ {
+- { 0, 0-1, 0-1, 0, 0, htd33},
+- { 1, 2-1, 2-1, 0, 7,htd01},
+- { 2, 3-1, 3-1, 0, 17,htd02},
+- { 3, 3-1, 3-1, 0, 17,htd03},
+- { 4, 0-1, 0-1, 0, 0, htd33},
+- { 5, 4-1, 4-1, 0, 31,htd05},
+- { 6, 4-1, 4-1, 0, 31,htd06},
+- { 7, 6-1, 6-1, 0, 71,htd07},
+- { 8, 6-1, 6-1, 0, 71,htd08},
+- { 9, 6-1, 6-1, 0, 71,htd09},
+- {10, 8-1, 8-1, 0,127,htd10},
+- {11, 8-1, 8-1, 0,127,htd11},
+- {12, 8-1, 8-1, 0,127,htd12},
+- {13,16-1,16-1, 0,511,htd13},
+- {14, 0-1, 0-1, 0, 0, htd33},
+- {15,16-1,16-1, 0,511,htd15},
+- {16,16-1,16-1, 1,511,htd16},
+- {17,16-1,16-1, 2,511,htd16},
+- {18,16-1,16-1, 3,511,htd16},
+- {19,16-1,16-1, 4,511,htd16},
+- {20,16-1,16-1, 6,511,htd16},
+- {21,16-1,16-1, 8,511,htd16},
+- {22,16-1,16-1,10,511,htd16},
+- {23,16-1,16-1,13,511,htd16},
+- {24,16-1,16-1, 4,512,htd24},
+- {25,16-1,16-1, 5,512,htd24},
+- {26,16-1,16-1, 6,512,htd24},
+- {27,16-1,16-1, 7,512,htd24},
+- {28,16-1,16-1, 8,512,htd24},
+- {29,16-1,16-1, 9,512,htd24},
+- {30,16-1,16-1,11,512,htd24},
+- {31,16-1,16-1,13,512,htd24},
+- {32, 1-1,16-1, 0, 31,htd32},
+- {33, 1-1,16-1, 0, 31,htd33}
++ { 0, 0-1U, 0-1U, 0, 0, htd33},
++ { 1, 2-1U, 2-1U, 0, 7,htd01},
++ { 2, 3-1U, 3-1U, 0, 17,htd02},
++ { 3, 3-1U, 3-1U, 0, 17,htd03},
++ { 4, 0-1U, 0-1U, 0, 0, htd33},
++ { 5, 4-1U, 4-1U, 0, 31,htd05},
++ { 6, 4-1U, 4-1U, 0, 31,htd06},
++ { 7, 6-1U, 6-1U, 0, 71,htd07},
++ { 8, 6-1U, 6-1U, 0, 71,htd08},
++ { 9, 6-1U, 6-1U, 0, 71,htd09},
++ {10, 8-1U, 8-1U, 0,127,htd10},
++ {11, 8-1U, 8-1U, 0,127,htd11},
++ {12, 8-1U, 8-1U, 0,127,htd12},
++ {13,16-1U,16-1U, 0,511,htd13},
++ {14, 0-1U, 0-1U, 0, 0, htd33},
++ {15,16-1U,16-1U, 0,511,htd15},
++ {16,16-1U,16-1U, 1,511,htd16},
++ {17,16-1U,16-1U, 2,511,htd16},
++ {18,16-1U,16-1U, 3,511,htd16},
++ {19,16-1U,16-1U, 4,511,htd16},
++ {20,16-1U,16-1U, 6,511,htd16},
++ {21,16-1U,16-1U, 8,511,htd16},
++ {22,16-1U,16-1U,10,511,htd16},
++ {23,16-1U,16-1U,13,511,htd16},
++ {24,16-1U,16-1U, 4,512,htd24},
++ {25,16-1U,16-1U, 5,512,htd24},
++ {26,16-1U,16-1U, 6,512,htd24},
++ {27,16-1U,16-1U, 7,512,htd24},
++ {28,16-1U,16-1U, 8,512,htd24},
++ {29,16-1U,16-1U, 9,512,htd24},
++ {30,16-1U,16-1U,11,512,htd24},
++ {31,16-1U,16-1U,13,512,htd24},
++ {32, 1-1U,16-1U, 0, 31,htd32},
++ {33, 1-1U,16-1U, 0, 31,htd33}
+ };