aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-07-21 04:05:24 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-07-21 04:05:24 +0000
commit37f3126279c26b3d7eead2182786b2720af03872 (patch)
tree59c4de1ac7cc13946edd71da8332d2ea4f31221a
parent3bb4f9146bc20a26aa93ed22fc7c893e3eb7d784 (diff)
downloadports-37f3126279c26b3d7eead2182786b2720af03872.tar.gz
ports-37f3126279c26b3d7eead2182786b2720af03872.zip
Notes
-rw-r--r--editors/abiword-devel/Makefile6
-rw-r--r--editors/abiword-devel/distinfo4
-rw-r--r--editors/abiword-devel/files/patch-GNUmakefile.in10
-rw-r--r--editors/abiword-devel/files/patch-src_af_util_xp_ut_iconv.cpp8
-rw-r--r--editors/abiword-devel/files/patch-src_wp_main_unix_GNUmakefile.in6
-rw-r--r--editors/abiword-devel/pkg-plist2
-rw-r--r--editors/abiword-plugins-devel/Makefile6
7 files changed, 26 insertions, 16 deletions
diff --git a/editors/abiword-devel/Makefile b/editors/abiword-devel/Makefile
index e5e67afbd4c4..12543645b8bc 100644
--- a/editors/abiword-devel/Makefile
+++ b/editors/abiword-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= abiword
-PORTVERSION= 2.3.2
+PORTVERSION= 2.3.4
CATEGORIES= editors
MASTER_SITES= http://www.abisource.com/downloads/%SUBDIR%/${PORTVERSION}/source/
MASTER_SITE_SUBDIR= abiword
@@ -46,6 +46,10 @@ ABIVERSION= 2.4
PLIST_SUB+= ABIVERSION=${ABIVERSION}
WRKSRC= ${WRKDIR}/abiword-${PORTVERSION}/abi
+EXTERNALS= MSVC* abipbx abiword-docs abiword-plugins expat fribidi \
+ libiconv libpng pbx popt wv zlib
+EXTRACT_AFTER_ARGS=| ${TAR} -xpf - ${EXTERNALS:C,^,--exclude ${DISTNAME}/,}
+
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug \
--enable-symbols
diff --git a/editors/abiword-devel/distinfo b/editors/abiword-devel/distinfo
index ff80b28e15f3..16eb5fdec2a5 100644
--- a/editors/abiword-devel/distinfo
+++ b/editors/abiword-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (AbiWord/abiword-2.3.2.tar.bz2) = 58fb70904f19ee911b7ae604cafdc3a4
-SIZE (AbiWord/abiword-2.3.2.tar.bz2) = 24241570
+MD5 (AbiWord/abiword-2.3.4.tar.bz2) = b205d8bb5240fdcb126daf8a7a9e45c8
+SIZE (AbiWord/abiword-2.3.4.tar.bz2) = 24120509
diff --git a/editors/abiword-devel/files/patch-GNUmakefile.in b/editors/abiword-devel/files/patch-GNUmakefile.in
index d3b652ea1edf..6385aea4d9af 100644
--- a/editors/abiword-devel/files/patch-GNUmakefile.in
+++ b/editors/abiword-devel/files/patch-GNUmakefile.in
@@ -1,6 +1,6 @@
---- GNUmakefile.in.orig Sun Jun 12 16:03:48 2005
-+++ GNUmakefile.in Sun Jun 12 16:04:57 2005
-@@ -326,15 +326,15 @@
+--- GNUmakefile.in.orig Wed Jul 20 22:21:46 2005
++++ GNUmakefile.in Wed Jul 20 22:23:12 2005
+@@ -337,15 +337,15 @@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
SUBDIRS = src
@@ -25,7 +25,7 @@
@BIGENDIAN_FALSE@dictionary = $(top_srcdir)/../abidistfiles/dictionary/LittleEndian32.american.hash
@BIGENDIAN_TRUE@dictionary = $(top_srcdir)/../abidistfiles/dictionary/BigEndian32.american.hash
@WITH_ISPELL_FALSE@INSTALLDICTIONARY = no
-@@ -829,7 +829,6 @@
+@@ -844,7 +844,6 @@
# Install the datafiles. This is quick-and-dirty.
install-data-local:
@@ -33,7 +33,7 @@
if test -d $(top_srcdir)/../abidistfiles ; then \
for dir in `cd $(top_srcdir)/../abidistfiles; find . -type d ! -name CVS` ; do \
$(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/$$dir ;\
-@@ -842,11 +841,7 @@
+@@ -857,11 +856,7 @@
for file in `echo $(top_srcdir)/../abidistfiles/$$dir/* | grep -v MANIFEST`; do \
if test -f $$file ; then \
sfile=`echo "$$file" | sed 's/\.[^.]*$$//'`; \
diff --git a/editors/abiword-devel/files/patch-src_af_util_xp_ut_iconv.cpp b/editors/abiword-devel/files/patch-src_af_util_xp_ut_iconv.cpp
index dd1f65d7282b..d892f8e3334f 100644
--- a/editors/abiword-devel/files/patch-src_af_util_xp_ut_iconv.cpp
+++ b/editors/abiword-devel/files/patch-src_af_util_xp_ut_iconv.cpp
@@ -1,11 +1,11 @@
---- src/af/util/xp/ut_iconv.cpp.orig Fri Jan 2 16:00:33 2004
-+++ src/af/util/xp/ut_iconv.cpp Fri Jan 2 16:08:03 2004
+--- src/af/util/xp/ut_iconv.cpp.orig Wed Jul 20 22:24:55 2005
++++ src/af/util/xp/ut_iconv.cpp Wed Jul 20 22:25:23 2005
@@ -67,7 +67,7 @@
#if defined (WIN32) || defined(__QNXNTO__) || defined(__CYGWIN__) || \
(defined (__MACH__) && defined (__APPLE__)) || \
(defined(TARGET_OS_MAC) && TARGET_OS_MAC) || \
--defined(__BEOS__) || defined (__AIX__) || \
-+defined(__BEOS__) || defined (__AIX__) || defined (__FreeBSD__) || \
+-defined (__AIX__) || \
++defined (__AIX__) || defined (__FreeBSD__) || \
(defined(__linux__) && defined(__powerpc__) && (__GLIBC__ <= 2) && (__GLIBC_MINOR__ <= 1))
#define ICONV_CONST const
diff --git a/editors/abiword-devel/files/patch-src_wp_main_unix_GNUmakefile.in b/editors/abiword-devel/files/patch-src_wp_main_unix_GNUmakefile.in
index dffefdd47235..4e85950f8c44 100644
--- a/editors/abiword-devel/files/patch-src_wp_main_unix_GNUmakefile.in
+++ b/editors/abiword-devel/files/patch-src_wp_main_unix_GNUmakefile.in
@@ -1,6 +1,6 @@
---- src/wp/main/unix/GNUmakefile.in.orig Sun Jun 12 16:12:49 2005
-+++ src/wp/main/unix/GNUmakefile.in Sun Jun 12 16:13:12 2005
-@@ -735,8 +735,6 @@
+--- src/wp/main/unix/GNUmakefile.in.orig Wed Jul 20 22:27:50 2005
++++ src/wp/main/unix/GNUmakefile.in Wed Jul 20 22:28:01 2005
+@@ -760,8 +760,6 @@
install-exec-local:
@if test -f $(DESTDIR)/$(bindir)/abiword; then \
echo "$(DESTDIR)/$(bindir)/abiword is a regular file - I'm not going to create a link."; \
diff --git a/editors/abiword-devel/pkg-plist b/editors/abiword-devel/pkg-plist
index 2a792dbbbbd7..4c98f86c3653 100644
--- a/editors/abiword-devel/pkg-plist
+++ b/editors/abiword-devel/pkg-plist
@@ -8,12 +8,14 @@ share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_FormatFrame.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_FormatTOC.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_FormatTable.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_Goto.glade
+share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_HdrFtr.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_InsertTable.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_Insert_DateTime.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_Latex.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_MailMerge.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_MetaData.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_New.glade
+share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_Options.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_Options_ColorSel.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_PageNumbers.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_PageSetup.glade
diff --git a/editors/abiword-plugins-devel/Makefile b/editors/abiword-plugins-devel/Makefile
index 6a2a130aecf1..81f58a794f90 100644
--- a/editors/abiword-plugins-devel/Makefile
+++ b/editors/abiword-plugins-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= abiword
-PORTVERSION= 2.3.2
+PORTVERSION= 2.3.4
CATEGORIES= editors
MASTER_SITES= http://www.abisource.com/downloads/%SUBDIR%/${PORTVERSION}/source/
MASTER_SITE_SUBDIR= abiword
@@ -37,6 +37,10 @@ MD5_FILE= ${.CURDIR}/../abiword-devel/distinfo
ABIVERSION= 2.4
PLIST_SUB+= ABIVERSION=${ABIVERSION}
+EXTERNALS= MSVC* abipbx abiword-docs expat fribidi libiconv libpng pbx \
+ popt wv zlib
+EXTRACT_AFTER_ARGS=| ${TAR} -xpf - ${EXTERNALS:C,^,--exclude ${DISTNAME}/,}
+
# NOTE: Please, keep those knobs in the ABC's order.
.if defined(WITH_AIKSAURUS) || defined(PACKAGE_BUILDING)