aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2017-05-22 09:15:22 +0000
committerMichael Landin <mich@FreeBSD.org>2017-05-22 09:15:22 +0000
commit391513e13f6626d4ca1fb15a8d489e483ed5be5b (patch)
tree6f404e545648386f0e9e721d5e1564ae4d43b9f4
parent7cad5c9ba574092f311f225c527268fcd2d2d061 (diff)
Notes
-rw-r--r--net-mgmt/cdpr/Makefile7
-rw-r--r--net-mgmt/cdpr/distinfo5
-rw-r--r--net-mgmt/cdpr/files/patch-cdpr.c36
-rw-r--r--net-mgmt/cdpr/files/patch-conffile.c19
4 files changed, 8 insertions, 59 deletions
diff --git a/net-mgmt/cdpr/Makefile b/net-mgmt/cdpr/Makefile
index 0596578becbb..f7b151f24445 100644
--- a/net-mgmt/cdpr/Makefile
+++ b/net-mgmt/cdpr/Makefile
@@ -2,14 +2,17 @@
# $FreeBSD$
PORTNAME= cdpr
-PORTVERSION= 2.2.1
+PORTVERSION= 2.4
CATEGORIES= net-mgmt
MASTER_SITES= SF
MAINTAINER= mich@FreeBSD.org
COMMENT= Cisco Discovery Protocol Reporter
-USES= dos2unix
+LICENSE= GPLv2
+
+USES= dos2unix
+USES= tar:tgz
DOS2UNIX_GLOB= *.c *.h
LDFLAGS+= -L${LOCALBASE}/lib -lpcap
diff --git a/net-mgmt/cdpr/distinfo b/net-mgmt/cdpr/distinfo
index 09ddb836acdb..8aa39e20b5d8 100644
--- a/net-mgmt/cdpr/distinfo
+++ b/net-mgmt/cdpr/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cdpr-2.2.1.tar.gz) = cb17ea99ec80d940fae54ea5ce14626df1062e7d91c8c886cdd518963bfe7abf
-SIZE (cdpr-2.2.1.tar.gz) = 25050
+TIMESTAMP = 1495443918
+SHA256 (cdpr-2.4.tgz) = 32d3b58d8be7e2f78834469bd5f48546450ccc2a86d513177311cce994dfbec5
+SIZE (cdpr-2.4.tgz) = 26053
diff --git a/net-mgmt/cdpr/files/patch-cdpr.c b/net-mgmt/cdpr/files/patch-cdpr.c
deleted file mode 100644
index 3a83c518fad5..000000000000
--- a/net-mgmt/cdpr/files/patch-cdpr.c
+++ /dev/null
@@ -1,36 +0,0 @@
---- cdpr.c.orig 2016-06-20 14:44:21 UTC
-+++ cdpr.c
-@@ -641,7 +641,7 @@ main(int argc, char *argv[])
- pcap_lookupnet(dev, &net, &mask, errbuf);
-
- /* Open the pcap device */
-- if((handle = pcap_open_live(dev, BUFSIZ, 1, 0, errbuf)) == NULL)
-+ if((handle = pcap_open_live(dev, BUFSIZ, 1, 1000, errbuf)) == NULL)
- {
- printf("Error opening device (%s)\n", errbuf);
- exit(1);
-@@ -658,11 +658,6 @@ main(int argc, char *argv[])
- pcap_setfilter(handle, &filter);
- pcap_freecode(&filter);
-
-- /* Set non-blocking mode */
-- if(pcap_setnonblock(handle, 1, errbuf))
-- {
-- pcap_perror(handle, NULL);
-- }
-
- /* Get the next packet that comes in, we only need one */
- printf("Waiting for CDP advertisement:\n");
-@@ -673,11 +668,7 @@ main(int argc, char *argv[])
- do
- {
- packet = pcap_next(handle, &header);
--#ifdef WIN32
-- Sleep(10000);
--#else
-- usleep(10000);
--#endif
-+
- } while ((!packet) && ( timeout=((start_time+seconds) > (unsigned int)time(NULL))) );
-
- /*
diff --git a/net-mgmt/cdpr/files/patch-conffile.c b/net-mgmt/cdpr/files/patch-conffile.c
deleted file mode 100644
index ef5a7d1191a4..000000000000
--- a/net-mgmt/cdpr/files/patch-conffile.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- conffile.c.orig 2016-06-20 14:44:21 UTC
-+++ conffile.c
-@@ -57,6 +57,7 @@ do_something_with (char *ip, char *url)
- struct hostent *h;
- char *addy;
- int port;
-+ char *tport;
-
- if (ip && url)
- {
-@@ -70,7 +71,7 @@ do_something_with (char *ip, char *url)
- else
- {
- strtok(ip,":");
-- char *tport = strtok(NULL,":");
-+ tport = strtok(NULL,":");
- port = atoi(tport);
- }
- /*