aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-01-01 02:11:18 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-01-01 02:11:18 +0000
commit39ab11c3c467bc540a432f7162e94ea3445c2e97 (patch)
treecfb094085bc9846518e1d557ccf0fd67942c4710
parent277c88757954efb2fbac18c69ff17a495f876506 (diff)
downloadports-39ab11c3c467bc540a432f7162e94ea3445c2e97.tar.gz
ports-39ab11c3c467bc540a432f7162e94ea3445c2e97.zip
Notes
-rw-r--r--graphics/autoq3d/Makefile31
-rw-r--r--graphics/autoq3d/pkg-descr3
2 files changed, 17 insertions, 17 deletions
diff --git a/graphics/autoq3d/Makefile b/graphics/autoq3d/Makefile
index 5f047a4c4b54..bcb567f78f13 100644
--- a/graphics/autoq3d/Makefile
+++ b/graphics/autoq3d/Makefile
@@ -14,34 +14,35 @@ COMMENT= Qt 4 quick 3D model editor
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
+USE_ZIP= yes
USES= dos2unix qmake
+DOS2UNIX_FILES= *.pro src/cmds/*.cpp src/fgui/*.cpp docs/*.txt
+DOS2UNIX_REGEX= .*.[^p][^n][^g]$
USE_GL= glu
-USE_ZIP= yes
USE_QT4= corelib gui opengl moc_build
PORTDOCS= 3DQformat.txt ChangeLog.txt
-DESKTOP_ENTRIES="AutoQ3D" \
- "${COMMENT}" \
- "AutoQ3D" \
- "AutoQ3D" \
- "Graphics;3DGraphics;Qt;" \
- true
+OPTIONS_DEFINE= DOCS
+
+DESKTOP_ENTRIES="AutoQ3D" "" "${PORTNAME}" \
+ "${PORTNAME}" "Graphics;3DGraphics;Qt;" ""
-.include <bsd.port.options.mk>
post-patch:
.for file in src/main.cpp src/fgui/cadform.cpp src/dialogs/prgsettings.cpp
- @${REINPLACE_CMD} -e \
- 's|/usr/share/AutoQ3D-Community|${DATADIR}|g' ${WRKSRC}/${file}
+ @${REINPLACE_CMD} \
+ -e 's|/usr/share/AutoQ3D-Community|${DATADIR}|g' \
+ ${WRKSRC}/${file}
.endfor
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/AutoQ3D ${STAGEDIR}${PREFIX}/bin
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} "images *.htm *.qm" ${STAGEDIR}${DATADIR})
- ${INSTALL_DATA} ${WRKSRC}/AutoQ3D.png ${STAGEDIR}${PREFIX}/share/pixmaps
-.if ${PORT_OPTIONS:MDOCS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/AutoQ3D ${STAGEDIR}${PREFIX}/bin/
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "images *.htm *.qm" \
+ ${STAGEDIR}${DATADIR})
+ ${INSTALL_DATA} ${WRKSRC}/AutoQ3D.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/graphics/autoq3d/pkg-descr b/graphics/autoq3d/pkg-descr
index d82a2eaa4712..b3bd5835aaee 100644
--- a/graphics/autoq3d/pkg-descr
+++ b/graphics/autoq3d/pkg-descr
@@ -1,5 +1,4 @@
AutoQ3D Community is the open source software project of
this 3D modeling application.
-WWW: http://www.autoq3d.com/
- http://sourceforge.net/projects/autoq3d/
+WWW: http://sourceforge.net/projects/autoq3d/