aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-10-09 15:32:37 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-10-09 15:37:59 +0000
commit3ae7a8b09484a2cc20361deb04caa54135082bb6 (patch)
treebbbb51e63670bd51edf60865fd68f66de30c97f1
parent264c923aa45a32a422d7a54a4133506ebaf45f10 (diff)
downloadports-3ae7a8b09484a2cc20361deb04caa54135082bb6.tar.gz
ports-3ae7a8b09484a2cc20361deb04caa54135082bb6.zip
-rw-r--r--textproc/py-sphinx-book-theme/Makefile3
-rw-r--r--textproc/py-sphinx-book-theme/distinfo6
-rw-r--r--textproc/py-sphinx-book-theme/files/setup.py5
-rw-r--r--textproc/py-sphinx-book-theme/pkg-plist74
4 files changed, 83 insertions, 5 deletions
diff --git a/textproc/py-sphinx-book-theme/Makefile b/textproc/py-sphinx-book-theme/Makefile
index 014e57af0217..b267fb212f02 100644
--- a/textproc/py-sphinx-book-theme/Makefile
+++ b/textproc/py-sphinx-book-theme/Makefile
@@ -1,5 +1,6 @@
PORTNAME= sphinx-book-theme
PORTVERSION= 0.3.3
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP \
LOCAL/sunpoet:static
@@ -28,6 +29,6 @@ post-patch:
@${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
post-install:
- cd ${WRKDIR}/static/ && ${COPYTREE_SHARE} . ${STAGEDIR}${PYTHON_SITELIBDIR}/sphinx_book_theme/theme/sphinx_book_theme/static/
+ cd ${WRKDIR}/static/ && ${COPYTREE_SHARE} . ${STAGEDIR}${PYTHON_SITELIBDIR}/sphinx_book_theme/
.include <bsd.port.mk>
diff --git a/textproc/py-sphinx-book-theme/distinfo b/textproc/py-sphinx-book-theme/distinfo
index 54d4abcf9199..775548cf1bbd 100644
--- a/textproc/py-sphinx-book-theme/distinfo
+++ b/textproc/py-sphinx-book-theme/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1664767996
+TIMESTAMP = 1665073160
SHA256 (sphinx_book_theme-0.3.3.tar.gz) = 0ec36208ff14c6d6bf8aee1f1f8268e0c6e2bfa3cef6e41143312b25275a6217
SIZE (sphinx_book_theme-0.3.3.tar.gz) = 273932
-SHA256 (sphinx_book_theme-0.3.3-static.tar.gz) = 575955c348b58775c92241c79e6baa5cdfd1f2cce8167c7f406bcb9823dfdacd
-SIZE (sphinx_book_theme-0.3.3-static.tar.gz) = 205312
+SHA256 (sphinx_book_theme-0.3.3-static.tar.gz) = 63258723a28d7b7450c9549ca559752f730ef4d6d8db3a0d81fe853b4606d539
+SIZE (sphinx_book_theme-0.3.3-static.tar.gz) = 412160
diff --git a/textproc/py-sphinx-book-theme/files/setup.py b/textproc/py-sphinx-book-theme/files/setup.py
index 1bfbf3e8f688..d39c8f31a7bc 100644
--- a/textproc/py-sphinx-book-theme/files/setup.py
+++ b/textproc/py-sphinx-book-theme/files/setup.py
@@ -7,7 +7,10 @@ setup(
maintainer = 'Chris Holdgraf',
maintainer_email = 'choldgraf@gmail.com',
url = None,
- packages = ['sphinx_book_theme'],
+ packages = [
+ 'sphinx_book_theme',
+ 'sphinx_book_theme.header_buttons',
+ ],
package_dir = {'': 'src'},
package_data = {'': ['*']},
install_requires = [
diff --git a/textproc/py-sphinx-book-theme/pkg-plist b/textproc/py-sphinx-book-theme/pkg-plist
index a8ba0d8fd501..90c247fad55e 100644
--- a/textproc/py-sphinx-book-theme/pkg-plist
+++ b/textproc/py-sphinx-book-theme/pkg-plist
@@ -1,3 +1,76 @@
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/scripts/index.js
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/abstracts/_mixins.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/abstracts/_variables.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/base/_base.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/base/_bootstrap.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/base/_print.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/base/_typography.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/components/_buttons.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/components/_search.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/content/_admonitions.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/content/_code.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/content/_field-lists.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/content/_footnotes.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/content/_glossary.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/content/_images.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/content/_margin.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/content/_math.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/content/_quotes.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/content/_sidebar.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/content/_tableofcontents.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/extensions/_ablog.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/extensions/_myst-nb.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/extensions/_readthedocs.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/extensions/_sphinx-tabs.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/extensions/_thebe.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/extensions/comments.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/index.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/pages/_search.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/sections/_article.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/sections/_footer-article.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/sections/_footer-content.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/sections/_header-article.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/sections/_headers.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/sections/_sidebar-primary.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/sections/_sidebar-secondary.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/styles/sections/_sidebars-toggle.scss
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/README.md
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/By the.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/By.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/Contents.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/Copyright.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/Download notebook file.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/Download source file.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/Download this page.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/Edit this page.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/Fullscreen mode.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/Last updated on.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/Launch.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/Open an issue.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/Print to PDF.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/Search the docs.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/Search this book.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/Source repository.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/Sphinx Book Theme.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/Theme by the.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/Toggle navigation.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/next page.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/open issue.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/previous page.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/repository.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/assets/translations/jsons/suggest edit.json
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/components/sbt-sidebar-nav.html
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/components/sidebar-logo.html
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/components/toc-button.html
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/layout.html
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/macros/buttons.html
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/sections/announcement.html
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/sections/footer-article.html
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/sections/footer-content.html
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/sections/header-article.html
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/sections/header.html
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/sections/sidebar.html
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/static/.gitignore
%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/static/images/logo_binder.svg
%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/static/images/logo_colab.png
%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/static/images/logo_deepnote.svg
@@ -51,3 +124,4 @@
%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/static/scripts/sphinx-book-theme.js
%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/static/scripts/sphinx-book-theme.js.map
%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/static/styles/sphinx-book-theme.css
+%%PYTHON_SITELIBDIR%%/sphinx_book_theme/theme/sphinx_book_theme/theme.conf