aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-07-17 15:12:55 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-07-17 15:12:55 +0000
commit3bb09a6bb5914ec1654c7ddeec297a8a13e91fdc (patch)
treeb56300ed30aa6ed80f4878c9ad9dac1af5bb32d4
parent992a13a9171dbdeaa75a2f0ae3ed9f4dc5f49191 (diff)
downloadports-3bb09a6bb5914ec1654c7ddeec297a8a13e91fdc.tar.gz
ports-3bb09a6bb5914ec1654c7ddeec297a8a13e91fdc.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/py-coherence/Makefile28
-rw-r--r--net/py-coherence/distinfo3
-rw-r--r--net/py-coherence/pkg-descr5
4 files changed, 37 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 6234f4e8c41b..4abf4785af29 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -946,6 +946,7 @@
SUBDIR += py-avahi
SUBDIR += py-beanstalkc
SUBDIR += py-cloudfiles
+ SUBDIR += py-coherence
SUBDIR += py-dpkt
SUBDIR += py-dugong
SUBDIR += py-ec2-cli-tools
diff --git a/net/py-coherence/Makefile b/net/py-coherence/Makefile
new file mode 100644
index 000000000000..8f8327f6b618
--- /dev/null
+++ b/net/py-coherence/Makefile
@@ -0,0 +1,28 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= Coherence
+PORTVERSION= 0.6.6.2
+CATEGORIES= net python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= DLNA/UPnP media server and framework for the digital living
+
+LICENSE= PD
+LICENSE_FILE= ${WRKSRC}/LICENCE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}configobj>=4.3:devel/py-configobj \
+ ${PYTHON_PKGNAMEPREFIX}twisted>8.2:devel/py-twisted \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface \
+ ${PYTHON_PKGNAMEPREFIX}Louie>0:devel/py-louie
+
+USE_GITHUB= yes
+GH_ACCOUNT= coherence-project
+GH_TAGNAME= 4d5ee5f
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net/py-coherence/distinfo b/net/py-coherence/distinfo
new file mode 100644
index 000000000000..76b0ad2e804d
--- /dev/null
+++ b/net/py-coherence/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1464287285
+SHA256 (coherence-project-Coherence-0.6.6.2-4d5ee5f_GH0.tar.gz) = 7e8cdca3cbba3585cf5819776d79dd43a13144e37f538808e9ac540703f3fe8d
+SIZE (coherence-project-Coherence-0.6.6.2-4d5ee5f_GH0.tar.gz) = 353670
diff --git a/net/py-coherence/pkg-descr b/net/py-coherence/pkg-descr
new file mode 100644
index 000000000000..8e49a8307ed2
--- /dev/null
+++ b/net/py-coherence/pkg-descr
@@ -0,0 +1,5 @@
+Coherence is a framework written in Python, providing a variety of UPnP
+MediaServer and UPnP MediaRenderer implementations for instant use.
+
+WWW: http://coherence-project.org
+WWW: https://pypi.python.org/pypi/Coherence