aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-01-26 19:51:15 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-01-26 19:51:15 +0000
commit3bca21b00e9c498994c273222ba7c530b1358b26 (patch)
tree7be154c49be7f937b3ee5f8c2c6054b942b76acc
parentef80786ca63b251e33d0eafc07c6bbd505f8d1bf (diff)
Notes
-rw-r--r--textproc/emacs-wiki/Makefile36
-rw-r--r--textproc/emacs-wiki/pkg-plist1
2 files changed, 13 insertions, 24 deletions
diff --git a/textproc/emacs-wiki/Makefile b/textproc/emacs-wiki/Makefile
index 0d2b57e3a80a..8e1d51dc5ca5 100644
--- a/textproc/emacs-wiki/Makefile
+++ b/textproc/emacs-wiki/Makefile
@@ -15,45 +15,35 @@ COMMENT= Create and use hyperlinks and simple formatting in plain text files
USE_EMACS= yes
EMACS_PORT_NAME?= emacs21
+OPTIONS_DEFINE= CONTRIB
+CONTRIB_DESC= Install extra packages. This can shadow versions already there.
+OPTIONS_SUB= yes
+
.if ${EMACS_PORT_NAME} != "emacs21"
PORTNAMESUFFIX= ${PKGNAMESUFFIX}
.endif
-RUN_DEPENDS+= ${PREFIX}/${EMACS_SITE_LISPDIR}/xml-parse.el:${PORTSDIR}/textproc/xml-parse.el
-RUN_DEPENDS+= ${PREFIX}/${EMACS_SITE_LISPDIR}/htmlize.el:${PORTSDIR}/textproc/htmlize.el
-
-.if defined(WITH_CONTRIB)
-PLIST_SUB+= CONTRIB=""
-.else
-PLIST_SUB+= CONTRIB="@comment "
-.endif
+RUN_DEPENDS+= ${LOCALBASE}/${EMACS_SITE_LISPDIR}/xml-parse.el:${PORTSDIR}/textproc/xml-parse.el
+RUN_DEPENDS+= ${LOCALBASE}/${EMACS_SITE_LISPDIR}/htmlize.el:${PORTSDIR}/textproc/htmlize.el
INFO= emacs-wiki
LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
-NO_STAGE= yes
-pre-everything::
-.if !defined(WITH_CONTRIB)
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You may want to build with WITH_CONTRIB=yes"
- @${ECHO_MSG} "to install some extra packages. Note this may"
- @${ECHO_MSG} "shadow the versions you already installed elsewhere."
- @${ECHO_MSG} ""
-.endif
+.include <bsd.port.options.mk>
do-build:
cd ${WRKSRC}; makeinfo --no-split emacs-wiki.texi
do-install:
- ${MKDIR} ${LISPDIR}
+ ${MKDIR} ${STAGEDIR}${LISPDIR}
.for i in *.el
- ${INSTALL_DATA} ${WRKSRC}/${i} ${LISPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${LISPDIR}
.endfor
- ${INSTALL_DATA} ${WRKSRC}/emacs-wiki.info ${PREFIX}/info
-.if defined(WITH_CONTRIB)
- ${MKDIR} ${LISPDIR}/contrib
+ ${INSTALL_DATA} ${WRKSRC}/emacs-wiki.info ${STAGEDIR}${PREFIX}/info
+.if ${PORT_OPTIONS:MCONTRIB}
+ ${MKDIR} ${STAGEDIR}${LISPDIR}/contrib
.for i in *.el
- ${INSTALL_DATA} ${WRKSRC}/contrib/${i} ${LISPDIR}/contrib
+ ${INSTALL_DATA} ${WRKSRC}/contrib/${i} ${STAGEDIR}${LISPDIR}/contrib
.endfor
.endif
diff --git a/textproc/emacs-wiki/pkg-plist b/textproc/emacs-wiki/pkg-plist
index 87cd8805f4b2..8de90feca0d2 100644
--- a/textproc/emacs-wiki/pkg-plist
+++ b/textproc/emacs-wiki/pkg-plist
@@ -15,7 +15,6 @@
%%CONTRIB%%%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/contrib/cgi.el
%%CONTRIB%%%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/contrib/htmlize.el
%%CONTRIB%%%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/contrib/httpd.el
-%%CONTRIB%%%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/contrib/pcomplete.el
%%CONTRIB%%%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/contrib/table.el
%%CONTRIB%%%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/contrib/update-remote.el
%%CONTRIB%%@dirrm %%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/contrib