aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2018-05-21 20:00:48 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2018-05-21 20:00:48 +0000
commit3c652549d38450e0f34388d7226c9273e3a90f23 (patch)
tree35f31ba27cdbc23965e31c22fc333e4818c7268a
parentfeaf078ddbf004eeeac02a464424532302cd90d7 (diff)
downloadports-3c652549d38450e0f34388d7226c9273e3a90f23.tar.gz
ports-3c652549d38450e0f34388d7226c9273e3a90f23.zip
Notes
-rw-r--r--audio/cpp-xmms2/Makefile5
-rw-r--r--audio/p5-xmms2/Makefile6
-rw-r--r--audio/py-xmms2/Makefile6
-rw-r--r--audio/xmms2/Makefile5
4 files changed, 15 insertions, 7 deletions
diff --git a/audio/cpp-xmms2/Makefile b/audio/cpp-xmms2/Makefile
index bffd15f69988..4f37a57d9c9e 100644
--- a/audio/cpp-xmms2/Makefile
+++ b/audio/cpp-xmms2/Makefile
@@ -1,7 +1,7 @@
# Created by: Alexander Botero-Lowry <alex@foxybanana.com>
# $FreeBSD$
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= audio
PKGNAMEPREFIX= cpp-
@@ -12,9 +12,12 @@ LIB_DEPENDS+= libboost_signals.so:devel/boost-libs \
libxmmsclient.so:audio/xmms2
MASTERDIR= ${.CURDIR}/../xmms2
+USES= ssl
USE_LDCONFIG= yes
USE_GNOME= glib20
+BROKEN_SSL= openssl-devel
+
PLIST= ${.CURDIR}/pkg-plist
XMMS2_SLAVE= cpp
diff --git a/audio/p5-xmms2/Makefile b/audio/p5-xmms2/Makefile
index d135ff834cad..3e4bd300efc6 100644
--- a/audio/p5-xmms2/Makefile
+++ b/audio/p5-xmms2/Makefile
@@ -1,7 +1,7 @@
# Created by: Alexander Botero-Lowry <alexbl@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio perl5
PKGNAMEPREFIX= p5-
@@ -12,7 +12,9 @@ LIB_DEPENDS+= libxmmsclient.so:audio/xmms2
MASTERDIR= ${.CURDIR}/../xmms2
-USES= perl5
+USES= perl5 ssl
+
+BROKEN_SSL= openssl-devel
PLIST= ${.CURDIR}/pkg-plist
diff --git a/audio/py-xmms2/Makefile b/audio/py-xmms2/Makefile
index a344910b504b..c53e3c3dfe04 100644
--- a/audio/py-xmms2/Makefile
+++ b/audio/py-xmms2/Makefile
@@ -1,7 +1,7 @@
# Created by: Alexander Botero-Lowry <alex@foxybanana.com>
# $FreeBSD$
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= audio python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,9 +14,11 @@ LIB_DEPENDS+= libxmmsclient.so:audio/xmms2
MASTERDIR= ${.CURDIR}/../xmms2
-USES= python:2.7
+USES= python:2.7 ssl
USE_PYTHON= flavors
+BROKEN_SSL= openssl-devel
+
PLIST= ${.CURDIR}/pkg-plist
XMMS2_SLAVE= python
diff --git a/audio/xmms2/Makefile b/audio/xmms2/Makefile
index c3606fa5c97f..eee3e0581667 100644
--- a/audio/xmms2/Makefile
+++ b/audio/xmms2/Makefile
@@ -4,7 +4,7 @@
PORTNAME?= xmms2
PORTVERSION= 0.8
DISTVERSIONSUFFIX= DrO_o
-PORTREVISION?= 25
+PORTREVISION?= 26
CATEGORIES?= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}%20${DISTVERSIONSUFFIX}
@@ -20,7 +20,7 @@ INSTALL_TARGET= install --without-ldconfig
.if !defined(XMMS2_SLAVE)
USE_GNOME= glib20
-USES+= sqlite
+USES+= readline sqlite
USE_LDCONFIG= yes
@@ -219,6 +219,7 @@ post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libxmmsclient*
.else
${RM} -R ${STAGEDIR}${PREFIX}/lib/xmms2
+ ${FIND} ${STAGEDIR}${PREFIX}/lib -name '*.so*' | ${XARGS} ${STRIP_CMD}
.endif
.include <bsd.port.post.mk>