aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2007-12-04 12:26:07 +0000
committerStanislav Sedov <stas@FreeBSD.org>2007-12-04 12:26:07 +0000
commit3d86af7e4a383f484cdcfd15c1c020864869f0a0 (patch)
treed2cd7afda5edc2147f23cd22675a94589b254c83
parentaec817d7db9777fd208cafd90ec32c7258bc6fab (diff)
downloadports-3d86af7e4a383f484cdcfd15c1c020864869f0a0.tar.gz
ports-3d86af7e4a383f484cdcfd15c1c020864869f0a0.zip
Notes
-rw-r--r--Mk/bsd.ruby.mk2
-rw-r--r--lang/ruby18/files/patch-lib_rexml_document.rb11
2 files changed, 12 insertions, 1 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 3017406121b0..46686d39d53d 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -162,7 +162,7 @@ RUBY?= ${LOCALBASE}/bin/${RUBY_NAME}
.if defined(RUBY_VER) && ${RUBY_VER} == 1.8
RUBY_RELVERSION= 1.8.6
-RUBY_PORTREVISION= 0
+RUBY_PORTREVISION= 1
RUBY_PORTEPOCH= 1
RUBY_PATCHLEVEL= 111
diff --git a/lang/ruby18/files/patch-lib_rexml_document.rb b/lang/ruby18/files/patch-lib_rexml_document.rb
new file mode 100644
index 000000000000..8f12653cb9d8
--- /dev/null
+++ b/lang/ruby18/files/patch-lib_rexml_document.rb
@@ -0,0 +1,11 @@
+--- lib/rexml/document.rb.orig 2007-12-04 03:05:22.000000000 +0300
++++ lib/rexml/document.rb 2007-12-04 03:05:26.000000000 +0300
+@@ -183,7 +183,7 @@
+ output = Output.new( output, xml_decl.encoding )
+ end
+ formatter = if indent > -1
+- if transitive
++ if trans
+ REXML::Formatters::Transitive.new( indent, ie_hack )
+ else
+ REXML::Formatters::Pretty.new( indent, ie_hack )