aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2019-11-12 17:00:40 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2019-11-12 17:00:40 +0000
commit3df71a614a34f1a85e4d931e5d32178c9e0d11a7 (patch)
tree69daf918a6f53b80839e0b8fa86fa52dd865dfb0
parent9b4840581dbd4c32929b4aaa31d899145176b442 (diff)
x11-wm/e16: update to 1.0.21, rework OPTIONS
Notes
Notes: svn path=/head/; revision=517341
-rw-r--r--x11-wm/e16/Makefile50
-rw-r--r--x11-wm/e16/distinfo6
2 files changed, 40 insertions, 16 deletions
diff --git a/x11-wm/e16/Makefile b/x11-wm/e16/Makefile
index bbb10821ed84..703a91395acc 100644
--- a/x11-wm/e16/Makefile
+++ b/x11-wm/e16/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= e16
-PORTVERSION= 1.0.20
+PORTVERSION= 1.0.21
PORTREVISION= 0
CATEGORIES= x11-wm enlightenment
MASTER_SITES= SF/enlightenment/${PORTNAME}/${PORTVERSION}/
@@ -17,16 +17,26 @@ LIB_DEPENDS= libImlib2.so:graphics/imlib2 \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
+USES= autoreconf gmake iconv libtool gnome perl5 pkgconfig \
+ shebangfix xorg
+
INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= DOCS NLS PANGO SOUND
+OPTIONS_DEFINE= DOCS NLS PANGO
+OPTIONS_RADIO= SOUND SOUNDLOADER
+OPTIONS_RADIO_SOUND= PULSEAUDIO SNDIO
+OPTIONS_RADIO_SOUNDLOADER= SNDFILE AUDIOFILE
OPTIONS_SUB= yes
-SOUND_LIB_DEPENDS= libpulse.so:audio/pulseaudio \
- libsndfile.so:audio/libsndfile
-SOUND_CONFIGURE_ON= --enable-sound=pulseaudio \
- --with-sndldr=sndfile
-SOUND_CONFIGURE_OFF= --disable-sound \
- --with-sndldr=none
+OPTIONS_DEFAULT= PULSEAUDIO SNDFILE
+
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+PULSEAUDIO_CONFIGURE_ON=--enable-sound=pulseaudio
+SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
+SNDIO_CONFIGURE_ON= --enable-sound=sndio
+SNDFILE_LIB_DEPENDS= libsndfile.so:audio/libsndfile
+SNDFILE_CONFIGURE_ON= --with-sndldr=sndfile
+AUDIOFILE_LIB_DEPENDS= libaudiofile.so:audio/libaudiofile
+AUDIOFILE_CONFIGURE_ON= --with-sndldr=audiofile
NLS_USES= gettext
NLS_CONFIGURE_OFF= --disable-nls
PANGO_USE= GNOME=pango
@@ -34,18 +44,32 @@ PANGO_CONFIGURE_ENABLE= pango
DOCS_CONFIGURE_ON= --enable-docs=yes
DOCS_CONFIGURE_OFF= --enable-docs=no
+.include <bsd.port.options.mk>
USES= autoreconf gmake iconv libtool gnome perl5 pkgconfig \
shebangfix xorg
-USE_XORG= ice sm xorgproto x11 xbitmaps \
- xcomposite xdamage xext xfixes xft xinerama xrandr xrender \
- xxf86vm
+# Double check SOUND and SOUNDLOADER
+E16_SOUND= ${PORT_OPTIONS:MPULSEAUDIO}${PORT_OPTIONS:MSNDIO}
+E16_SNDLDR= ${PORT_OPTIONS:MSNDFILE}${PORT_OPTIONS:MAUDIOFILE}
+.if !empty(E16_SOUND) && empty(E16_SNDLDR)
+IGNORE= sound support requires a sound loader
+.endif
+.if empty(E16_SOUND) && !empty(E16_SNDLDR)
+IGNORE= sound loader only makes sense with sound support
+.endif
+
+USE_XORG= ice sm xorgproto x11 xbitmaps xcomposite xdamage xext xfixes \
+ xft xinerama xrandr xrender xxf86vm
SHEBANG_FILES= scripts/e_gen_menu
CFLAGS+= -Wno-unused-parameter -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-dependency-tracking \
- --disable-rpath --enable-mans SHELL=/bin/sh
+CONFIGURE_ARGS= --disable-dependency-tracking --disable-rpath \
+ --enable-mans SHELL=/bin/sh
+
+.if empty(E16_SOUND) && empty(E16_SNDLDR)
+CONFIGURE_ARGS+=--enable-sound=no --with-sndldr=none
+.endif
post-patch:
${REINPLACE_CMD} -e 's|$$(USER)|${SHAREOWN}:${SHAREGRP}|g' \
diff --git a/x11-wm/e16/distinfo b/x11-wm/e16/distinfo
index a00930750995..2729cb2003d4 100644
--- a/x11-wm/e16/distinfo
+++ b/x11-wm/e16/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1559558966
-SHA256 (e16-1.0.20.tar.gz) = 9645f99294b1067863ce116838a674806a1777063c57761356c0839228caddff
-SIZE (e16-1.0.20.tar.gz) = 2469250
+TIMESTAMP = 1572859983
+SHA256 (e16-1.0.21.tar.gz) = 1241c2fbd9d3aff9cee78c5fa405db4d105f8e0df442cb37ebcfab3f4cd2bcf1
+SIZE (e16-1.0.21.tar.gz) = 2472975