aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-04 00:11:40 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-04 00:11:40 +0000
commit403890a6887ad5fd77114330dc4119158d21d0a4 (patch)
tree30d5f1ae1e55ce564d037a65b0932481c309eba0
parentde494a80910bba9be314cb2d32f0c7e07de7b33f (diff)
downloadports-403890a6887ad5fd77114330dc4119158d21d0a4.tar.gz
ports-403890a6887ad5fd77114330dc4119158d21d0a4.zip
Notes
-rw-r--r--irc/ctrlproxy/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Object/Makefile4
-rw-r--r--irc/p5-POE-Session-Irssi/Makefile4
-rw-r--r--irc/py-supybot/Makefile4
-rw-r--r--irc/simpleirc/Makefile4
5 files changed, 10 insertions, 10 deletions
diff --git a/irc/ctrlproxy/Makefile b/irc/ctrlproxy/Makefile
index 33600213c123..b3a839c1dcb8 100644
--- a/irc/ctrlproxy/Makefile
+++ b/irc/ctrlproxy/Makefile
@@ -21,6 +21,8 @@ USES= pkgconfig gmake
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= DOCS
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ctrlproxy
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ctrlproxy-admin
@@ -30,12 +32,10 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/doc/ctrlproxy_config.5 ${STAGEDIR}${MANPREFIX}/man/man5
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/doc/help.txt ${STAGEDIR}${DATADIR}/help.txt
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in AUTHORS HACKING NEWS README
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
${INSTALL_DATA} ${WRKSRC}/doc/user-guide.html ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/irc/p5-POE-Component-IRC-Object/Makefile b/irc/p5-POE-Component-IRC-Object/Makefile
index f49235e87894..2775cced589f 100644
--- a/irc/p5-POE-Component-IRC-Object/Makefile
+++ b/irc/p5-POE-Component-IRC-Object/Makefile
@@ -18,11 +18,11 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
+OPTIONS_DEFINE= EXAMPLES
+
post-install:
-.ifndef(NOPORTDOCS)
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/example/* ${STAGEDIR}${EXAMPLESDIR}
-.endif
.include <bsd.port.mk>
diff --git a/irc/p5-POE-Session-Irssi/Makefile b/irc/p5-POE-Session-Irssi/Makefile
index d11a289fb5aa..c213fb34434b 100644
--- a/irc/p5-POE-Session-Irssi/Makefile
+++ b/irc/p5-POE-Session-Irssi/Makefile
@@ -27,11 +27,11 @@ CONFIGURE_ARGS+= INSTALLDIRS=site
USES= perl5
USE_PERL5= configure
+OPTIONS_DEFINE= EXAMPLES
+
post-install:
-.ifndef(NOPORTEXAMPLES)
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/samples/* ${STAGEDIR}${EXAMPLESDIR}
-.endif
.include <bsd.port.mk>
diff --git a/irc/py-supybot/Makefile b/irc/py-supybot/Makefile
index 523fc25bcf05..e425071a28e8 100644
--- a/irc/py-supybot/Makefile
+++ b/irc/py-supybot/Makefile
@@ -23,17 +23,17 @@ MANCOMPRESSED= no
MAN1= supybot.1 supybot-adduser.1 supybot-wizard.1 supybot-botchk.1 \
supybot-plugin-create.1 supybot-plugin-doc.1
+OPTIONS_DEFINE= DOCS
+
post-install:
.for f in ${MAN1}
${INSTALL_MAN} ${WRKSRC}/docs/man/${f} ${STAGEDIR}${MAN1PREFIX}/man/man1
.endfor
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
${INSTALL_DATA} ${WRKSRC}/docs/GETTING_STARTED ${STAGEDIR}${DOCSDIR}
-.endif
.if !defined(BATCH)
@${CAT} ${PKGMESSAGE}
.endif
diff --git a/irc/simpleirc/Makefile b/irc/simpleirc/Makefile
index 8b1db9d05a53..3c2f2825ea70 100644
--- a/irc/simpleirc/Makefile
+++ b/irc/simpleirc/Makefile
@@ -17,12 +17,12 @@ LICENSE= MIT
PLIST_FILES= bin/simpleirc man/man1/simpleirc.1.gz
PORTDOCS= README LICENSE
+OPTIONS_DEFINE= DOCS
+
post-install:
-.if !defined(NOPORTDOCS)
@${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_MAN} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
@${INSTALL_MAN} ${WRKSRC}/LICENSE ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>