aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2011-12-11 22:54:03 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2011-12-11 22:54:03 +0000
commit40808811d2a95c68ea214ebd01e9f50657a9043d (patch)
treec9e321a0e35751bed6b1fe2c536757a68a3e788d
parentc15eb5b2ce4554bf020a893a1ba04518b250b6fd (diff)
downloadports-40808811d2a95c68ea214ebd01e9f50657a9043d.tar.gz
ports-40808811d2a95c68ea214ebd01e9f50657a9043d.zip
Notes
-rw-r--r--www/WebMagick/Makefile2
-rw-r--r--www/WebMagick/files/patch-aa19
2 files changed, 15 insertions, 6 deletions
diff --git a/www/WebMagick/Makefile b/www/WebMagick/Makefile
index 32650c205fca..004e3b6aa86e 100644
--- a/www/WebMagick/Makefile
+++ b/www/WebMagick/Makefile
@@ -7,7 +7,7 @@
PORTNAME= WebMagick
PORTVERSION= 2.03p3
-PORTREVISION= 46
+PORTREVISION= 47
PORTEPOCH= 1
CATEGORIES= www graphics
MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME:L}-beta/2.03pre3
diff --git a/www/WebMagick/files/patch-aa b/www/WebMagick/files/patch-aa
index 0339590feaf1..f86d073ab7fd 100644
--- a/www/WebMagick/files/patch-aa
+++ b/www/WebMagick/files/patch-aa
@@ -2,15 +2,15 @@ Index: webmagick.in
===================================================================
RCS file: /cvsroot/webmagick/WebMagick/webmagick.in,v
retrieving revision 1.117
-retrieving revision 1.169
-diff -u -r1.117 -r1.169
+retrieving revision 1.170
+diff -u -r1.117 -r1.170
--- webmagick.in 23 Oct 2002 16:14:47 -0000 1.117
-+++ webmagick.in 21 Sep 2011 05:54:43 -0000 1.169
++++ webmagick.in 11 Dec 2011 22:46:56 -0000 1.170
@@ -1,6 +1,6 @@
#! @PERL@
#
-# $Id: webmagick.in,v 1.117 2002/10/23 16:14:47 clindell Exp $
-+# $Id: webmagick.in,v 1.169 2011/09/21 05:54:43 ache Exp $
++# $Id: webmagick.in,v 1.170 2011/12/11 22:46:56 ache Exp $
#
# You are looking at the main PERL script for WebMagick, a package to
# intelligently create HTML and JavaScript index files and imagemaps
@@ -1551,12 +1551,21 @@ diff -u -r1.117 -r1.169
sub compareHash {
my( $hash1, $hash2) = @_;
-+ if (defined(%$hash1) != defined(%$hash2)) {
++ if (!%$hash1 != !%$hash2) {
+ return( 1 );
+ }
if(scalar(keys(%$hash1)) != scalar(keys(%$hash2))) {
return( 1 ); # different length
}
+@@ -3633,7 +3894,7 @@
+ }
+ }
+
+- if( !defined(%iconImageSizes) || ( compareHash(\%iconImageSizes,\%tmp_iconImageSizes) ) ) {
++ if( !%iconImageSizes || ( compareHash(\%iconImageSizes,\%tmp_iconImageSizes) ) ) {
+ %iconImageSizes = %tmp_iconImageSizes;
+ print( STDERR "Icon sizes have changed, must re-do all HTML\n" )
+ if $opt_debug;
@@ -3868,7 +4129,7 @@
# Set image label
#