aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-04-12 15:17:34 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-04-12 15:17:34 +0000
commit4220347afad5a1b9968651da7901aadbb220e5bd (patch)
tree7cdd537ed4fcda992616c8248c617aa8f766af47
parent9eb8f07c0feb59c824defea7a88a6a4a4ad2b42f (diff)
downloadports-4220347afad5a1b9968651da7901aadbb220e5bd.tar.gz
ports-4220347afad5a1b9968651da7901aadbb220e5bd.zip
Notes
-rw-r--r--graphics/gdal/Makefile3
-rw-r--r--graphics/grads/Makefile2
-rw-r--r--math/p5-NetCDF/Makefile3
-rw-r--r--science/py-netCDF4/Makefile3
4 files changed, 7 insertions, 4 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index ed6861256ae9..0cdb09bb4cc1 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gdal
PORTVERSION= 1.8.0
+PORTREVISION= 1
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/gdal/ \
ftp://ftp.remotesensing.org/pub/gdal/ \
@@ -145,7 +146,7 @@ CONFIGURE_ARGS+= --with-mysql=no
.if defined(WITH_NETCDF)
.if (${NETCDF_VER} == "4")
-LIB_DEPENDS+= netcdf.6:${PORTSDIR}/science/netcdf4
+LIB_DEPENDS+= netcdf.7:${PORTSDIR}/science/netcdf4
.else
LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
.endif
diff --git a/graphics/grads/Makefile b/graphics/grads/Makefile
index 8adfab453451..7e4ba4a800f0 100644
--- a/graphics/grads/Makefile
+++ b/graphics/grads/Makefile
@@ -7,7 +7,7 @@
PORTNAME= grads
PORTVERSION= 1.9b4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics science math
MASTER_SITES= ftp://grads.iges.org/grads/1.9/:src \
ftp://grads.iges.org/grads/:other
diff --git a/math/p5-NetCDF/Makefile b/math/p5-NetCDF/Makefile
index d3cd446d892b..5ca438acc243 100644
--- a/math/p5-NetCDF/Makefile
+++ b/math/p5-NetCDF/Makefile
@@ -7,6 +7,7 @@
PORTNAME= NetCDF
PORTVERSION= 1.2.4
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/netcdf-perl/
PKGNAMEPREFIX= p5-
@@ -18,7 +19,7 @@ COMMENT= Perl5 module to read and write netCDF files
NETCDF_VER?= 4
.if (${NETCDF_VER} == 4)
-LIB_DEPENDS= netcdf.6:${PORTSDIR}/science/netcdf4
+LIB_DEPENDS= netcdf.7:${PORTSDIR}/science/netcdf4
.else
LIB_DEPENDS= netcdf.4:${PORTSDIR}/science/netcdf
.endif
diff --git a/science/py-netCDF4/Makefile b/science/py-netCDF4/Makefile
index 10716e1d977d..71b9eb572c54 100644
--- a/science/py-netCDF4/Makefile
+++ b/science/py-netCDF4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= netCDF4
PORTVERSION= 0.9.3
+PORTREVISION= 1
CATEGORIES= science python
MASTER_SITES= http://netcdf4-python.googlecode.com/files/ \
CHEESESHOP
@@ -18,7 +19,7 @@ COMMENT= Python Interface to the NetCDF Library(versions 3 and 4)
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
RUN_DEPENDS= ${BUILD_DEPENDS}
LIB_DEPENDS= hdf5.6:${PORTSDIR}/science/hdf5-18 \
- netcdf.6:${PORTSDIR}/science/netcdf4
+ netcdf.7:${PORTSDIR}/science/netcdf4
USE_PYTHON= 2.5+
USE_PYDISTUTILS= yes