aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2003-01-23 21:03:14 +0000
committerAnders Nordby <anders@FreeBSD.org>2003-01-23 21:03:14 +0000
commit43a2fe364641ff77603fff0bdefe29790123e154 (patch)
tree39d147b686d9e60c1a42abb6443672578f353f37
parent637a804348ca2c0ad5c976d1454fb256d1f97c7b (diff)
downloadports-43a2fe364641ff77603fff0bdefe29790123e154.tar.gz
ports-43a2fe364641ff77603fff0bdefe29790123e154.zip
Notes
-rw-r--r--ftp/oftpd/Makefile3
-rw-r--r--security/fpm/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/ftp/oftpd/Makefile b/ftp/oftpd/Makefile
index 11f302199b22..2e017c8fc7eb 100644
--- a/ftp/oftpd/Makefile
+++ b/ftp/oftpd/Makefile
@@ -15,6 +15,7 @@ MASTER_SITES= http://www.time-travellers.org/oftpd/ \
MAINTAINER= anders@FreeBSD.org
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
DOCFILES= README AUTHORS ChangeLog NEWS TODO BUGS
@@ -25,7 +26,7 @@ MAN8= oftpd.8
post-patch:
.if defined(MAX_NUM_CLIENTS)
- @${PERL} -pi -e "s,MAX_NUM_CLIENTS 300,MAX_NUM_CLIENTS ${MAX_NUM_CLIENTS}," ${WRKSRC}/src/oftpd.h
+ ${REINPLACE_CMD} -e "s@MAX_NUM_CLIENTS 300@MAX_NUM_CLIENTS ${MAX_NUM_CLIENTS}@" ${WRKSRC}/src/oftpd.h
.endif
do-install:
diff --git a/security/fpm/Makefile b/security/fpm/Makefile
index 19587bc78f15..6bd2b4c3ee69 100644
--- a/security/fpm/Makefile
+++ b/security/fpm/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= anders@FreeBSD.org
USE_GNOME= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
SOURCEFILES= main.c fpm.c support.c interface.c passfile.c callbacks.c \
blowfish.c fpm_crypt.c fpm_gpw.c md5.c fpm_clist.c fpm_pref.c
@@ -26,7 +27,7 @@ GNOME_LIBS?= `${GNOME_CONFIG} --libs gnomeui` \
CFLAGS+= -DHAVE_CONFIG_H -I. -I.. ${GNOME_CFLAGS}
pre-build:
- ${PERL} -pi -e "s@encrypt\(@bfishencrypt\(@g" ${WRKSRC}/src/blowfish.c
+ ${REINPLACE_CMD} -E -e ""s@encrypt\(@bfishencrypt\(@g" ${WRKSRC}/src/blowfish.c
do-build:
.for f in ${SOURCEFILES}