aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2011-11-23 11:56:53 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2011-11-23 11:56:53 +0000
commit449868b8a1d4accba1a51a04260b8d0c4eb6fe91 (patch)
tree784ade854c8072efd57721fbf13880d3b9da0fca
parent59134b7c45fcef0168ddb962ce10f866bd593d0f (diff)
downloadports-449868b8a1d4accba1a51a04260b8d0c4eb6fe91.tar.gz
ports-449868b8a1d4accba1a51a04260b8d0c4eb6fe91.zip
Add quick fix for fresh redis.
Also drop a note for UPDATING. Feature safe: yes Pointy hat to: osa
Notes
Notes: svn path=/head/; revision=286303
-rw-r--r--UPDATING10
-rw-r--r--databases/redis/files/patch-src::Makefile24
2 files changed, 22 insertions, 12 deletions
diff --git a/UPDATING b/UPDATING
index d281f2b71c6a..57086fddf55c 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,16 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20111123:
+ AFFECTS: users of databases/redis
+ AUTHOR: osa@FreeBSD.org
+
+ The redis configuration file, redis.conf, have been changed, some options
+ removed in newer versions (>=2.4). In some cases, redis-server with
+ older configuration might does not run at startup.
+
+ If you run into startup problems, re-edit configuration file.
+
20111101:
AFFECTS: users of x11/kde4-workspace
AUTHOR: kde@FreeBSD.org
diff --git a/databases/redis/files/patch-src::Makefile b/databases/redis/files/patch-src::Makefile
index 1a3bdd9047d9..2bc136769d79 100644
--- a/databases/redis/files/patch-src::Makefile
+++ b/databases/redis/files/patch-src::Makefile
@@ -1,24 +1,24 @@
---- src/Makefile.orig 2011-09-14 10:32:32.000000000 +0400
-+++ src/Makefile 2011-09-14 10:34:08.000000000 +0400
-@@ -22,6 +22,9 @@
- CFLAGS?= -std=c99 -pedantic $(OPTIMIZATION) -Wall -W -D__EXTENSIONS__ -D_XPG6
- CCLINK?= -ldl -lnsl -lsocket -lm -lpthread
- DEBUG?= -g -ggdb
+--- src/Makefile.orig 2011-11-21 21:47:39.000000000 +0400
++++ src/Makefile 2011-11-23 06:29:54.000000000 +0400
+@@ -28,6 +28,9 @@
+ CFLAGS?=-std=c99 -pedantic $(OPTIMIZATION) -Wall -W -D__EXTENSIONS__ -D_XPG6
+ CCLINK?=-ldl -lnsl -lsocket -lm -lpthread
+ DEBUG?=-g -ggdb
+else ifeq ($(uname_S),FreeBSD)
+ CFLAGS?= $(CFLAGS)
+ CCLINK?= -pthread -lm
else
- CFLAGS?= -std=c99 -pedantic $(OPTIMIZATION) -Wall -W $(ARCH) $(PROF)
- CCLINK?= -lm -pthread
-@@ -32,9 +35,9 @@
- CCLINK+= -ltcmalloc
- CFLAGS+= -DUSE_TCMALLOC
+ CFLAGS?=-std=c99 -pedantic $(OPTIMIZATION) -Wall -W $(ARCH) $(PROF)
+ CCLINK?=-lm -pthread
+@@ -52,9 +55,9 @@
+ ALLOC_FLAGS=-DUSE_JEMALLOC -I../deps/jemalloc/include
endif
+
-CCOPT= $(CFLAGS) $(ARCH) $(PROF)
+CCOPT= $(CFLAGS) $(PROF)
-PREFIX= /usr/local
-+PREFIX?= $(PREFIX)
++PREFIX:= ${PREFIX}
INSTALL_BIN= $(PREFIX)/bin
INSTALL= cp -p