aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-02-22 19:51:34 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-02-22 19:51:34 +0000
commit458c9f8a3403534c99d7a6bef85048820bbb9c2f (patch)
treecb64f37192f9ab483c22309af9f0a8eada9cbc7d
parentd9ff6ab227e744b76ee62589287929f86a760b3c (diff)
downloadports-458c9f8a3403534c99d7a6bef85048820bbb9c2f.tar.gz
ports-458c9f8a3403534c99d7a6bef85048820bbb9c2f.zip
Notes
-rw-r--r--audio/speex-devel/Makefile19
-rw-r--r--audio/speex-devel/distinfo6
-rw-r--r--audio/speex-devel/files/patch-src::speexdec.c17
-rw-r--r--audio/speex-devel/files/patch-src_vq.h14
-rw-r--r--audio/speex-devel/pkg-descr3
-rw-r--r--audio/speex-devel/pkg-plist3
6 files changed, 15 insertions, 47 deletions
diff --git a/audio/speex-devel/Makefile b/audio/speex-devel/Makefile
index 995b6de6adf2..70a13bc66fb7 100644
--- a/audio/speex-devel/Makefile
+++ b/audio/speex-devel/Makefile
@@ -1,13 +1,13 @@
-# ex:ts=8
# Ports collection makefile for: Speex
# Date created: Jul 30, 2002
# Whom: ijliao
#
# $FreeBSD$
# $MCom: ports-stable/audio/speex-devel/Makefile,v 1.1 2006/03/04 21:32:25 ahze Exp $
+#
PORTNAME= speex
-PORTVERSION= 1.1.12
+DISTVERSION= 1.2beta1
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= http://downloads.us.xiph.org/releases/speex/
@@ -18,24 +18,21 @@ COMMENT= An open-source patent-free voice codec
LIB_DEPENDS= ogg.5:${PORTSDIR}/audio/libogg
-CONFLICTS= speex-1.0*
+CONFLICTS= speex-[0-9]*
-USE_GNOME= gnomehack
+USE_GNOME= gnomehack gnometarget ltverhack
+USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:15
-USE_GETOPT_LONG= yes
+USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-ogg-dir=${LOCALBASE}
-INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN1= speexdec.1 speexenc.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Does not build on 4.x
-.endif
-
.if ${MACHINE_CPU:Msse}!=""
CONFIGURE_ARGS+= --enable-sse
.endif
diff --git a/audio/speex-devel/distinfo b/audio/speex-devel/distinfo
index a2d95c6b2f26..e26d00c20185 100644
--- a/audio/speex-devel/distinfo
+++ b/audio/speex-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (speex-1.1.12.tar.gz) = 1bd6cdf3a0ebabf818cd72a3401e2610
-SHA256 (speex-1.1.12.tar.gz) = 77c8505bd9b73192789770299e0a727fba9c1d556d853b8cc473bfee393709f8
-SIZE (speex-1.1.12.tar.gz) = 740110
+MD5 (speex-1.2beta1.tar.gz) = aac2e4ba42122b885c787ea280acb3d9
+SHA256 (speex-1.2beta1.tar.gz) = d8bef008b3be87b3b155128c091286b269fee32a38b0849bc8cacb3cd5f7f6a0
+SIZE (speex-1.2beta1.tar.gz) = 932798
diff --git a/audio/speex-devel/files/patch-src::speexdec.c b/audio/speex-devel/files/patch-src::speexdec.c
deleted file mode 100644
index 96a7c2c22841..000000000000
--- a/audio/speex-devel/files/patch-src::speexdec.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/speexdec.c.orig Sun Jun 1 14:58:51 2003
-+++ src/speexdec.c Wed Jun 11 02:07:49 2003
-@@ -72,6 +72,14 @@
- ((buf[base+1]<<8)&0xff00)| \
- (buf[base]&0xff))
-
-+#if !defined(AFMT_S16_NE)
-+#if defined(BYTE_ORDER) && (BYTE_ORDER == BIG_ENDIAN)
-+#define AFMT_S16_NE AFMT_S16_BE
-+#else
-+#define AFMT_S16_NE AFMT_S16_LE
-+#endif
-+#endif
-+
- static void print_comments(char *comments, int length)
- {
- char *c=comments;
diff --git a/audio/speex-devel/files/patch-src_vq.h b/audio/speex-devel/files/patch-src_vq.h
deleted file mode 100644
index e3564cc6abe3..000000000000
--- a/audio/speex-devel/files/patch-src_vq.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- libspeex/vq.h.orig Fri Jun 3 13:39:38 2005
-+++ libspeex/vq.h Fri Jun 3 13:39:47 2005
-@@ -41,9 +41,9 @@
- int vq_index(float *in, const float *codebook, int len, int entries);
- #ifdef _USE_SSE
- #include <xmmintrin.h>
--void vq_nbest(spx_word16_t *in, const __m128 *codebook, int len, int entries, __m128 *E, int N, int *nbest, spx_word32_t *best_dist, char *stack);
-+// void vq_nbest(spx_word16_t *in, const __m128 *codebook, int len, int entries, __m128 *E, int N, int *nbest, spx_word32_t *best_dist, char *stack);
-
--void vq_nbest_sign(spx_word16_t *in, const __m128 *codebook, int len, int entries, __m128 *E, int N, int *nbest, spx_word32_t *best_dist, char *stack);
-+// void vq_nbest_sign(spx_word16_t *in, const __m128 *codebook, int len, int entries, __m128 *E, int N, int *nbest, spx_word32_t *best_dist, char *stack);
- #else
- void vq_nbest(spx_word16_t *in, const spx_word16_t *codebook, int len, int entries, spx_word32_t *E, int N, int *nbest, spx_word32_t *best_dist, char *stack);
-
diff --git a/audio/speex-devel/pkg-descr b/audio/speex-devel/pkg-descr
index deda059aaa99..0243650844ba 100644
--- a/audio/speex-devel/pkg-descr
+++ b/audio/speex-devel/pkg-descr
@@ -5,4 +5,7 @@ applications include VoIP, internet audio streaming, archiving of
speech data (e.g. voice mail), and audio books. In some sense, it is
meant to be complementary to the Ogg Vorbis codec.
+This ports is for the development version of speex, but the file format
+is compatibile with the base (1.0 and 1.1) versions.
+
WWW: http://www.speex.org/
diff --git a/audio/speex-devel/pkg-plist b/audio/speex-devel/pkg-plist
index 9870728b80ee..132f73986d20 100644
--- a/audio/speex-devel/pkg-plist
+++ b/audio/speex-devel/pkg-plist
@@ -1,6 +1,5 @@
bin/speexdec
bin/speexenc
-include/speex/pcm_wrapper.h
include/speex/speex.h
include/speex/speex_bits.h
include/speex/speex_callbacks.h
@@ -14,7 +13,7 @@ include/speex/speex_types.h
lib/libspeex.a
lib/libspeex.la
lib/libspeex.so
-lib/libspeex.so.3
+lib/libspeex.so.1
libdata/pkgconfig/speex.pc
share/aclocal/speex.m4
@dirrm include/speex