aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2019-01-15 00:22:14 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2019-01-15 00:22:14 +0000
commit45dcd804d0f0fb714adcad60a289349cc7f9ad56 (patch)
tree67aca01e71980d9e875630e3026ee82f8728ddbb
parentfe89ef625f3b5fb393c67abea69ec1631488cff1 (diff)
downloadports-45dcd804d0f0fb714adcad60a289349cc7f9ad56.tar.gz
ports-45dcd804d0f0fb714adcad60a289349cc7f9ad56.zip
Notes
-rw-r--r--dns/gdnsd2/Makefile2
-rw-r--r--dns/gdnsd2/files/patch-libgdmaps_gdgeoip2.c16
2 files changed, 17 insertions, 1 deletions
diff --git a/dns/gdnsd2/Makefile b/dns/gdnsd2/Makefile
index 72a28093653f..2fbe2bda099f 100644
--- a/dns/gdnsd2/Makefile
+++ b/dns/gdnsd2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gdnsd
PORTVERSION= 2.4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns
MASTER_SITES= https://github.com/gdnsd/gdnsd/releases/download/v${PORTVERSION}/ \
ZI \
diff --git a/dns/gdnsd2/files/patch-libgdmaps_gdgeoip2.c b/dns/gdnsd2/files/patch-libgdmaps_gdgeoip2.c
new file mode 100644
index 000000000000..470eeb335f8a
--- /dev/null
+++ b/dns/gdnsd2/files/patch-libgdmaps_gdgeoip2.c
@@ -0,0 +1,16 @@
+--- libgdmaps/gdgeoip2.c.orig 2019-01-15 00:17:32 UTC
++++ libgdmaps/gdgeoip2.c
+@@ -172,12 +172,7 @@ static geoip2_t* geoip2_new(const char*
+ db->is_city = !!strstr(meta->database_type, "City");
+
+ if(db->is_city) {
+- // 1546300799 == 2018-12-31T23:59:59
+- if(city_auto_mode && strstr(meta->database_type, "GeoLite2") && meta->build_epoch > (uint64_t)1546300799LLU) {
+- dmn_log_err("plugin_geoip: map '%s': GeoIP2 DB '%s' appears to be a post-2018 GeoLite2-City database, which will not work with auto_dc_coords as configured because these databases lack the latitude and longitude data present in the commercial version. See the auto_dc_coords section of the gdnsd-plugin-geoip documentation for more details.", map_name, pathname);
+- geoip2_destroy(db);
+- return NULL;
+- }
++ // noop
+ } else {
+ if(city_auto_mode) {
+ dmn_log_err("plugin_geoip: map '%s': GeoIP2 DB '%s' is not a City-level"