aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-12 17:07:08 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-12 17:07:08 +0000
commit46b556be1c5e78a30a7e153cc9096e9ff3fd084a (patch)
treeec18cef613a0fc54432d428850a3c719902d7112
parentfed77d64811993002799efa97b0032ef9a95edc6 (diff)
downloadports-46b556be1c5e78a30a7e153cc9096e9ff3fd084a.tar.gz
ports-46b556be1c5e78a30a7e153cc9096e9ff3fd084a.zip
Notes
-rw-r--r--audio/cmus-post.fm/Makefile4
-rw-r--r--audio/mp32ogg/Makefile3
-rw-r--r--deskutils/adesklets/Makefile5
-rw-r--r--graphics/gimp-save-for-web/Makefile4
-rw-r--r--graphics/pfscalibration/Makefile4
-rw-r--r--math/algotutor/Makefile4
-rw-r--r--math/naturalmath/Makefile3
-rw-r--r--security/clamtk/Makefile4
-rw-r--r--security/p5-openxpki-i18n/Makefile4
-rw-r--r--security/steghide/Makefile3
-rw-r--r--x11-fonts/mkbold/Makefile3
-rw-r--r--x11-fonts/mkitalic/Makefile3
-rw-r--r--x11/bgrot/Makefile3
-rw-r--r--x11/gnome-libs/Makefile4
-rw-r--r--x11/xdotool/Makefile4
-rw-r--r--x11/xfree86_xkb_xml/Makefile5
16 files changed, 23 insertions, 37 deletions
diff --git a/audio/cmus-post.fm/Makefile b/audio/cmus-post.fm/Makefile
index 2cf35cc89ece..1e1d49d82fa9 100644
--- a/audio/cmus-post.fm/Makefile
+++ b/audio/cmus-post.fm/Makefile
@@ -13,9 +13,9 @@ COMMENT= Last.fm submitter
RUN_DEPENDS= p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww \
p5-Storable>=0:${PORTSDIR}/devel/p5-Storable
-USES= shebangfix
+USES= shebangfix perl5
USE_BZIP2= yes
-USE_PERL5_RUN= yes
+USE_PERL5= run
SUB_FILES= pkg-message
NO_BUILD= yes
PLIST_FILES= libexec/${PORTNAME} %%EXAMPLESDIR%%/${PORTNAME}.conf
diff --git a/audio/mp32ogg/Makefile b/audio/mp32ogg/Makefile
index 43a027fbfbf1..3361326fb59f 100644
--- a/audio/mp32ogg/Makefile
+++ b/audio/mp32ogg/Makefile
@@ -18,8 +18,7 @@ RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123 \
p5-MP3-Info>=0:${PORTSDIR}/audio/p5-MP3-Info \
p5-String-ShellQuote>=0:${PORTSDIR}/textproc/p5-String-ShellQuote
-USE_PERL5= yes
-USES= shebangfix
+USES= shebangfix perl5
SHEBANG_FILES= mp32ogg
NO_WRKSUBDIR= yes
EXTRACT_CMD= ${CP}
diff --git a/deskutils/adesklets/Makefile b/deskutils/adesklets/Makefile
index 10680c3f3e93..d58f359c7ffe 100644
--- a/deskutils/adesklets/Makefile
+++ b/deskutils/adesklets/Makefile
@@ -21,8 +21,7 @@ USE_PYTHON= yes
USE_GMAKE= yes
USE_BZIP2= yes
USE_EFL= imlib2
-USES= iconv
-WANT_PERL= yes
+USES= iconv gmake
MAN1= adesklets.1 \
adesklets_checkin.1 \
@@ -36,7 +35,7 @@ INSTALLS_EGGINFO= yes
LDFLAGS+= ${ICONV_LIB}
.if !defined(WITHOUT_PERL)
-USE_PERL5= yes
+USES+= perl5
PLIST_SUB+= PERL=""
.else
CONFIGURE_ARGS+= --without-perl-support
diff --git a/graphics/gimp-save-for-web/Makefile b/graphics/gimp-save-for-web/Makefile
index 4f4cc1abe162..9caad9bb537d 100644
--- a/graphics/gimp-save-for-web/Makefile
+++ b/graphics/gimp-save-for-web/Makefile
@@ -14,8 +14,8 @@ LIB_DEPENDS= gimp-2.0:${PORTSDIR}/graphics/gimp-app
BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
USE_BZIP2= yes
-USES= gettext gmake pkgconfig
-USE_PERL5_BUILD=yes
+USES= gettext gmake pkgconfig perl5
+USE_PERL5= build
GNU_CONFIGURE= yes
USE_GNOME= gnomehack intltool
diff --git a/graphics/pfscalibration/Makefile b/graphics/pfscalibration/Makefile
index 3298cc878c01..577c5b14c1c4 100644
--- a/graphics/pfscalibration/Makefile
+++ b/graphics/pfscalibration/Makefile
@@ -13,12 +13,10 @@ COMMENT= Photometric calibration of cameras and recovery HDR images from the set
PFS_CPPFLAGS= -I${LOCALBASE}/include
PFS_LDFLAGS= -L${LOCALBASE}/lib
-USES= pkgconfig shebangfix
+USES= gmake pkgconfig shebangfix perl5
GNU_CONFIGURE= yes
CPPFLAGS+= ${PFS_CPPFLAGS}
LDFLAGS+= ${PFS_LDFLAGS}
-USE_GMAKE= yes
-USE_PERL5= yes
LIB_DEPENDS= pfs-1.2:${PORTSDIR}/graphics/pfstools
diff --git a/math/algotutor/Makefile b/math/algotutor/Makefile
index 0466d1d3ce3a..0193b0082ae1 100644
--- a/math/algotutor/Makefile
+++ b/math/algotutor/Makefile
@@ -13,7 +13,7 @@ COMMENT= Interactive tutorial for algorithms and data structures
BUILD_DEPENDS= p5-Tk>=0:${PORTSDIR}/x11-toolkits/p5-Tk
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PERL5_BUILD=yes
+USE_PERL5= build
NO_BUILD= yes
MAN1= algotutor.1 gen_at_graph.1
@@ -23,7 +23,7 @@ LIBFILES= BST.pm Board.pm Collection.pm Configurable.pm DCEdge.pm \
RecCanvas.pm RecDialog.pm TreeNode.pm Vector.pm Vector2.pm \
Vector3.pm Vertex.pm basic.pl utilalgo
-USES= shebangfix
+USES= shebangfix perl5
SHEBANG_FILES= algotutor
post-patch:
diff --git a/math/naturalmath/Makefile b/math/naturalmath/Makefile
index 58d0c5e14b91..786226748139 100644
--- a/math/naturalmath/Makefile
+++ b/math/naturalmath/Makefile
@@ -10,9 +10,8 @@ MASTER_SITES= http://www.math.missouri.edu/~stephen/naturalmath/
MAINTAINER= stephen@FreeBSD.org
COMMENT= Script to turn intuitively written math into latex
-USE_PERL5= yes
USE_TEX= latex:build dvipsk:build
-USES= shebangfix
+USES= shebangfix perl5
SHEBANG_FILES= naturalmath
do-build:
diff --git a/security/clamtk/Makefile b/security/clamtk/Makefile
index 7c5ba0d38b43..23b96281400b 100644
--- a/security/clamtk/Makefile
+++ b/security/clamtk/Makefile
@@ -27,8 +27,8 @@ RUN_DEPENDS= p5-Config-Tiny>=2.12:${PORTSDIR}/devel/p5-Config-Tiny \
p5-Gtk2>=1.144:${PORTSDIR}/x11-toolkits/p5-Gtk2
NO_BUILD= yes
-USE_PERL5_RUN= yes
-USES= gettext:run
+USES= gettext:run perl5
+USE_PERL5= run
MAN1= ${PORTNAME}.1
diff --git a/security/p5-openxpki-i18n/Makefile b/security/p5-openxpki-i18n/Makefile
index 0ba456f1badf..77fee02cd461 100644
--- a/security/p5-openxpki-i18n/Makefile
+++ b/security/p5-openxpki-i18n/Makefile
@@ -16,11 +16,9 @@ BUILD_DEPENDS= \
p5-openxpki>=0:${PORTSDIR}/security/p5-openxpki
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PERL5= yes
-USES= gettext
+USES= gettext gmake perl5
### We can not go WITHOUT_NLS. Internationalization is needed
### even to use English language.
-USE_GMAKE= yes
ALL_TARGET= default
.include <bsd.port.mk>
diff --git a/security/steghide/Makefile b/security/steghide/Makefile
index 9692b3a66cc7..15bc6fbe3e6c 100644
--- a/security/steghide/Makefile
+++ b/security/steghide/Makefile
@@ -21,8 +21,7 @@ LIB_DEPENDS= mcrypt.8:${PORTSDIR}/security/libmcrypt \
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gettext
-USE_PERL5= yes
+USES= gettext perl5
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lintl -lmcrypt"
diff --git a/x11-fonts/mkbold/Makefile b/x11-fonts/mkbold/Makefile
index 8178906ec017..242eed95f2ed 100644
--- a/x11-fonts/mkbold/Makefile
+++ b/x11-fonts/mkbold/Makefile
@@ -14,9 +14,8 @@ COMMENT= Perl script to make BDF font bold
CONFLICTS= mkbold-mkitalic-[0-9]*
PLIST_FILES= bin/mkbold
-USES= shebangfix
+USES= shebangfix perl5
SHEBANG_FILES= mkbold
-USE_PERL5= yes
EXTRACT_CMD= ${BZCAT}
EXTRACT_BEFORE_ARGS= #
EXTRACT_AFTER_ARGS= > ${WRKSRC}/mkbold
diff --git a/x11-fonts/mkitalic/Makefile b/x11-fonts/mkitalic/Makefile
index 934cd06e4e57..8bb3fee32655 100644
--- a/x11-fonts/mkitalic/Makefile
+++ b/x11-fonts/mkitalic/Makefile
@@ -14,13 +14,12 @@ COMMENT= Perl script to make BDF font italic
CONFLICTS= mkbold-mkitalic-[0-9]*
PLIST_FILES= bin/mkitalic
-USE_PERL5= yes
EXTRACT_CMD= ${BZCAT}
EXTRACT_BEFORE_ARGS= #
EXTRACT_AFTER_ARGS= > ${WRKSRC}/mkitalic
NO_WRKSUBDIR= yes
USE_BZIP2= yes
-USES= shebangfix
+USES= shebangfix perl5
SHEBANG_FILES= mkitalic
do-build:
diff --git a/x11/bgrot/Makefile b/x11/bgrot/Makefile
index 87805a9fd4d9..def0fcab4097 100644
--- a/x11/bgrot/Makefile
+++ b/x11/bgrot/Makefile
@@ -13,8 +13,7 @@ COMMENT= A program to handle your X background to prevent boredom
RUN_DEPENDS= xv:${PORTSDIR}/graphics/xv
-USES= shebangfix
-USE_PERL5= yes
+USES= shebangfix perl5
SHEBANG_FILES= *.pl
MAN1= bgrot.1
diff --git a/x11/gnome-libs/Makefile b/x11/gnome-libs/Makefile
index 8a8c1d0b4d6e..5d6d33e58659 100644
--- a/x11/gnome-libs/Makefile
+++ b/x11/gnome-libs/Makefile
@@ -17,11 +17,9 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
RUN_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
MAKE_JOBS_UNSAFE=yes
-USES= charsetfix gettext pathfix
+USES= charsetfix gettext gmake pathfix perl5
USE_BZIP2= yes
USE_XORG= xpm ice x11
-USE_PERL5= yes
-USE_GMAKE= yes
USE_GNOME= gnomehier gnomeprefix esound gtk12 imlib libxml orbit
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/x11/xdotool/Makefile b/x11/xdotool/Makefile
index 10dd03e3719c..efe47b88346d 100644
--- a/x11/xdotool/Makefile
+++ b/x11/xdotool/Makefile
@@ -9,10 +9,10 @@ MASTER_SITES= http://semicomplete.googlecode.com/files/
MAINTAINER= wxs@FreeBSD.org
COMMENT= Programmatically simulate keyboard input or mouse activity
-USE_PERL5_BUILD= yes
USE_LDCONFIG= yes
-USES= gmake pkgconfig
+USES= gmake pkgconfig perl5
USE_XORG= x11 xtst xinerama
+USE_PERL5= build
MAN1= xdotool.1
PLIST_FILES= bin/xdotool lib/libxdo.so lib/libxdo.so.2 include/xdo.h
diff --git a/x11/xfree86_xkb_xml/Makefile b/x11/xfree86_xkb_xml/Makefile
index d42fc8504841..2e161dfb6f1e 100644
--- a/x11/xfree86_xkb_xml/Makefile
+++ b/x11/xfree86_xkb_xml/Makefile
@@ -14,11 +14,10 @@ MASTER_SITES= SF/gswitchit/OldFiles
MAINTAINER= gnome@FreeBSD.org
COMMENT= A little set of XML files useful for dealing with XKB rules
-USES= gettext iconv
+USES= gettext gmake iconv perl5
USE_XORG= x11
-USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
CONFIGURE_ARGS= --with-xkb-base=${LOCALBASE}/lib/X11/xkb
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib