aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-24 09:50:20 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-24 09:50:20 +0000
commit475fb8834b5e0f35bcb2ccaee6880c797ad390c7 (patch)
tree6c69f8ce3b820716b67f12d5454e7e134294835d
parent29aeb1087a3c4b5f5472a383fc213ad3d1e85d42 (diff)
Notes
-rw-r--r--x11/sterm/Makefile19
-rw-r--r--x11/sterm/files/patch-Makefile7
2 files changed, 11 insertions, 15 deletions
diff --git a/x11/sterm/Makefile b/x11/sterm/Makefile
index 660b1afc0e4a..a6ce8855afe1 100644
--- a/x11/sterm/Makefile
+++ b/x11/sterm/Makefile
@@ -15,17 +15,15 @@ LICENSE_NAME= MIT/X Consortium License
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-LIB_DEPENDS= fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- freetype:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
+ libfreetype.so:${PORTSDIR}/print/freetype2
-USES= pkgconfig ncurses:port
+USES= pkgconfig ncurses:port
USE_XORG= x11 xext xft
-MAN1= st.1
-PLIST_FILES= bin/st
-PORTDOCS= README
+PLIST_FILES= bin/st man/man1/st.1.gz
-NO_STAGE= yes
+PORTDOCS= README
OPTIONS_DEFINE= DOCS
@@ -49,11 +47,10 @@ post-patch:
${WRKSRC}/config.mk
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/st
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/x11/sterm/files/patch-Makefile b/x11/sterm/files/patch-Makefile
index ba4a83391616..37629c1a4354 100644
--- a/x11/sterm/files/patch-Makefile
+++ b/x11/sterm/files/patch-Makefile
@@ -1,11 +1,10 @@
---- Makefile.orig 2013-06-26 00:09:00.000000000 -0500
-+++ Makefile 2013-06-26 00:10:14.000000000 -0500
-@@ -49,7 +49,7 @@
+--- Makefile.orig 2013-04-20 15:29:39.000000000 +0200
++++ Makefile 2014-02-24 10:49:11.418450591 +0100
+@@ -49,7 +49,6 @@
@sed "s/VERSION/${VERSION}/g" < st.1 > ${DESTDIR}${MANPREFIX}/man1/st.1
@chmod 644 ${DESTDIR}${MANPREFIX}/man1/st.1
@echo Please see the README file regarding the terminfo entry of st.
- @tic -s st.info
-+ @tic -s -o ${LOCALBASE}/share/misc st.info
uninstall:
@echo removing executable file from ${DESTDIR}${PREFIX}/bin