aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2003-02-27 00:17:18 +0000
committerAlexander Langer <alex@FreeBSD.org>2003-02-27 00:17:18 +0000
commit47695840417950f9e740f87925693b0ee61fd957 (patch)
tree2cc16e61f18019689524713133d6719967f7bea0
parentb815d65b95b8ce37d583f1bc4afb7f4705a66846 (diff)
downloadports-47695840417950f9e740f87925693b0ee61fd957.tar.gz
ports-47695840417950f9e740f87925693b0ee61fd957.zip
Notes
-rw-r--r--math/fxt/Makefile3
-rw-r--r--math/fxt/distinfo2
-rw-r--r--math/fxt/files/patch-include::jjassert.h11
-rw-r--r--math/fxt/files/patch-makefile15
-rw-r--r--math/fxt/pkg-plist31
5 files changed, 48 insertions, 14 deletions
diff --git a/math/fxt/Makefile b/math/fxt/Makefile
index 5d55118f3474..f11ac2408f64 100644
--- a/math/fxt/Makefile
+++ b/math/fxt/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= fxt
-PORTVERSION= 2002.12.16
+PORTVERSION= 2003.02.18
CATEGORIES= math
MASTER_SITES= http://www.jjj.de/fxt/
EXTRACT_SUFX= .tgz
@@ -17,7 +17,6 @@ COMMENT= FFT code and related stuff
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_GCC= 3.1
USE_GMAKE= yes
MAKEFILE= makefile
diff --git a/math/fxt/distinfo b/math/fxt/distinfo
index d4437a6d4a5d..3267ffa50384 100644
--- a/math/fxt/distinfo
+++ b/math/fxt/distinfo
@@ -1 +1 @@
-MD5 (fxt-2002.12.16.tgz) = 2794f9ff63b8c4c79e46e923a3c02362
+MD5 (fxt-2003.02.18.tgz) = e9941264cf6f6755f88ebc92063608ed
diff --git a/math/fxt/files/patch-include::jjassert.h b/math/fxt/files/patch-include::jjassert.h
new file mode 100644
index 000000000000..47b53e6ea6a3
--- /dev/null
+++ b/math/fxt/files/patch-include::jjassert.h
@@ -0,0 +1,11 @@
+--- include/jjassert.h.orig Sun Feb 23 14:08:38 2003
++++ include/jjassert.h Sun Feb 23 14:08:56 2003
+@@ -2,7 +2,7 @@
+ #define HAVE_JJASSERT_H__
+
+ // if you don't have sys/cdefs.h just uncomment the next line:
+-//#include <sys/cdefs.h> // __STRING()
++#include <sys/cdefs.h> // __STRING()
+
+ // aux0/jjassert.cc:
+ // options for last action of jjassert_fail():
diff --git a/math/fxt/files/patch-makefile b/math/fxt/files/patch-makefile
index c2b3ea25f577..90c3a13b6e9a 100644
--- a/math/fxt/files/patch-makefile
+++ b/math/fxt/files/patch-makefile
@@ -1,5 +1,5 @@
---- makefile.orig Tue Dec 17 02:37:28 2002
-+++ makefile Sun Dec 22 08:38:00 2002
+--- makefile.orig Sat Jan 11 18:08:57 2003
++++ makefile Mon Jan 27 16:08:56 2003
@@ -3,7 +3,7 @@
PROJ=fxt
@@ -9,16 +9,15 @@
PPLIBS = -lm -lstdc++
-@@ -16,7 +16,7 @@
+@@ -15,7 +15,6 @@
# -mcpu= Schedule code for given CPU
# Note that specifying `-march=CPU-TYPE' implies `-mcpu=CPU-TYPE'
--OFLAGS = -O2 -ffast-math
-+OFLAGS += -ffast-math
- OFLAGS += $(ARCHFLAG)
+-OFLAGS = -O2
OFLAGS += -fomit-frame-pointer
OFLAGS += -fno-exceptions
-@@ -47,12 +47,12 @@
+ OFLAGS += -ffast-math
+@@ -53,12 +52,12 @@
-Imod -Iwavelet -Isort -Islow
#### choose the FLAG combo here:
@@ -34,7 +33,7 @@
#-------------------------------------
-@@ -348,16 +348,16 @@
+@@ -354,16 +353,16 @@
# @echo ' ===== make FXT lib DONE. ====='
diff --git a/math/fxt/pkg-plist b/math/fxt/pkg-plist
index c02aac41e57b..57d1a1eb6fcf 100644
--- a/math/fxt/pkg-plist
+++ b/math/fxt/pkg-plist
@@ -11,16 +11,31 @@ include/fxt/auxdouble.h
include/fxt/auxprint.h
include/fxt/binarydebruijn.h
include/fxt/binaryprimestring.h
+include/fxt/bit2adic.h
+include/fxt/bit2composition.h
include/fxt/bit2pow.h
include/fxt/bitarray.h
include/fxt/bitasm.h
-include/fxt/bitcombination.h
+include/fxt/bitcombcolex.h
+include/fxt/bitcomblex.h
include/fxt/bitcombminchange.h
+include/fxt/bitcopy.h
include/fxt/bitcount.h
include/fxt/bitcyclic.h
+include/fxt/bitcyclic2.h
+include/fxt/bitgather.h
include/fxt/bithigh.h
+include/fxt/bitinvolutions.h
+include/fxt/bitlex.h
include/fxt/bitlow.h
+include/fxt/bitmat.h
include/fxt/bitmisc.h
+include/fxt/bitmrotate.h
+include/fxt/bitpol.h
+include/fxt/bitpolirred.h
+include/fxt/bitpolmodmult.h
+include/fxt/bitpolmodmultrev.h
+include/fxt/bitpoltrace.h
include/fxt/bitrotate.h
include/fxt/bitsequency.h
include/fxt/bitsperlong.h
@@ -37,6 +52,8 @@ include/fxt/comblazy.h
include/fxt/comblex.h
include/fxt/combminchange.h
include/fxt/complextype.h
+include/fxt/compositionalt.h
+include/fxt/compositionlex.h
include/fxt/constants.h
include/fxt/convex.h
include/fxt/copy.h
@@ -51,6 +68,7 @@ include/fxt/diskaux.h
include/fxt/dslazy.h
include/fxt/dyadiccnvl.h
include/fxt/factor.h
+include/fxt/fcsr.h
include/fxt/fhtmulsqr.h
include/fxt/funcemu.h
include/fxt/fxt.h
@@ -61,6 +79,7 @@ include/fxt/fxtmult.h
include/fxt/fxttypes.h
include/fxt/graycode.h
include/fxt/graypermute.h
+include/fxt/grayrevpermute.h
include/fxt/greencode.h
include/fxt/haarnn.h
include/fxt/haarnninplace.h
@@ -72,15 +91,21 @@ include/fxt/inline.h
include/fxt/intarith.h
include/fxt/jjassert.h
include/fxt/ldn2rc.h
+include/fxt/lfsr.h
+include/fxt/lfsr64.h
+include/fxt/lhca.h
include/fxt/lowbitprimpoly.h
include/fxt/matrix.h
include/fxt/matrixsymmetryq.h
include/fxt/minmax.h
include/fxt/minmax2d.h
+include/fxt/minweightlhcarule.h
include/fxt/minweightprimpoly.h
include/fxt/misc.h
include/fxt/misc2d.h
+include/fxt/mixedradix.h
include/fxt/mixedradixgray.h
+include/fxt/mixedradixlex.h
include/fxt/mmult.h
include/fxt/mod.h
include/fxt/modarith.h
@@ -89,11 +114,13 @@ include/fxt/modm.h
include/fxt/modularmixedradixgray.h
include/fxt/moduli.h
include/fxt/monotone.h
+include/fxt/monotonegray.h
include/fxt/mrotate.h
include/fxt/mtypes.h
include/fxt/ntt.h
include/fxt/orderedrarray.h
include/fxt/paren.h
+include/fxt/paren2.h
include/fxt/partition.h
include/fxt/permapply.h
include/fxt/permcyclic.h
@@ -138,7 +165,6 @@ include/fxt/searchidx.h
include/fxt/searchptr.h
include/fxt/shift.h
include/fxt/shift2d.h
-include/fxt/shiftregistersequence.h
include/fxt/shortfhtdifcore.h
include/fxt/shortfhtditcore.h
include/fxt/shortgraypermute.h
@@ -155,7 +181,6 @@ include/fxt/sortfunc.h
include/fxt/sortidx.h
include/fxt/sortlazy.h
include/fxt/sortptr.h
-include/fxt/srs64.h
include/fxt/stack.h
include/fxt/subsetdebruijn.h
include/fxt/subsetlex.h