aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-03-21 10:33:40 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-03-21 10:33:40 +0000
commit479345a67bff7f644cd3ecdbabac1364b7a73c2d (patch)
tree65221dc1821978e2b45ab31daa88230f869aaf17
parentdc316315a89846bdbb3a6411cb0779ef01bf11f6 (diff)
downloadports-479345a67bff7f644cd3ecdbabac1364b7a73c2d.tar.gz
ports-479345a67bff7f644cd3ecdbabac1364b7a73c2d.zip
Notes
-rw-r--r--databases/mysql55-server/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/databases/mysql55-server/Makefile b/databases/mysql55-server/Makefile
index 2550307d5e3d..532a71499367 100644
--- a/databases/mysql55-server/Makefile
+++ b/databases/mysql55-server/Makefile
@@ -14,7 +14,7 @@ COMMENT?= Multithreaded SQL database (server)
LICENSE= GPLv2
SLAVEDIRS= databases/mysql55-client
-USES= cmake:insource,noninja compiler:c++11-lang readline shebangfix
+USES= cmake:insource,noninja readline shebangfix
CXXFLAGS+= ${CPPFLAGS}
NO_OPTIONS_SORT=yes
@@ -50,6 +50,14 @@ SHEBANG_FILES= scripts/*.pl* scripts/*.sh
.include <bsd.port.options.mk>
+.if defined(PPC_ABI) && ${PPC_ABI} == ELFv2
+USES+= compiler:gcc-c++11-lib
+USE_CXXSTD= gnu++11
+.else
+USES+= compiler:c++11-lang
+USE_CXXSTD= gnu++98
+.endif
+
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200057
SUB_LIST+= LEGACY_LIMITS="@comment " MODERN_LIMITS=""
.else