aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-04-13 04:11:02 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-04-13 04:11:02 +0000
commit482f6df82cb337a78d7c43b5fa9c9670fcbecdbf (patch)
tree86907bba0974735f951e4b7489ab339fa3606ad3
parentd89ef551cffaa1f3fe2d176a00bb70c809aadef7 (diff)
downloadports-482f6df82cb337a78d7c43b5fa9c9670fcbecdbf.tar.gz
ports-482f6df82cb337a78d7c43b5fa9c9670fcbecdbf.zip
Notes
-rw-r--r--x11/xsel/Makefile29
-rw-r--r--x11/xsel/pkg-descr2
2 files changed, 17 insertions, 14 deletions
diff --git a/x11/xsel/Makefile b/x11/xsel/Makefile
index c9cdc74afa1d..2abd6091a73e 100644
--- a/x11/xsel/Makefile
+++ b/x11/xsel/Makefile
@@ -1,33 +1,38 @@
-# Created by: ijliao
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
PORTNAME= xsel
PORTVERSION= 0.04.1
PORTREVISION= 5
CATEGORIES= x11
-MASTER_SITES= CENKES
-#http://www.niksula.cs.hut.fi/~vherva/xsel/xsel.{c,man}
+MASTER_SITES= http://BSDforge.com/projects/source/x11/xsel/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Access X selection from command line
+MAINTAINER= portmaster@BSDforge.com
+COMMENT= Access X11 selection buffer from command line
-BROKEN= No public distfiles
+LICENSE= MIT
-CONFLICTS= xsel-conrad-[0-9]*
-USES= tar:bzip2
+CONFLICTS_INSTALL= xsel-conrad-[0-9]*
+
+USES= tar:bzip2
USE_XORG= xmu xaw xt xproto xkbfile
+
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lXt -lXaw -lX11 -lXmu
+
PLIST_FILES= bin/${PORTNAME} man/man1/xsel.1.gz
PORTDOCS= ${PORTNAME}.html
+OPTIONS_DEFINE= DOCS
+
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} xsel.c -o xsel ${LDFLAGS}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man ${STAGEDIR}${MAN1PREFIX}/man/man1/${PORTNAME}.1
- ${INSTALL} -d ${STAGEDIR}${DOCSDIR}/
- cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1/${PORTNAME}.1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/x11/xsel/pkg-descr b/x11/xsel/pkg-descr
index a28700be1d62..22cd9e3a1069 100644
--- a/x11/xsel/pkg-descr
+++ b/x11/xsel/pkg-descr
@@ -1,5 +1,3 @@
xsel is a quick hack to give access to the X selection from the command line.
You can paste stuff from the X selection to stdout and copy stuff from stdin
to X selection.
-
-WWW: http://www.niksula.cs.hut.fi/~vherva/xsel/