aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2005-10-07 07:05:16 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2005-10-07 07:05:16 +0000
commit486bebf7153d51871592d480721d7f3c6540c631 (patch)
tree351c9bcf5db5dec1d6e20be6b31c29ea437ff2ae
parentbf2b195e00f981d150baf43629d86ba389f9034c (diff)
Notes
-rw-r--r--sysutils/cfengine2/Makefile1
-rw-r--r--sysutils/cfengine2/files/patch-CAN-2005-296030
2 files changed, 31 insertions, 0 deletions
diff --git a/sysutils/cfengine2/Makefile b/sysutils/cfengine2/Makefile
index 5b7cb0d6ebe0..0584dc8f7f2f 100644
--- a/sysutils/cfengine2/Makefile
+++ b/sysutils/cfengine2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cfengine
PORTVERSION= 2.1.16
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.iu.hio.no/pub/cfengine/ \
${MASTER_SITE_GNU}
diff --git a/sysutils/cfengine2/files/patch-CAN-2005-2960 b/sysutils/cfengine2/files/patch-CAN-2005-2960
new file mode 100644
index 000000000000..25e497f10556
--- /dev/null
+++ b/sysutils/cfengine2/files/patch-CAN-2005-2960
@@ -0,0 +1,30 @@
+diff -u -p -Nr --exclude CVS contrib/vicf.in.orig contrib/vicf.in
+--- contrib/vicf.in.orig 2005-02-08 12:48:56.000000000 +0100
++++ contrib/vicf.in 2005-09-23 12:11:34.000000000 +0200
+@@ -56,12 +56,13 @@ EdFile () {
+ while [ "$editfile" = "n" ]
+ do
+ ${EDITOR} ${CFINPUTS}/.${file}.lock
+- cp /dev/null /tmp/cfparse.$$
+- $sbindir/cfengine --no-warn --parse-only --file ${CFINPUTS}/.${file}.lock > /tmp/cfparse.$$ 2>&1
+- if [ -s /tmp/cfparse.$$ ]
++ tmpfile=`mktemp -t tempfile.XXXXXX` || { echo "$0: Cannot create temporary file" >&2; exit 1; }
++ trap " [ -f \"$tmpfile\" ] && /bin/rm -f -- \"$tmpfile\"" 0 1 2 3 13 15
++ $sbindir/cfengine --no-warn --parse-only --file ${CFINPUTS}/.${file}.lock > $tmpfile 2>&1
++ if [ -s $tmpfile ]
+ then
+ echo PARSE ERROR IN NEW INPUT-FILE:
+- cat /tmp/cfparse.$$
++ cat $tmpfile
+ /usr/ucb/echo -n "Re-edit file? (Y/n) "
+ read answer
+ if [ "$answer" = "n" ]
+@@ -75,7 +76,7 @@ EdFile () {
+ fi
+ done
+
+- rm -f /tmp/cfparse.$$ ${CFINPUTS}/.${file}.lock
++ rm -f ${CFINPUTS}/.${file}.lock
+ }
+
+ force=n