aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-23 09:18:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-23 09:18:57 +0000
commit48777d6973790ebe72953c3031e247dfd2fb45c4 (patch)
treee90eca5d845a8b6e747df383c5f477a2e427c489
parentb4b07a8bb2c91f8aea228c646e1d69037f91acc0 (diff)
downloadports-48777d6973790ebe72953c3031e247dfd2fb45c4.tar.gz
ports-48777d6973790ebe72953c3031e247dfd2fb45c4.zip
Notes
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/deegree-igeoportal/Makefile46
-rw-r--r--graphics/deegree-igeoportal/distinfo3
-rw-r--r--graphics/deegree-igeoportal/pkg-descr5
-rw-r--r--graphics/deegree-igeoportal/pkg-message10
5 files changed, 65 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index b48c457dd9ff..10695940f828 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -91,6 +91,7 @@
SUBDIR += dc3play
SUBDIR += dcraw
SUBDIR += deegree-csw
+ SUBDIR += deegree-igeoportal
SUBDIR += demeter
SUBDIR += devil
SUBDIR += dia
diff --git a/graphics/deegree-igeoportal/Makefile b/graphics/deegree-igeoportal/Makefile
new file mode 100644
index 000000000000..9be45d8783cd
--- /dev/null
+++ b/graphics/deegree-igeoportal/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: deegree-igeoportal
+# Date created: 17 April, 2009
+# Whom: wenheping@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= igeoportal
+PORTVERSION= 2.2
+CATEGORIES= graphics java
+MASTER_SITES= http://download.deegree.org/deegree${PORTVERSION}/
+PKGNAMEPREFIX= deegree-
+DISTNAME= ${PORTNAME}-std_v${PORTVERSION:S/./_/}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Browserbased Client Handling WMS, WFS and Proxy Service
+
+RUN_DEPENDS= ${TOMCATDIR}:${PORTSDIR}/www/tomcat55
+
+USE_ZIP= yes
+USE_JAVA= 1.5+
+
+NO_BUILD= yes
+TOMCATVER= tomcat5.5
+TOMCATDIR= ${PREFIX}/${TOMCATVER}
+TOMCATOWN= www
+TOMCATGRP= www
+WEBAPPDIR= ${TOMCATDIR}/webapps
+PORTDOCS= *
+DOCSDIR= ${PREFIX}/share/doc/deegree-igeoportal
+PLIST_FILES= ${TOMCATVER}/webapps/igeoportal-std.war
+
+do-install:
+ cd ${WRKDIR} && \
+ ${INSTALL} -g ${TOMCATGRP} -o ${TOMCATOWN} -m 444 igeoportal-std.war ${WEBAPPDIR};
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/README_igeoportal.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/deegree_igeoportal_documentation_en.pdf ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/graphics/deegree-igeoportal/distinfo b/graphics/deegree-igeoportal/distinfo
new file mode 100644
index 000000000000..2eb52269de6c
--- /dev/null
+++ b/graphics/deegree-igeoportal/distinfo
@@ -0,0 +1,3 @@
+MD5 (igeoportal-std_v2_2.zip) = 44cbc07e3c4e61adf6721747bf964127
+SHA256 (igeoportal-std_v2_2.zip) = de4cfbbfabfbebb94a9dddf85f30c755ffe357a6618e657b0b9b09e6e2601200
+SIZE (igeoportal-std_v2_2.zip) = 15889141
diff --git a/graphics/deegree-igeoportal/pkg-descr b/graphics/deegree-igeoportal/pkg-descr
new file mode 100644
index 000000000000..a3868a1854f5
--- /dev/null
+++ b/graphics/deegree-igeoportal/pkg-descr
@@ -0,0 +1,5 @@
+Deegree iGeoPortal is the web-based portal framework of deegree. It
+offers visualization of geodata through a standard web browser like
+Mozilla, Firefox or MSIE.
+
+WWW: http://www.deegree.org/
diff --git a/graphics/deegree-igeoportal/pkg-message b/graphics/deegree-igeoportal/pkg-message
new file mode 100644
index 000000000000..13df82f03621
--- /dev/null
+++ b/graphics/deegree-igeoportal/pkg-message
@@ -0,0 +1,10 @@
+==========================================================================
+To start DeeGree correctly, please set the variable JAVA_OPTS with:
+
+setenv JAVA_OPTS "-server -Xms256m -Xmx512m"
+
+Now you should start your Tomcat server and browse with:
+ http://your-server:8180/deegree-wcs
+
+Enjoy it !
+==========================================================================