aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-07-14 14:15:11 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-07-14 14:15:11 +0000
commit4934b4116e8bedd51afe5061728fd1e45a2aaa9a (patch)
tree45ce8e55b0b4976ac1e5a1a0f70ed9c5dac05b47
parentbc1e93a03536cf1d67f6eeb667627f58798579ae (diff)
downloadports-4934b4116e8bedd51afe5061728fd1e45a2aaa9a.tar.gz
ports-4934b4116e8bedd51afe5061728fd1e45a2aaa9a.zip
Notes
-rw-r--r--print/Makefile1
-rw-r--r--print/epson-inkjet-printer-201401w/Makefile53
-rw-r--r--print/epson-inkjet-printer-201401w/distinfo5
-rw-r--r--print/epson-inkjet-printer-201401w/pkg-descr19
-rw-r--r--print/epson-inkjet-printer-201401w/pkg-plist49
5 files changed, 127 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 6ebd1808c543..c0ed27d779e6 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -41,6 +41,7 @@
SUBDIR += enscript-a4
SUBDIR += enscript-letter
SUBDIR += enscript-letterdj
+ SUBDIR += epson-inkjet-printer-201401w
SUBDIR += epson-inkjet-printer-escpr
SUBDIR += epsonepl
SUBDIR += fig2dev
diff --git a/print/epson-inkjet-printer-201401w/Makefile b/print/epson-inkjet-printer-201401w/Makefile
new file mode 100644
index 000000000000..cfcdeb923ba2
--- /dev/null
+++ b/print/epson-inkjet-printer-201401w/Makefile
@@ -0,0 +1,53 @@
+# $FreeBSD$
+
+PORTNAME= epson-inkjet-printer-201401w
+PORTVERSION= 1.0.0
+CATEGORIES= print
+MASTER_SITES= https://download3.ebz.epson.net/dsc/f/03/00/03/45/41/d95c03482376873661d7a8d4c165b385cd082cf3/:amd64 \
+ https://download3.ebz.epson.net/dsc/f/03/00/03/45/41/0c527f1eef727e350302db951a45d31319ee501b/:i386
+DISTFILES_amd64=${DISTNAME}-1lsb3.2.x86_64.rpm:amd64
+DISTFILES_i386= ${DISTNAME}-1lsb3.2.i486.rpm:i386
+
+MAINTAINER= hello@blubee.me
+COMMENT= CUPS filter for Seiko Epson Color Ink Jet Printers
+
+LICENSE= EPSON LGPL21
+LICENSE_COMB= multi
+LICENSE_NAME_EPSON= SEIKO EPSON CORPORATION SOFTWARE LICENSE AGREEMENT
+LICENSE_FILE_EPSON= ${WRKSRC}/opt/${PORTNAME}/doc/COPYING.EPSON
+LICENSE_FILE_LGPL21= ${WRKSRC}/opt/${PORTNAME}/doc/COPYING.LIB
+LICENSE_PERMS_EPSON= none
+
+RUN_DEPENDS= ${LOCALBASE}/libexec/cups/filter/gstoraster:print/cups-filters
+
+RESTRICTED= License does not allow redistribution
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+PLIST_SUB= LINUXBASE=${LINUXBASE} \
+ PORTNAME=${PORTNAME}
+USES= linux
+USE_LINUX= cups-libs jpeg
+
+.include <bsd.port.pre.mk>
+
+.if ${LINUX_ARCH} == i386
+PLIST_SUB+= LIBDIR=lib
+.elif ${LINUX_ARCH} == x86_64
+PLIST_SUB+= LIBDIR=lib64
+.endif
+
+post-extract:
+ @${GUNZIP_CMD} ${WRKSRC}/opt/${PORTNAME}/ppds/Epson/*.ppd.gz
+
+post-patch:
+ @${SED} -i '' '/^\*cupsFilter:/s,/opt/,${LINUXBASE}&,' \
+ ${WRKSRC}/opt/${PORTNAME}/ppds/Epson/*.ppd
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${LINUXBASE}
+ ${CP} -Rp ${WRKSRC}/opt ${STAGEDIR}${LINUXBASE}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/cups/model/
+ ${LN} -sf ${LINUXBASE}/opt/${PORTNAME}/ppds/Epson ${STAGEDIR}${PREFIX}/share/cups/model/Epson-201401w
+
+.include <bsd.port.post.mk>
diff --git a/print/epson-inkjet-printer-201401w/distinfo b/print/epson-inkjet-printer-201401w/distinfo
new file mode 100644
index 000000000000..be14d802ffd0
--- /dev/null
+++ b/print/epson-inkjet-printer-201401w/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1499931076
+SHA256 (epson-inkjet-printer-201401w-1.0.0-1lsb3.2.i486.rpm) = fa9276e227990a837aa60b670df661754cbfc34e04267da75752f3022f09d75c
+SIZE (epson-inkjet-printer-201401w-1.0.0-1lsb3.2.i486.rpm) = 1997093
+SHA256 (epson-inkjet-printer-201401w-1.0.0-1lsb3.2.x86_64.rpm) = d75081eb87fd3a212a284f5cf4d781a3160daacdc59078f570a86c4773c3ed3f
+SIZE (epson-inkjet-printer-201401w-1.0.0-1lsb3.2.x86_64.rpm) = 2020919
diff --git a/print/epson-inkjet-printer-201401w/pkg-descr b/print/epson-inkjet-printer-201401w/pkg-descr
new file mode 100644
index 000000000000..34cc8af6a3db
--- /dev/null
+++ b/print/epson-inkjet-printer-201401w/pkg-descr
@@ -0,0 +1,19 @@
+This software is a filter program used with Common UNIX Printing
+System (CUPS) from the Linux. This can supply the high quality print
+with Seiko Epson Color Ink Jet Printers.
+
+This printer driver is supporting the following printers.
+L456
+L455
+L366
+L365
+L362
+L360
+L312
+L310
+L222
+L220
+L132
+L130
+
+WWW: http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
diff --git a/print/epson-inkjet-printer-201401w/pkg-plist b/print/epson-inkjet-printer-201401w/pkg-plist
new file mode 100644
index 000000000000..de2341043e30
--- /dev/null
+++ b/print/epson-inkjet-printer-201401w/pkg-plist
@@ -0,0 +1,49 @@
+%%LINUXBASE%%/opt/%%PORTNAME%%/cups/lib/filter/epson_inkjet_printer_filter
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/AUTHORS
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/COPYING
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/COPYING.EPSON
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/COPYING.LIB
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/Manual.txt
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/README
+%%LINUXBASE%%/opt/%%PORTNAME%%/%%LIBDIR%%/libEpson_201401w.MT.so.1.0.0
+%%LINUXBASE%%/opt/%%PORTNAME%%/%%LIBDIR%%/libEpson_201401w.so.1.0.0
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L130_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L132_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L220_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L222_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L310_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L312_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L360_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L362_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L365_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L366_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L455_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L456_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/resource/Epson_201401w.1.data
+%%LINUXBASE%%/opt/%%PORTNAME%%/resource/Epson_201401w.MT.1.data
+%%LINUXBASE%%/opt/%%PORTNAME%%/resource/Epson_201401w.MT.2.data
+%%LINUXBASE%%/opt/%%PORTNAME%%/resource/Epson_201401w.MT.3.data
+%%LINUXBASE%%/opt/%%PORTNAME%%/resource/Epson_201401w.MT.4.data
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG00.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG01.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG02.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG03.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG04.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG05.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG06.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG07.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG08.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG09.EID
+share/cups/model/Epson-201401w
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/cups/lib/filter
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/cups/lib
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/cups
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/doc
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/%%LIBDIR%%
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/ppds
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/resource
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/watermark
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%
+@dir %%LINUXBASE%%/opt
+@dir %%LINUXBASE%%