aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-06-12 22:42:39 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-06-12 22:42:39 +0000
commit49bc989c46c29566e95d26ccb2604aae9352e296 (patch)
tree5ac4d2ecbc741ac9b79db6810bb88ca28eb74edc
parentcb00e89e4a6d067a6d7fe97b1cdb636f41dcdfbd (diff)
downloadports-49bc989c46c29566e95d26ccb2604aae9352e296.tar.gz
ports-49bc989c46c29566e95d26ccb2604aae9352e296.zip
Notes
-rw-r--r--misc/gkrellshoot2/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/misc/gkrellshoot2/Makefile b/misc/gkrellshoot2/Makefile
index f5ebbd6bbcf9..d87fa8f8724f 100644
--- a/misc/gkrellshoot2/Makefile
+++ b/misc/gkrellshoot2/Makefile
@@ -11,18 +11,23 @@ PKGNAMESUFFIX= 2
MAINTAINER= ports@FreeBSD.org
COMMENT= Screen locking and screen capture plugin for GKrellM 2
-USES= pkgconfig
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2 \
import:${PORTSDIR}/graphics/ImageMagick
+USES= pkgconfig
+
PLIST_FILES= libexec/gkrellm2/plugins/gkrellshoot.so
WRKSRC= ${WRKDIR}/gkrellShoot-${PORTVERSION}
ALL_TARGET= ${PORTNAME}.so
+PLUGINDIR= ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins
+
+post-patch:
+ @${REINPLACE_CMD} '/^CFLAGS/ s|= |= ${CFLAGS} |' ${WRKSRC}/Makefile
-NO_STAGE= yes
do-install:
- @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.so ${PREFIX}/libexec/gkrellm2/plugins
+ @${MKDIR} ${PLUGINDIR}
+ ${INSTALL_LIB} ${WRKSRC}/${PORTNAME}.so ${PLUGINDIR}
.include <bsd.port.mk>