aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-02-01 12:25:46 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-02-01 12:25:46 +0000
commit4ab47432678d685360e529fe701d8787c88dc7a6 (patch)
tree9ffcf47466cf6bf8528134ba0aad263bc9a67220
parent3a2f943a326128b005180fcebd9e5ccc0bd5257b (diff)
downloadports-4ab47432678d685360e529fe701d8787c88dc7a6.tar.gz
ports-4ab47432678d685360e529fe701d8787c88dc7a6.zip
Notes
-rw-r--r--games/xmemory/Makefile2
-rw-r--r--games/xmemory/files/patch-gif__image.C13
2 files changed, 14 insertions, 1 deletions
diff --git a/games/xmemory/Makefile b/games/xmemory/Makefile
index 9c361c139096..7d19789fcc05 100644
--- a/games/xmemory/Makefile
+++ b/games/xmemory/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xmemory
PORTVERSION= 3.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= XCONTRIB/games/multiplayer
diff --git a/games/xmemory/files/patch-gif__image.C b/games/xmemory/files/patch-gif__image.C
new file mode 100644
index 000000000000..ac3b3026e31d
--- /dev/null
+++ b/games/xmemory/files/patch-gif__image.C
@@ -0,0 +1,13 @@
+--- gif_image.C.orig 1996-07-04 20:36:15 UTC
++++ gif_image.C
+@@ -58,8 +58,8 @@ GifImage::GifImage(const char *filename,
+ : lockcount(0) {
+ first=0;
+ LoadGIF( filename );
+- name = strrchr(filename,'/');
+- if (name) name=strdup(name+1);
++ const char *pos = strrchr(filename,'/');
++ if (pos) name=strdup(pos+1);
+ else name=strdup(filename);
+
+ if (autocrop&&!fastinfo_flag) CropImage();