aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-08-02 13:16:57 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-08-02 13:16:57 +0000
commit4ac916381e0c8da65a35cd0fce03157236b2c106 (patch)
tree2c53aa9514d149c4ed255106859f35636f77c532
parente58ceb5b651ada391f160c35320beec3d50e12ca (diff)
downloadports-4ac916381e0c8da65a35cd0fce03157236b2c106.tar.gz
ports-4ac916381e0c8da65a35cd0fce03157236b2c106.zip
Notes
-rw-r--r--math/Makefile1
-rw-r--r--math/pdal/Makefile61
-rw-r--r--math/pdal/distinfo2
-rw-r--r--math/pdal/files/patch-src-Utils.cpp10
-rw-r--r--math/pdal/pkg-descr10
-rw-r--r--math/pdal/pkg-plist122
6 files changed, 206 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 56472ac3106f..19e30fc6942b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -519,6 +519,7 @@
SUBDIR += pari
SUBDIR += parmetis
SUBDIR += parmgridgen
+ SUBDIR += pdal
SUBDIR += pear-Math_BigInteger
SUBDIR += pear-Math_Combinatorics
SUBDIR += pecl-big_int
diff --git a/math/pdal/Makefile b/math/pdal/Makefile
new file mode 100644
index 000000000000..c57dd0e00a67
--- /dev/null
+++ b/math/pdal/Makefile
@@ -0,0 +1,61 @@
+# Created by: bart <bart@bureau>
+# $FreeBSD$
+
+PORTNAME= pdal
+PORTVERSION= 0.9.8
+CATEGORIES= databases math graphics
+MASTER_SITES= http://github.com/PDAL/PDAL/archive/${PORTVERSION}.tar.gz?dummy=/
+
+MAINTAINER= coder@tuxfamily.org
+COMMENT= Library for translating and manipulating point cloud data
+
+LICENSE= BSD3CLAUSE
+
+WRKSRC= ${WRKDIR}/PDAL-${PORTVERSION}
+
+USES= cmake compiler
+compiler_ARGS= c++11-lang
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= GDAL GEOTIFF LIBXML2 EMBED_BOOST
+OPTIONS_DEFAULT= GDAL GEOTIFF LIBXML2
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGDAL}
+CMAKE_ARGS+= -DWITH_GDAL:BOOL=TRUE
+LIB_DEPENDS+= libgdal.so:${PORTSDIR}/graphics/gdal
+PLIST_SUB+= GDAL=""
+.else
+CMAKE_ARGS+= -DWITH_GDAL:BOOL=FALSE
+PLIST_SUB+= GDAL="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MGEOTIFF}
+CMAKE_ARGS+= -DWITH_GEOTIFF:BOOL=TRUE
+LIB_DEPENDS+= libgeotiff.so:${PORTSDIR}/graphics/libgeotiff
+PLIST_SUB+= GEOTIFF=""
+.else
+CMAKE_ARGS+= -DWITH_GEOTIFF:BOOL=FALSE
+PLIST_SUB+= GEOTIFF="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MLIBXML2}
+CMAKE_ARGS+= -DWITH_LIBXML2:BOOL=TRUE
+LIB_DEPENDS+= libxml2.so:${PORTSDIR}/textproc/libxml2
+PLIST_SUB+= LIBXML2=""
+.else
+CMAKE_ARGS+= -DWITH_LIBXML2:BOOL=FALSE
+PLIST_SUB+= LIBXML2="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MEMBED_BOOST}
+CMAKE_ARGS+= -DPDAL_EMBED_BOOST:BOOL=TRUE
+PLIST_SUB+= EMBED_BOOST=""
+.else
+CMAKE_ARGS+= -DPDAL_EMBED_BOOST:BOOL=FALSE
+LIB_DEPENDS+= libboost_thread.so:${PORTSDIR}/devel/boost-libs
+PLIST_SUB+= EMBED_BOOST="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/pdal/distinfo b/math/pdal/distinfo
new file mode 100644
index 000000000000..c09403f2f6a9
--- /dev/null
+++ b/math/pdal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pdal-0.9.8.tar.gz) = aef41ae7c8b87541eb9cc11c2e17f086ac26799f3e4da0f19f8e78e0538060ff
+SIZE (pdal-0.9.8.tar.gz) = 11046030
diff --git a/math/pdal/files/patch-src-Utils.cpp b/math/pdal/files/patch-src-Utils.cpp
new file mode 100644
index 000000000000..8615706edd13
--- /dev/null
+++ b/math/pdal/files/patch-src-Utils.cpp
@@ -0,0 +1,10 @@
+--- src/Utils.cpp.orig 2014-07-27 19:02:59.456832475 +0200
++++ src/Utils.cpp 2014-07-27 19:03:23.513363445 +0200
+@@ -37,6 +37,7 @@
+ #include <cassert>
+ #include <cstdlib>
+ #include <cctype>
++#include <sys/wait.h>
+
+ #ifdef PDAL_COMPILER_MSVC
+ # pragma warning(disable: 4127) // conditional expression is constant
diff --git a/math/pdal/pkg-descr b/math/pdal/pkg-descr
new file mode 100644
index 000000000000..db0ab474dd56
--- /dev/null
+++ b/math/pdal/pkg-descr
@@ -0,0 +1,10 @@
+PDAL is a BSD licensed library for translating and manipulating
+point cloud data of various formats. It is a library that is
+analogous to the GDAL raster library. PDAL is focussed on reading,
+writing, and translating point cloud data from the ever-growing
+constellation of data formats that are being developed for working
+with multi-dimensional emitted-pulse scanning systems. While PDAL is
+ not explicitly limited to working with LiDAR data formats, its
+initial rollout is focused in that area.
+
+WWW: http://www.pdal.io/
diff --git a/math/pdal/pkg-plist b/math/pdal/pkg-plist
new file mode 100644
index 000000000000..0672e3168e4b
--- /dev/null
+++ b/math/pdal/pkg-plist
@@ -0,0 +1,122 @@
+bin/pc2pc
+bin/pcequal
+bin/pcinfo
+bin/pcpipeline
+bin/pcquery
+bin/pdal-config
+include/pdal/Bounds.hpp
+include/pdal/Dimension.hpp
+include/pdal/Endian.hpp
+include/pdal/FileUtils.hpp
+include/pdal/Filter.hpp
+include/pdal/FilterIterator.hpp
+include/pdal/GDALUtils.hpp
+include/pdal/GlobalEnvironment.hpp
+include/pdal/Log.hpp
+include/pdal/Metadata.hpp
+include/pdal/MultiFilter.hpp
+include/pdal/MultiFilterIterator.hpp
+include/pdal/Object.hpp
+include/pdal/Options.hpp
+include/pdal/PipelineManager.hpp
+include/pdal/PipelineReader.hpp
+include/pdal/PipelineWriter.hpp
+include/pdal/PointBuffer.hpp
+include/pdal/Range.hpp
+include/pdal/Reader.hpp
+include/pdal/ReaderIterator.hpp
+include/pdal/Schema.hpp
+include/pdal/SpatialReference.hpp
+include/pdal/Stage.hpp
+include/pdal/StageBase.hpp
+include/pdal/StageFactory.hpp
+include/pdal/StageIterator.hpp
+include/pdal/StreamFactory.hpp
+include/pdal/ThreadEnvironment.hpp
+include/pdal/UserCallback.hpp
+include/pdal/Utils.hpp
+include/pdal/Vector.hpp
+include/pdal/Writer.hpp
+include/pdal/XMLSchema.hpp
+include/pdal/drivers/buffer/Reader.hpp
+include/pdal/drivers/caris/CloudIterator.hpp
+include/pdal/drivers/caris/CloudReader.hpp
+include/pdal/drivers/faux/Reader.hpp
+include/pdal/drivers/faux/Writer.hpp
+include/pdal/drivers/las/Header.hpp
+include/pdal/drivers/las/Reader.hpp
+include/pdal/drivers/las/ReaderBase.hpp
+include/pdal/drivers/las/SummaryData.hpp
+include/pdal/drivers/las/Support.hpp
+include/pdal/drivers/las/VariableLengthRecord.hpp
+include/pdal/drivers/las/Writer.hpp
+include/pdal/drivers/mrsid/Reader.hpp
+include/pdal/drivers/nitf/Reader.hpp
+include/pdal/drivers/nitf/Writer.hpp
+include/pdal/drivers/oci/Reader.hpp
+include/pdal/drivers/oci/Writer.hpp
+include/pdal/drivers/oci/common.hpp
+include/pdal/drivers/oci/oci_wrapper.h
+include/pdal/drivers/p2g/Writer.hpp
+include/pdal/drivers/pgpointcloud/Reader.hpp
+include/pdal/drivers/pgpointcloud/Writer.hpp
+include/pdal/drivers/pgpointcloud/common.hpp
+include/pdal/drivers/pipeline/Reader.hpp
+include/pdal/drivers/qfit/Reader.hpp
+include/pdal/drivers/soci/Reader.hpp
+include/pdal/drivers/soci/Writer.hpp
+include/pdal/drivers/soci/common.hpp
+include/pdal/drivers/terrasolid/Reader.hpp
+include/pdal/drivers/text/Writer.hpp
+include/pdal/filters/ByteSwap.hpp
+include/pdal/filters/Cache.hpp
+include/pdal/filters/Chipper.hpp
+include/pdal/filters/Color.hpp
+include/pdal/filters/Colorization.hpp
+include/pdal/filters/Crop.hpp
+include/pdal/filters/Decimation.hpp
+include/pdal/filters/HexBin.hpp
+include/pdal/filters/InPlaceReprojection.hpp
+include/pdal/filters/Index.hpp
+include/pdal/filters/Mosaic.hpp
+include/pdal/filters/PointBufferCache.hpp
+include/pdal/filters/Predicate.hpp
+include/pdal/filters/Programmable.hpp
+include/pdal/filters/Reprojection.hpp
+include/pdal/filters/Scaling.hpp
+include/pdal/filters/Selector.hpp
+include/pdal/filters/Stats.hpp
+include/pdal/gitsha.h
+include/pdal/pdal_config.hpp
+include/pdal/pdal_defines.h
+include/pdal/pdal_error.hpp
+include/pdal/pdal_export.hpp
+include/pdal/pdal_internal.hpp
+include/pdal/pdal_macros.hpp
+include/pdal/pdal_types.hpp
+include/pdal/plang/BufferedInvocation.hpp
+include/pdal/plang/Invocation.hpp
+include/pdal/plang/PythonEnvironment.hpp
+include/pdal/plang/Script.hpp
+include/pdal/third/nanoflann.hpp
+lib/libpdal.so
+lib/libpdal.so.0
+@dirrmtry include/pdal/drivers/buffer
+@dirrmtry include/pdal/drivers/caris
+@dirrmtry include/pdal/drivers/faux
+@dirrmtry include/pdal/drivers/las
+@dirrmtry include/pdal/drivers/mrsid
+@dirrmtry include/pdal/drivers/nitf
+@dirrmtry include/pdal/drivers/oci
+@dirrmtry include/pdal/drivers/p2g
+@dirrmtry include/pdal/drivers/pgpointcloud
+@dirrmtry include/pdal/drivers/pipeline
+@dirrmtry include/pdal/drivers/qfit
+@dirrmtry include/pdal/drivers/soci
+@dirrmtry include/pdal/drivers/terrasolid
+@dirrmtry include/pdal/drivers/text
+@dirrmtry include/pdal/drivers
+@dirrmtry include/pdal/filters
+@dirrmtry include/pdal/plang
+@dirrmtry include/pdal/third
+@dirrmtry include/pdal