aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-09-27 13:55:41 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-09-27 13:55:41 +0000
commit4bcccab0018368e9c3b7d4f615440a2702a3963c (patch)
tree4188586c931e519ee116bbf10e4df92b7d631c90
parent6b028c509da9a7c1381eac1e236f8e15b6232a09 (diff)
downloadports-4bcccab0018368e9c3b7d4f615440a2702a3963c.tar.gz
ports-4bcccab0018368e9c3b7d4f615440a2702a3963c.zip
Notes
-rw-r--r--Mk/bsd.ruby.mk7
-rw-r--r--lang/ruby-devel/Makefile7
-rw-r--r--lang/ruby-devel/distinfo4
-rw-r--r--lang/ruby-devel/pkg-message2
-rw-r--r--lang/ruby16_static/Makefile14
-rw-r--r--lang/ruby18/Makefile7
-rw-r--r--lang/ruby18/distinfo4
-rw-r--r--lang/ruby18/pkg-message2
-rw-r--r--lang/ruby18_static/Makefile2
-rw-r--r--lang/ruby_static-devel/Makefile2
-rw-r--r--lang/ruby_static/Makefile14
11 files changed, 13 insertions, 52 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 70b2e7196846..f7fc528d9df1 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -109,10 +109,9 @@ RUBY?= ${LOCALBASE}/bin/${RUBY_NAME}
.if defined(RUBY_VER) && ${RUBY_VER} == 1.7
RUBY_VERSION?= 1.7.3
RUBY_PORT?= lang/ruby${RUBY_R}-devel
-RUBY_DISTVERSION?= ${RUBY_VER}-2002.09.12
-RUBY_PATCHFILES?= ruby-${RUBY_DISTVERSION}-2002.09.17.diff.bz2 \
- ruby-${RUBY_VER}-2002.09.17-2002.09.20.diff.bz2
-RUBY_PORTVERSION?= ${RUBY_VERSION}.2002.09.20
+RUBY_DISTVERSION?= ${RUBY_VERSION}-2002.09.27
+#RUBY_PATCHFILES?= ruby-${RUBY_DISTVERSION}-yyyy.mm.dd.diff.bz2
+RUBY_PORTVERSION?= ${RUBY_VERSION}.2002.09.27
.else
RUBY_VERSION?= 1.6.7
RUBY_DISTVERSION?= ${RUBY_VERSION}-2002.09.12
diff --git a/lang/ruby-devel/Makefile b/lang/ruby-devel/Makefile
index eb2b0e000da7..86b1fb40769b 100644
--- a/lang/ruby-devel/Makefile
+++ b/lang/ruby-devel/Makefile
@@ -24,8 +24,6 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
-
.if defined(WITH_ONIGURUMA)
ONIGURUMA_MASTER_SITES= ${MASTER_SITE_RUBY}
ONIGURUMA_MASTER_SITE_SUBDIR= contrib
@@ -45,12 +43,12 @@ RUBY_NO_RUN_DEPENDS= yes
#USE_AUTOCONF= yes # does not work with 2.13; requires 2.53 or later
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
WRKSRC= ${RUBY_WRKSRC}
CONFIGURE_ARGS= ${RUBY_CONFIGURE_ARGS} \
--enable-shared
MAKE_ENV= LANG=C # prevent bison 1.33 w/ gettext 0.10.35 from coredumping
MAKE_ARGS= -j3
+INSTALLS_SHLIB= yes
MAN1= ruby${_RUBY_SUFFIX}.1
LATEST_LINK= ruby-devel
@@ -110,9 +108,6 @@ post-patch:
${MV} ${WRKSRC}/ext/${d} ${WRKDIR}/
.endfor
-pre-configure:
- cd ${WRKSRC}; autoconf
-
pre-install:
${RM} -f ${RUBY_WITHOUT_SUFFIX}${RUBY_R} \
${PREFIX}/man/man1/ruby${RUBY_R}.1 \
diff --git a/lang/ruby-devel/distinfo b/lang/ruby-devel/distinfo
index 5c12f472cbc0..5825638d6ece 100644
--- a/lang/ruby-devel/distinfo
+++ b/lang/ruby-devel/distinfo
@@ -1,4 +1,2 @@
-MD5 (ruby/ruby-1.7-2002.09.12.tar.bz2) = 4f85e9368137db51eab34e14f2301efa
-MD5 (ruby/ruby-1.7-2002.09.12-2002.09.17.diff.bz2) = ffe16aadf69c9d8f9552536f4803020b
-MD5 (ruby/ruby-1.7-2002.09.17-2002.09.20.diff.bz2) = a4a9f9d197c1014b13ad165d3034a98d
+MD5 (ruby/ruby-1.7.3-2002.09.27.tar.bz2) = 07b719c23124b58be95cd4895c6510c6
MD5 (ruby/onigd20020424.tar.gz) = d5e6505aa776378a58cdb0fd4ef9cdc0
diff --git a/lang/ruby-devel/pkg-message b/lang/ruby-devel/pkg-message
index 0a25857ba8da..8c0b38ef6dbf 100644
--- a/lang/ruby-devel/pkg-message
+++ b/lang/ruby-devel/pkg-message
@@ -7,6 +7,8 @@ set RUBY_DEFAULT_VER=1.7.
Note that some stuff that comes with the standard Ruby distribution is
provided as separate ports:
+ converters/ruby-iconv iconv module
+
databases/ruby-gdbm: GDBM module
lang/ruby-tcltklib: Tcl/Tk libraries
diff --git a/lang/ruby16_static/Makefile b/lang/ruby16_static/Makefile
index cf3db63a9c38..945722cd4f5f 100644
--- a/lang/ruby16_static/Makefile
+++ b/lang/ruby16_static/Makefile
@@ -39,15 +39,6 @@ EXT_PORTS+= converters/ruby-iconv
BUILD_DEPENDS+= ${NONEXISTENT}:${_PORTSDIR}/${p}:patch
.endfor
-.if defined(RUBY_VER)
-.if ${RUBY_VER} > 1.6
-NEWAUTOCONF= yes
-.endif
-.endif
-
-.if defined(NEWAUTOCONF)
-BUILD_DEPENDS+= autoconf:${PORTSDIR}/devel/autoconf
-.endif
GNU_CONFIGURE= yes
WRKSRC= ${RUBY_WRKSRC}
@@ -126,11 +117,6 @@ do-extract:
echo $$extdir; \
done >> Setup
-.if defined(NEWAUTOCONF)
-pre-configure:
- cd ${WRKSRC}; autoconf
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${RUBY_NAME} ${RUBY_WITH_SUFFIX}_s
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index eb2b0e000da7..86b1fb40769b 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -24,8 +24,6 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
-
.if defined(WITH_ONIGURUMA)
ONIGURUMA_MASTER_SITES= ${MASTER_SITE_RUBY}
ONIGURUMA_MASTER_SITE_SUBDIR= contrib
@@ -45,12 +43,12 @@ RUBY_NO_RUN_DEPENDS= yes
#USE_AUTOCONF= yes # does not work with 2.13; requires 2.53 or later
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
WRKSRC= ${RUBY_WRKSRC}
CONFIGURE_ARGS= ${RUBY_CONFIGURE_ARGS} \
--enable-shared
MAKE_ENV= LANG=C # prevent bison 1.33 w/ gettext 0.10.35 from coredumping
MAKE_ARGS= -j3
+INSTALLS_SHLIB= yes
MAN1= ruby${_RUBY_SUFFIX}.1
LATEST_LINK= ruby-devel
@@ -110,9 +108,6 @@ post-patch:
${MV} ${WRKSRC}/ext/${d} ${WRKDIR}/
.endfor
-pre-configure:
- cd ${WRKSRC}; autoconf
-
pre-install:
${RM} -f ${RUBY_WITHOUT_SUFFIX}${RUBY_R} \
${PREFIX}/man/man1/ruby${RUBY_R}.1 \
diff --git a/lang/ruby18/distinfo b/lang/ruby18/distinfo
index 5c12f472cbc0..5825638d6ece 100644
--- a/lang/ruby18/distinfo
+++ b/lang/ruby18/distinfo
@@ -1,4 +1,2 @@
-MD5 (ruby/ruby-1.7-2002.09.12.tar.bz2) = 4f85e9368137db51eab34e14f2301efa
-MD5 (ruby/ruby-1.7-2002.09.12-2002.09.17.diff.bz2) = ffe16aadf69c9d8f9552536f4803020b
-MD5 (ruby/ruby-1.7-2002.09.17-2002.09.20.diff.bz2) = a4a9f9d197c1014b13ad165d3034a98d
+MD5 (ruby/ruby-1.7.3-2002.09.27.tar.bz2) = 07b719c23124b58be95cd4895c6510c6
MD5 (ruby/onigd20020424.tar.gz) = d5e6505aa776378a58cdb0fd4ef9cdc0
diff --git a/lang/ruby18/pkg-message b/lang/ruby18/pkg-message
index 0a25857ba8da..8c0b38ef6dbf 100644
--- a/lang/ruby18/pkg-message
+++ b/lang/ruby18/pkg-message
@@ -7,6 +7,8 @@ set RUBY_DEFAULT_VER=1.7.
Note that some stuff that comes with the standard Ruby distribution is
provided as separate ports:
+ converters/ruby-iconv iconv module
+
databases/ruby-gdbm: GDBM module
lang/ruby-tcltklib: Tcl/Tk libraries
diff --git a/lang/ruby18_static/Makefile b/lang/ruby18_static/Makefile
index 8037a0c13934..2f553da976d4 100644
--- a/lang/ruby18_static/Makefile
+++ b/lang/ruby18_static/Makefile
@@ -7,7 +7,7 @@
MASTERDIR= ${.CURDIR}/../ruby_static
-PORTREVISION= 1
+PORTREVISION= 0
RUBY_VER= 1.7
diff --git a/lang/ruby_static-devel/Makefile b/lang/ruby_static-devel/Makefile
index 8037a0c13934..2f553da976d4 100644
--- a/lang/ruby_static-devel/Makefile
+++ b/lang/ruby_static-devel/Makefile
@@ -7,7 +7,7 @@
MASTERDIR= ${.CURDIR}/../ruby_static
-PORTREVISION= 1
+PORTREVISION= 0
RUBY_VER= 1.7
diff --git a/lang/ruby_static/Makefile b/lang/ruby_static/Makefile
index cf3db63a9c38..945722cd4f5f 100644
--- a/lang/ruby_static/Makefile
+++ b/lang/ruby_static/Makefile
@@ -39,15 +39,6 @@ EXT_PORTS+= converters/ruby-iconv
BUILD_DEPENDS+= ${NONEXISTENT}:${_PORTSDIR}/${p}:patch
.endfor
-.if defined(RUBY_VER)
-.if ${RUBY_VER} > 1.6
-NEWAUTOCONF= yes
-.endif
-.endif
-
-.if defined(NEWAUTOCONF)
-BUILD_DEPENDS+= autoconf:${PORTSDIR}/devel/autoconf
-.endif
GNU_CONFIGURE= yes
WRKSRC= ${RUBY_WRKSRC}
@@ -126,11 +117,6 @@ do-extract:
echo $$extdir; \
done >> Setup
-.if defined(NEWAUTOCONF)
-pre-configure:
- cd ${WRKSRC}; autoconf
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${RUBY_NAME} ${RUBY_WITH_SUFFIX}_s
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}