aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-18 23:24:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-18 23:24:27 +0000
commit4bf4bc9d9c8e4cda6f1c67e6be2be5090fae143d (patch)
tree75741e70ecf1d66653a4cde4917017a7b6cad587
parentde82a2483dae4feb73e0cefc18f39593fbcabec1 (diff)
downloadports-4bf4bc9d9c8e4cda6f1c67e6be2be5090fae143d.tar.gz
ports-4bf4bc9d9c8e4cda6f1c67e6be2be5090fae143d.zip
Notes
-rw-r--r--graphics/gnash/Makefile14
-rw-r--r--graphics/gnash/distinfo6
-rw-r--r--graphics/gnash/files/patch-backend-render_handler_ogl.h178
-rw-r--r--graphics/gnash/pkg-plist19
4 files changed, 27 insertions, 190 deletions
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index fc183a7292b7..9ee0010e6535 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= gnash
-PORTVERSION= 0.8.2
-PORTREVISION= 2
+PORTVERSION= 0.8.3
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITES= http://getgnash.org/packages/releases/ \
+ ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= amdmi3@amdmi3.ru
@@ -26,6 +26,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
WANT_SDL= yes
WANT_GNOME= yes
+USE_GCC= 4.2+ # triggers compiler error on gcc 3.4
WANT_GSTREAMER= yes
USE_GNOME= pkgconfig libxml2
USE_XORG= x11 xau xdmcp xext xi xinerama ice sm
@@ -41,6 +42,11 @@ CONFIGURE_ARGS= --with-boost-incl="${LOCALBASE}/include" \
--with-npapi-plugindir="${PREFIX}/lib/browser_plugins" \
--with-kde-pluginprefix="${PREFIX}"
+GNASHVER= ${DISTVERSION}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${GNASHVER}
+PLIST_SUB+= GNASHVER="${GNASHVER}"
+
USE_LDCONFIG= ${PREFIX}/lib/gnash
MAN1= cygnal.1 gnash.1 gprocessor.1 soldumper.1 dumpshm.1
@@ -167,8 +173,6 @@ pre-everything::
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|^LIBS = |&$${INTLLIBS} |' \
- ${WRKSRC}/utilities/Makefile.in ${WRKSRC}/cygnal/Makefile.in
@${REINPLACE_CMD} -e '/^PTHREAD_[LC][IF]*=/ d' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g; \
s|/lib64|/lib|g; \
diff --git a/graphics/gnash/distinfo b/graphics/gnash/distinfo
index 509eef638dc2..f15da3bbfa92 100644
--- a/graphics/gnash/distinfo
+++ b/graphics/gnash/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnash-0.8.2.tar.bz2) = 05cac831181be3fb40cbf3c00ab25c0f
-SHA256 (gnash-0.8.2.tar.bz2) = 4c81e71e6619b79da9641a90ed2c73c362603103bcdcc7b9cc5cc53739d06baa
-SIZE (gnash-0.8.2.tar.bz2) = 2637636
+MD5 (gnash-0.8.3.tar.bz2) = 5033ef2602ea1234a9ccb73000a0dedb
+SHA256 (gnash-0.8.3.tar.bz2) = af1fd8454472e0ac588c015b09c67449392f32aa6297d4a625b8344dce11c39a
+SIZE (gnash-0.8.3.tar.bz2) = 2902610
diff --git a/graphics/gnash/files/patch-backend-render_handler_ogl.h b/graphics/gnash/files/patch-backend-render_handler_ogl.h
deleted file mode 100644
index b4f4382b3e44..000000000000
--- a/graphics/gnash/files/patch-backend-render_handler_ogl.h
+++ /dev/null
@@ -1,178 +0,0 @@
-diff -ruN backend/render_handler_ogl.h.orig backend/render_handler_ogl.h
---- backend/render_handler_ogl.h.orig 1970-01-01 03:00:00.000000000 +0300
-+++ backend/render_handler_ogl.h 2008-05-15 06:18:41.725653935 +0400
-@@ -0,0 +1,174 @@
-+//
-+// Copyright (C) 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
-+//
-+// This program is free software; you can redistribute it and/or modify
-+// it under the terms of the GNU General Public License as published by
-+// the Free Software Foundation; either version 3 of the License, or
-+// (at your option) any later version.
-+//
-+// This program is distributed in the hope that it will be useful,
-+// but WITHOUT ANY WARRANTY; without even the implied warranty of
-+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+// GNU General Public License for more details.
-+//
-+// You should have received a copy of the GNU General Public License
-+// along with this program; if not, write to the Free Software
-+// Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-+
-+#ifndef __RENDER_HANDLER_OGL_H__
-+#define __RENDER_HANDLER_OGL_H__
-+
-+
-+#if defined(NOT_SGI_GL) || defined(__APPLE_CC__)
-+#include <AGL/agl.h>
-+#include <OpenGL/gl.h>
-+#include <OpenGL/glu.h>
-+#include <OpenGL/glext.h>
-+#define GLUCALLBACKTYPE GLvoid (*)(...)
-+#else
-+# define GLUCALLBACKTYPE void (*)()
-+# include <GL/gl.h>
-+# ifdef WIN32
-+# define GL_CLAMP_TO_EDGE 0x812F
-+# else
-+# include <GL/glx.h>
-+# ifdef OSMESA_TESTING
-+# include <GL/osmesa.h>
-+# endif // OSMESA_TESTING
-+# endif
-+# include <GL/glu.h>
-+# ifndef APIENTRY
-+# define APIENTRY
-+# endif
-+#endif
-+
-+
-+
-+
-+namespace gnash {
-+
-+
-+
-+
-+typedef std::vector<const path*> PathRefs;
-+
-+
-+
-+struct oglVertex {
-+ oglVertex(double x, double y, double z = 0.0)
-+ : _x(x), _y(y), _z(z)
-+ {
-+ }
-+
-+ oglVertex(const point& p)
-+ : _x(p.x), _y(p.y), _z(0.0)
-+ {
-+ }
-+
-+ GLdouble _x;
-+ GLdouble _y;
-+ GLdouble _z;
-+};
-+
-+typedef std::map< const path*, std::vector<oglVertex> > PathPointMap;
-+
-+class Tesselator
-+{
-+public:
-+ Tesselator();
-+ ~Tesselator();
-+
-+ void beginPolygon();
-+
-+ void feed(std::vector<oglVertex>& vertices);
-+
-+ void tesselate();
-+
-+ void beginContour();
-+ void endContour();
-+
-+ void rememberVertex(GLdouble* v);
-+
-+ static void
-+ error(GLenum error);
-+
-+ static void combine(GLdouble coords [3], void *vertex_data[4],
-+ GLfloat weight[4], void **outData, void* userdata);
-+
-+
-+
-+private:
-+ std::vector<GLdouble*> _vertices;
-+ GLUtesselator* _tessobj;
-+};
-+
-+class WholeShape
-+{
-+public:
-+ void newPath(const path& new_path)
-+ {
-+ PathRefs refs;
-+ refs.push_back(&new_path);
-+
-+ shape.push_back(refs);
-+ }
-+
-+ void addPath(const path& add_path)
-+ {
-+ PathRefs& refs = shape.back();
-+ refs.push_back(&add_path);
-+ }
-+
-+ void addPathRefs(const PathRefs& pathrefs)
-+ {
-+
-+ PathRefs new_refs(pathrefs.begin(), pathrefs.end());
-+
-+ shape.push_back(new_refs);
-+ }
-+
-+
-+ const std::vector<PathRefs>& get() const
-+ {
-+ return shape;
-+ }
-+
-+private:
-+ std::vector<PathRefs> shape;
-+
-+};
-+
-+
-+class bitmap_info_ogl : public bitmap_info
-+{
-+ public:
-+ bitmap_info_ogl(image::image_base* image, GLenum pixelformat,
-+ bool ogl_accessible);
-+ ~bitmap_info_ogl();
-+
-+ void apply(const gnash::matrix& bitmap_matrix,
-+ render_handler::bitmap_wrap_mode wrap_mode);
-+ private:
-+ inline bool ogl_accessible() const;
-+ void setup();
-+ void upload(boost::uint8_t* data, size_t width, size_t height);
-+
-+ std::auto_ptr<image::image_base> _img;
-+ GLenum _pixel_format;
-+ GLenum _ogl_img_type;
-+ bool _ogl_accessible;
-+ GLuint _texture_id;
-+ size_t _orig_width;
-+ size_t _orig_height;
-+};
-+
-+
-+
-+
-+
-+
-+} // namespace gnash
-+
-+
-+#endif // __RENDER_HANDLER_OGL_H__
-+
diff --git a/graphics/gnash/pkg-plist b/graphics/gnash/pkg-plist
index 992a8659bc75..4e5c1624448e 100644
--- a/graphics/gnash/pkg-plist
+++ b/graphics/gnash/pkg-plist
@@ -12,22 +12,32 @@ bin/soldumper
%%KONQPLUGIN%%lib/kde3/libklashpart.a
%%KONQPLUGIN%%lib/kde3/libklashpart.so
%%KONQPLUGIN%%lib/kde3/libklashpart.la
-lib/gnash/libgnashamf-0.8.2.so
+etc/gnashpluginrc
+etc/gnashrc
+lib/gnash/libgnashamf-%%GNASHVER%%.so
lib/gnash/libgnashamf.a
lib/gnash/libgnashamf.la
lib/gnash/libgnashamf.so
-lib/gnash/libgnashbase-0.8.2.so
+lib/gnash/libgnashbase-%%GNASHVER%%.so
lib/gnash/libgnashbase.a
lib/gnash/libgnashbase.la
lib/gnash/libgnashbase.so
-lib/gnash/libgnashmedia-0.8.2.so
+lib/gnash/libgnashmedia-%%GNASHVER%%.so
lib/gnash/libgnashmedia.a
lib/gnash/libgnashmedia.la
lib/gnash/libgnashmedia.so
-lib/gnash/libgnashserver-0.8.2.so
+lib/gnash/libgnashnet.a
+lib/gnash/libgnashnet.la
+lib/gnash/libgnashnet.so
+lib/gnash/libgnashnet.so.0
+lib/gnash/libgnashserver-%%GNASHVER%%.so
lib/gnash/libgnashserver.a
lib/gnash/libgnashserver.la
lib/gnash/libgnashserver.so
+%%FFPLUGIN%%lib/gnash/libmozsdk.a
+%%FFPLUGIN%%lib/gnash/libmozsdk.la
+%%FFPLUGIN%%lib/gnash/libmozsdk.so
+%%FFPLUGIN%%lib/gnash/libmozsdk.so.0
%%DOCSDIR%%/gnashuser.html
%%DOCSDIR%%/images/car_crash.png
%%DOCSDIR%%/images/rtmp.png
@@ -40,6 +50,7 @@ share/locale/es/LC_MESSAGES/gnash.mo
share/locale/fi/LC_MESSAGES/gnash.mo
share/locale/fr/LC_MESSAGES/gnash.mo
share/locale/it/LC_MESSAGES/gnash.mo
+share/locale/ja/LC_MESSAGES/gnash.mo
share/locale/sv/LC_MESSAGES/gnash.mo
@dirrm %%DATADIR%%
@dirrm %%DOCSDIR%%/images