aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2016-04-14 00:41:35 +0000
committerSofian Brabez <sbz@FreeBSD.org>2016-04-14 00:41:35 +0000
commit4c265c20b4f98754689e517d85a1622ee7fcdcba (patch)
tree58e7558008453cf25f83d583fd9926ca8c612ccc
parente15c68ce10821aee7796b48a844be9ef51d739e6 (diff)
downloadports-4c265c20b4f98754689e517d85a1622ee7fcdcba.tar.gz
ports-4c265c20b4f98754689e517d85a1622ee7fcdcba.zip
Notes
-rw-r--r--security/libssh2/Makefile9
-rw-r--r--security/libssh2/distinfo4
-rw-r--r--security/libssh2/pkg-plist2
3 files changed, 11 insertions, 4 deletions
diff --git a/security/libssh2/Makefile b/security/libssh2/Makefile
index 28a6ee26d4c8..06579114ec97 100644
--- a/security/libssh2/Makefile
+++ b/security/libssh2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libssh2
-PORTVERSION= 1.6.0
-PORTREVISION= 1
+PORTVERSION= 1.7.0
PORTEPOCH= 2
CATEGORIES= security devel
MASTER_SITES= http://www.libssh2.org/download/ \
@@ -13,6 +12,7 @@ MAINTAINER= sbz@FreeBSD.org
COMMENT= Library implementing the SSH2 protocol
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
@@ -52,4 +52,9 @@ post-build:
@${REINPLACE_CMD} -E -e '/Requires.private:/{s/[[:<:]]zlib[[:>:]]//;s/,,/,/;s/ ,/ /;s/,$$//;}' \
${WRKSRC}/libssh2.pc
+# allow maintainer to generate MAN3 manpages list (make extract is required before)
+x-generate-man3: extract
+ @(cd ${WRKSRC}/docs && ${LS} -1F *.3 | ${SORT} | ${CUT} -d '/' -f4 \
+ | ${GREP} -v template)
+
.include <bsd.port.post.mk>
diff --git a/security/libssh2/distinfo b/security/libssh2/distinfo
index 97df55f69fa5..7ccf52c08a90 100644
--- a/security/libssh2/distinfo
+++ b/security/libssh2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libssh2-1.6.0.tar.gz) = 5a202943a34a1d82a1c31f74094f2453c207bf9936093867f41414968c8e8215
-SIZE (libssh2-1.6.0.tar.gz) = 734110
+SHA256 (libssh2-1.7.0.tar.gz) = e4561fd43a50539a8c2ceb37841691baf03ecb7daf043766da1b112e4280d584
+SIZE (libssh2-1.7.0.tar.gz) = 811714
diff --git a/security/libssh2/pkg-plist b/security/libssh2/pkg-plist
index eca5d52e4fb8..3dd4c0d715e6 100644
--- a/security/libssh2/pkg-plist
+++ b/security/libssh2/pkg-plist
@@ -90,6 +90,7 @@ man/man3/libssh2_publickey_remove.3.gz
man/man3/libssh2_publickey_remove_ex.3.gz
man/man3/libssh2_publickey_shutdown.3.gz
man/man3/libssh2_scp_recv.3.gz
+man/man3/libssh2_scp_recv2.3.gz
man/man3/libssh2_scp_send.3.gz
man/man3/libssh2_scp_send64.3.gz
man/man3/libssh2_scp_send_ex.3.gz
@@ -113,6 +114,7 @@ man/man3/libssh2_session_last_error.3.gz
man/man3/libssh2_session_method_pref.3.gz
man/man3/libssh2_session_methods.3.gz
man/man3/libssh2_session_set_blocking.3.gz
+man/man3/libssh2_session_set_last_error.3.gz
man/man3/libssh2_session_set_timeout.3.gz
man/man3/libssh2_session_startup.3.gz
man/man3/libssh2_session_supported_algs.3.gz