aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2018-01-16 00:56:37 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2018-01-16 00:56:37 +0000
commit4cf0e8ef1df80e7ae6dbb220c1832c3a9f1de8a1 (patch)
treed9d476b8ea52251b6fac047995188703a12de8a4
parent2c41d3b5813af69e6a60c2a81616956667d408fe (diff)
downloadports-4cf0e8ef1df80e7ae6dbb220c1832c3a9f1de8a1.tar.gz
ports-4cf0e8ef1df80e7ae6dbb220c1832c3a9f1de8a1.zip
Notes
-rw-r--r--www/libevhtp/Makefile5
-rw-r--r--www/libevhtp/distinfo6
-rw-r--r--www/libevhtp/files/patch-CMakeLists.txt11
-rw-r--r--www/libevhtp/files/patch-evhtp.c30
-rw-r--r--www/libevhtp/pkg-plist1
5 files changed, 6 insertions, 47 deletions
diff --git a/www/libevhtp/Makefile b/www/libevhtp/Makefile
index 332db0c051fa..914ba8731650 100644
--- a/www/libevhtp/Makefile
+++ b/www/libevhtp/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= libevhtp
-PORTVERSION= 1.2.15
-PORTREVISION= 1
+PORTVERSION= 1.2.16
CATEGORIES= www
MAINTAINER= ultima@FreeBSD.org
@@ -21,7 +20,7 @@ GH_ACCOUNT= criticalstack
CMAKE_ARGS= -DCMAKE_INCLUDE_PATH:PATH=include/event2 \
-DCMAKE_LIBRARY_PATH:PATH=lib/event2
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
+PLIST_SUB= PORTVERSION=${PORTVERSION}
OPTIONS_DEFINE= REGEX SSL THREADS STATIC DEBUG
OPTIONS_DEFAULT=REGEX SSL THREADS
diff --git a/www/libevhtp/distinfo b/www/libevhtp/distinfo
index 84630a1ba025..d33647dcf661 100644
--- a/www/libevhtp/distinfo
+++ b/www/libevhtp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1514908590
-SHA256 (criticalstack-libevhtp-1.2.15_GH0.tar.gz) = f78ee8a34492e266fc1b6b9d4003825659df672da1cf918120217a0ee0d14ed3
-SIZE (criticalstack-libevhtp-1.2.15_GH0.tar.gz) = 171933
+TIMESTAMP = 1516059355
+SHA256 (criticalstack-libevhtp-1.2.16_GH0.tar.gz) = 4c3f510b15873e9fc29299de0c5d4d257d1d910710e104e33439a17c27fc414b
+SIZE (criticalstack-libevhtp-1.2.16_GH0.tar.gz) = 181311
diff --git a/www/libevhtp/files/patch-CMakeLists.txt b/www/libevhtp/files/patch-CMakeLists.txt
deleted file mode 100644
index 424edb036f4f..000000000000
--- a/www/libevhtp/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.orig 2018-01-02 16:30:26 UTC
-+++ CMakeLists.txt
-@@ -196,7 +196,7 @@ add_library (evhtp ${EVHTP_LIBTYPE} ${LIBEVH
- target_link_libraries (evhtp ${LIBEVHTP_EXTERNAL_LIBS})
-
- if (EVHTP_BUILD_SHARED)
-- set_target_properties(evhtp PROPERTIES VERSION "${PROJECT_VERSION}" 0 OUTPUT_NAME "evhtp")
-+ set_target_properties(evhtp PROPERTIES VERSION "${PROJECT_VERSION}" SOVERSION 0 OUTPUT_NAME "evhtp")
- endif()
-
- add_subdirectory(examples)
diff --git a/www/libevhtp/files/patch-evhtp.c b/www/libevhtp/files/patch-evhtp.c
deleted file mode 100644
index 0a492d710b2f..000000000000
--- a/www/libevhtp/files/patch-evhtp.c
+++ /dev/null
@@ -1,30 +0,0 @@
---- evhtp.c.orig 2017-12-06 22:34:23 UTC
-+++ evhtp.c
-@@ -2373,15 +2373,15 @@ htp__connection_writecb_(struct bufferevent * bev, voi
- return;
- }
-
-- /* run user-hook for on_write callback before further analysis */
-- htp__hook_connection_write_(conn);
--
- /* connection is in a paused state, no further processing yet */
- if ((conn->flags & EVHTP_CONN_FLAG_PAUSED))
- {
- return;
- }
-
-+ /* run user-hook for on_write callback before further analysis */
-+ htp__hook_connection_write_(conn);
-+
- if (conn->flags & EVHTP_CONN_FLAG_WAITING)
- {
- HTP_FLAG_OFF(conn, EVHTP_CONN_FLAG_WAITING);
-@@ -3043,7 +3043,7 @@ evhtp_connection_pause(evhtp_connection_t * c)
-
- HTP_FLAG_ON(c, EVHTP_CONN_FLAG_PAUSED);
-
-- bufferevent_disable(c->bev, EV_READ | EV_WRITE);
-+ bufferevent_disable(c->bev, EV_READ);
-
- return;
- }
diff --git a/www/libevhtp/pkg-plist b/www/libevhtp/pkg-plist
index 09a50e696ecf..15ab4bd7a412 100644
--- a/www/libevhtp/pkg-plist
+++ b/www/libevhtp/pkg-plist
@@ -2,6 +2,7 @@ include/evhtp.h
include/evhtp/config.h
include/evhtp/evhtp.h
include/evhtp/parser.h
+%%SSL%%include/evhtp/sslutils.h
%%THREADS%%include/evhtp/thread.h
%%NO_STATIC%%lib/libevhtp.so
%%NO_STATIC%%lib/libevhtp.so.0