aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-05-24 10:40:09 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-05-24 10:40:09 +0000
commit4d0e2cf48f1b87dc13e12b7dce4a1407b2bc2c04 (patch)
tree720284f3355f9257429d973c920d43e205503079
parentbcdeafc1850f0281a3239a263406b79811e23f0b (diff)
downloadports-4d0e2cf48f1b87dc13e12b7dce4a1407b2bc2c04.tar.gz
ports-4d0e2cf48f1b87dc13e12b7dce4a1407b2bc2c04.zip
Notes
-rw-r--r--sysutils/puppetserver/Makefile34
-rw-r--r--sysutils/puppetserver/distinfo4
-rw-r--r--sysutils/puppetserver/files/patch-ext__config__conf.d__webserver.conf12
-rw-r--r--sysutils/puppetserver/pkg-plist27
4 files changed, 42 insertions, 35 deletions
diff --git a/sysutils/puppetserver/Makefile b/sysutils/puppetserver/Makefile
index 21cc1064247e..a32f43c55d2b 100644
--- a/sysutils/puppetserver/Makefile
+++ b/sysutils/puppetserver/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= puppetserver
-PORTVERSION= 2.2.1
+PORTVERSION= 2.3.1
CATEGORIES= sysutils java
MASTER_SITES= http://downloads.puppetlabs.com/puppet/
@@ -55,19 +55,25 @@ post-patch:
.endfor
do-install:
- ${MKDIR} ${STAGEDIR}${DATADIR}
- ${MKDIR} ${STAGEDIR}${ETCDIR}
- ${MKDIR} ${STAGEDIR}${ETCDIR}/conf.d
- ${MKDIR} ${STAGEDIR}${PREFIX}/etc/puppet/code
- ${MKDIR} ${STAGEDIR}/var/log/puppetserver
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}/cli
+ @${MKDIR} ${STAGEDIR}${DATADIR}/cli/apps
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+ @${MKDIR} ${STAGEDIR}${ETCDIR}/conf.d
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/puppet/code
+ @${MKDIR} ${STAGEDIR}/var/log/puppetserver
${INSTALL_DATA} ${WRKSRC}/puppet-server-release.jar ${STAGEDIR}${DATADIR}/puppetserver.jar
- ${INSTALL_DATA} ${WRKSRC}/ext/config/conf.d/global.conf ${STAGEDIR}${ETCDIR}/conf.d/global.conf
- ${INSTALL_DATA} ${WRKSRC}/ext/config/logback.xml ${STAGEDIR}${ETCDIR}/logback.xml
- ${INSTALL_DATA} ${WRKSRC}/ext/config/bootstrap.cfg ${STAGEDIR}${ETCDIR}/bootstrap.cfg
- ${INSTALL_DATA} ${WRKSRC}/ext/config/request-logging.xml ${STAGEDIR}${ETCDIR}/request-logging.xml
- ${INSTALL_DATA} ${WRKSRC}/ext/config/conf.d/puppetserver.conf ${STAGEDIR}${ETCDIR}/conf.d/puppetserver.conf
- ${INSTALL_DATA} ${WRKSRC}/ext/config/conf.d/web-routes.conf ${STAGEDIR}${ETCDIR}/conf.d/web-routes.conf
- ${INSTALL_DATA} ${WRKSRC}/ext/config/conf.d/webserver.conf ${STAGEDIR}${ETCDIR}/conf.d/webserver.conf
- ${INSTALL_DATA} ${WRKSRC}/ext/config/conf.d/auth.conf ${STAGEDIR}${ETCDIR}/conf.d/auth.conf
+ ${INSTALL_DATA} ${WRKSRC}/ext/config/conf.d/global.conf ${STAGEDIR}${ETCDIR}/conf.d/global.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/ext/config/logback.xml ${STAGEDIR}${ETCDIR}/logback.xml.sample
+ ${INSTALL_DATA} ${WRKSRC}/ext/config/bootstrap.cfg ${STAGEDIR}${ETCDIR}/bootstrap.cfg.sample
+ ${INSTALL_DATA} ${WRKSRC}/ext/config/request-logging.xml ${STAGEDIR}${ETCDIR}/request-logging.xml.sample
+ ${INSTALL_DATA} ${WRKSRC}/ext/config/conf.d/puppetserver.conf ${STAGEDIR}${ETCDIR}/conf.d/puppetserver.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/ext/config/conf.d/web-routes.conf ${STAGEDIR}${ETCDIR}/conf.d/web-routes.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/ext/config/conf.d/webserver.conf ${STAGEDIR}${ETCDIR}/conf.d/webserver.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/ext/config/conf.d/auth.conf ${STAGEDIR}${ETCDIR}/conf.d/auth.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/ext/cli/foreground ${STAGEDIR}${DATADIR}/cli/apps/foreground
+ ${INSTALL_DATA} ${WRKSRC}/ext/cli/gem ${STAGEDIR}${DATADIR}/cli/apps/gem
+ ${INSTALL_DATA} ${WRKSRC}/ext/cli/irb ${STAGEDIR}${DATADIR}/cli/apps/irb
+ ${INSTALL_DATA} ${WRKSRC}/ext/cli/ruby ${STAGEDIR}${DATADIR}/cli/apps/ruby
.include <bsd.port.mk>
diff --git a/sysutils/puppetserver/distinfo b/sysutils/puppetserver/distinfo
index 22007c0441a8..fc03fdf7bf3f 100644
--- a/sysutils/puppetserver/distinfo
+++ b/sysutils/puppetserver/distinfo
@@ -1,2 +1,2 @@
-SHA256 (puppetserver-2.2.1.tar.gz) = 583662380b161fc35e0f0c5e7e2964892ec4b7e0cb848cadcd76b29684a85843
-SIZE (puppetserver-2.2.1.tar.gz) = 42665674
+SHA256 (puppetserver-2.3.1.tar.gz) = 25e0d27339c2e8313cb083503e5790e4f7f1c5c3b29a67b73a35a3aca2f513d9
+SIZE (puppetserver-2.3.1.tar.gz) = 33667638
diff --git a/sysutils/puppetserver/files/patch-ext__config__conf.d__webserver.conf b/sysutils/puppetserver/files/patch-ext__config__conf.d__webserver.conf
index 40310663026d..573e0a605a01 100644
--- a/sysutils/puppetserver/files/patch-ext__config__conf.d__webserver.conf
+++ b/sysutils/puppetserver/files/patch-ext__config__conf.d__webserver.conf
@@ -1,9 +1,9 @@
---- ext/config/conf.d/webserver.conf.orig 2015-10-27 16:26:17 UTC
+--- ext/config/conf.d/webserver.conf.orig 2016-03-28 10:32:26.000000000 -0700
+++ ext/config/conf.d/webserver.conf
@@ -1,5 +1,5 @@
webserver: {
-- access-log-config = /etc/puppetlabs/puppetserver/request-logging.xml
-+ access-log-config = %%PREFIX%%/etc/puppetserver/request-logging.xml
- client-auth = want
- ssl-host = 0.0.0.0
- ssl-port = 8140
+- access-log-config: /etc/puppetlabs/puppetserver/request-logging.xml
++ access-log-config: %%PREFIX%%/etc/puppetserver/request-logging.xml
+ client-auth: want
+ ssl-host: 0.0.0.0
+ ssl-port: 8140
diff --git a/sysutils/puppetserver/pkg-plist b/sysutils/puppetserver/pkg-plist
index 341c7766ae7a..2e105ebacdba 100644
--- a/sysutils/puppetserver/pkg-plist
+++ b/sysutils/puppetserver/pkg-plist
@@ -1,14 +1,15 @@
-%%ETCDIR%%/logback.xml
-%%ETCDIR%%/bootstrap.cfg
-%%ETCDIR%%/request-logging.xml
-%%ETCDIR%%/conf.d/global.conf
-%%ETCDIR%%/conf.d/puppetserver.conf
-%%ETCDIR%%/conf.d/web-routes.conf
-%%ETCDIR%%/conf.d/webserver.conf
-%%ETCDIR%%/conf.d/auth.conf
+@sample %%ETCDIR%%/logback.xml.sample
+@sample %%ETCDIR%%/bootstrap.cfg.sample
+@sample %%ETCDIR%%/request-logging.xml.sample
+@sample %%ETCDIR%%/conf.d/auth.conf.sample
+@sample %%ETCDIR%%/conf.d/global.conf.sample
+@sample %%ETCDIR%%/conf.d/puppetserver.conf.sample
+@sample %%ETCDIR%%/conf.d/web-routes.conf.sample
+@sample %%ETCDIR%%/conf.d/webserver.conf.sample
+@dir(,puppet,750) etc/puppet/code
%%DATADIR%%/puppetserver.jar
-@mode 0750
-@group puppet
-@dir etc/puppet/code
-@owner puppet
-@dir /var/log/puppetserver
+%%DATADIR%%/cli/apps/foreground
+%%DATADIR%%/cli/apps/gem
+%%DATADIR%%/cli/apps/irb
+%%DATADIR%%/cli/apps/ruby
+@dir(puppet,puppet,750) /var/log/puppetserver