aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-02-26 12:11:35 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-02-26 12:11:35 +0000
commit4d9773d24d0a08c4310f75ff1b0a24436eea71bb (patch)
tree3b8d6f920637cb09cad7cd15b239e733fe213f6c
parent370a14b53d0078ef0d4230aa9b6b39cd39c0aa16 (diff)
downloadports-4d9773d24d0a08c4310f75ff1b0a24436eea71bb.tar.gz
ports-4d9773d24d0a08c4310f75ff1b0a24436eea71bb.zip
Clean up some things
- Fix typos - Remove duplicate variables - Remove nop variables - Sort categories Reported by: portscan
Notes
Notes: svn path=/head/; revision=566598
-rw-r--r--audio/lsp-plugins-lv2/Makefile3
-rw-r--r--audio/pulseaudio-module-xrdp/Makefile2
-rw-r--r--audio/strawberry/Makefile1
-rw-r--r--audio/welle.io/Makefile1
-rw-r--r--comms/uhd/Makefile1
-rw-r--r--databases/Makefile2
-rw-r--r--databases/couchdb3/Makefile1
-rw-r--r--databases/redisdesktopmanager/Makefile1
-rw-r--r--deskutils/nextcloudclient/Makefile1
-rw-r--r--deskutils/notification-daemon/Makefile2
-rw-r--r--devel/cl-alexandria/Makefile2
-rw-r--r--devel/py-datatest/Makefile2
-rw-r--r--devel/snorenotify/Makefile2
-rw-r--r--emulators/mgba/Makefile1
-rw-r--r--graphics/libyuv/Makefile2
-rw-r--r--graphics/opencv/Makefile1
-rw-r--r--irc/irssi/Makefile2
-rw-r--r--mail/mailagent/Makefile2
-rw-r--r--multimedia/arcan/Makefile2
-rw-r--r--multimedia/lives/Makefile4
-rw-r--r--multimedia/zoneminder/Makefile1
-rw-r--r--net-mgmt/Makefile2
-rw-r--r--net-p2p/jackett/Makefile3
-rw-r--r--sysutils/Makefile10
-rw-r--r--sysutils/cinnamon-settings-daemon/Makefile1
-rw-r--r--sysutils/consolekit2/Makefile1
-rw-r--r--sysutils/plasma5-plasma-disks/Makefile2
-rw-r--r--sysutils/tracker-miners/Makefile1
-rw-r--r--textproc/en-hunspell/Makefile1
-rw-r--r--www/neon/Makefile2
-rw-r--r--www/screego/Makefile2
-rw-r--r--www/unit/Makefile1
-rw-r--r--x11/mate-dock-applet/Makefile3
-rw-r--r--x11/py-qt5-opengl/Makefile3
34 files changed, 21 insertions, 47 deletions
diff --git a/audio/lsp-plugins-lv2/Makefile b/audio/lsp-plugins-lv2/Makefile
index 32ed298fba88..b25e676ee48a 100644
--- a/audio/lsp-plugins-lv2/Makefile
+++ b/audio/lsp-plugins-lv2/Makefile
@@ -26,9 +26,6 @@ USE_GNOME= cairo
USE_XORG= x11
USE_GL= gl
-USE_GITHUB= yes
-GH_ACCOUNT= sadko4u
-
BINARY_ALIAS= g++=${CXX} c++=${CXX}
MAKE_ARGS= BUILD_MODULES='lv2' ETC_PATH=${PREFIX}/etc VERSION=${DISTVERSION}
diff --git a/audio/pulseaudio-module-xrdp/Makefile b/audio/pulseaudio-module-xrdp/Makefile
index cbafbd3b5a72..d49dbfc4bc52 100644
--- a/audio/pulseaudio-module-xrdp/Makefile
+++ b/audio/pulseaudio-module-xrdp/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= meta@FreeBSD.org
COMMENT= PulseAudio module which enables xrdp to use audio redirection
LICENSE= LGPL21
-LICNSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${NONEXISTENT}:audio/pulseaudio:configure
LIB_DEPENDS= libpulse.so:audio/pulseaudio
diff --git a/audio/strawberry/Makefile b/audio/strawberry/Makefile
index 62f20b7ba9a8..3d7fc0268073 100644
--- a/audio/strawberry/Makefile
+++ b/audio/strawberry/Makefile
@@ -47,7 +47,6 @@ TEST_TARGET= strawberry_test
OPTIONS_DEFINE= AUDIOCD IPOD MOODBAR MTPDEV MUSICBRAINZ \
SUBSONIC TIDAL VLC
-APPLEDEV_IMPLIES= IPOD
OPTIONS_DEFAULT= PULSEAUDIO MOODBAR
OPTIONS_MULTI= SOUND
diff --git a/audio/welle.io/Makefile b/audio/welle.io/Makefile
index 9009bb205e8c..67dc4b53ee70 100644
--- a/audio/welle.io/Makefile
+++ b/audio/welle.io/Makefile
@@ -32,7 +32,6 @@ SOAPY_DESC= SoapySDR support
FFTW_DESC= Use FFTW3 instead of KISSFFT
CLI_DESC= Build the welle-cli tool
-RTLSDR_DEPENDS= rtl-sdr:comms/rtl-sdr
RTLSDR_LIB_DEPENDS= librtlsdr.so:comms/rtl-sdr
RTLSDR_CMAKE_BOOL= RTLSDR
diff --git a/comms/uhd/Makefile b/comms/uhd/Makefile
index 2a98d7f59947..7f03da07e5a9 100644
--- a/comms/uhd/Makefile
+++ b/comms/uhd/Makefile
@@ -40,7 +40,6 @@ BROKEN_FreeBSD_13_aarch64= fails to configure: Could not find standard set_new_h
BROKEN_FreeBSD_13_armv6= fails to configure: Could not find standard set_new_handler function
BROKEN_FreeBSD_13_armv7= fails to configure: Could not find standard set_new_handler function
-USE_LDCONFIG= yes
CMAKE_SOURCE_PATH= ${WRKSRC}/host
#CXXFLAGS_amd64= -msse2 -std=c++11
CXXFLAGS_i386= -msse2
diff --git a/databases/Makefile b/databases/Makefile
index d42e36c5ea5f..da3bc254876c 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -164,8 +164,8 @@
SUBDIR += linux-c7-sqlite3
SUBDIR += linux-oracle-instantclient-basic
SUBDIR += linux-oracle-instantclient-sdk
- SUBDIR += litestream
SUBDIR += liquibase
+ SUBDIR += litestream
SUBDIR += lmdb
SUBDIR += lua-lsqlite3
SUBDIR += lua-resty-redis
diff --git a/databases/couchdb3/Makefile b/databases/couchdb3/Makefile
index cdd7b41e45a6..85007e237ede 100644
--- a/databases/couchdb3/Makefile
+++ b/databases/couchdb3/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= couchdb3
-PORTREVISION= 1
DISTVERSION= 3.1.1
PORTREVISION= 1
CATEGORIES= databases
diff --git a/databases/redisdesktopmanager/Makefile b/databases/redisdesktopmanager/Makefile
index b970be529276..9b29ae42535f 100644
--- a/databases/redisdesktopmanager/Makefile
+++ b/databases/redisdesktopmanager/Makefile
@@ -26,7 +26,6 @@ CONFIGURE_WRKSRC= ${WRKSRC}/src
INSTALL_WRKSRC= ${WRKSRC}/bin/linux/release
PLIST_FILES= bin/rdm \
share/pixmaps/rdm.png
-BINARY_ALIAS= python3-config=${PYTHON_CMD}-config
DESKTOP_ENTRIES= "Redis Desktop Manager" \
"Redis Desktop Manager" \
"rdm" \
diff --git a/deskutils/nextcloudclient/Makefile b/deskutils/nextcloudclient/Makefile
index 2f96ed8a1624..8b2fc02ec0a9 100644
--- a/deskutils/nextcloudclient/Makefile
+++ b/deskutils/nextcloudclient/Makefile
@@ -5,7 +5,6 @@ PORTNAME= nextcloudclient
PORTVERSION= 3.1.2
DISTVERSIONPREFIX= v
CATEGORIES= deskutils
-CATEGORIES= deskutils
MAINTAINER= mr@FreeBSD.org
COMMENT= NextCloud Desktop Syncing Client
diff --git a/deskutils/notification-daemon/Makefile b/deskutils/notification-daemon/Makefile
index 39bb15853222..ee639f4c841c 100644
--- a/deskutils/notification-daemon/Makefile
+++ b/deskutils/notification-daemon/Makefile
@@ -3,7 +3,7 @@
PORTNAME= notification-daemon
PORTVERSION= 3.20.0
-PORTERVISION= 1
+PORTREVISION= 1
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME
diff --git a/devel/cl-alexandria/Makefile b/devel/cl-alexandria/Makefile
index 014b8910f05b..ea1d57a122de 100644
--- a/devel/cl-alexandria/Makefile
+++ b/devel/cl-alexandria/Makefile
@@ -17,8 +17,6 @@ USE_GITLAB= yes
GL_SITE= https://gitlab.common-lisp.net
GL_COMMIT= f35e232ceb2ada8d10e7fdf27ccac07f781eea0e
-NO_ARCH= yes
-
OPTIONS_DEFINE= DOCS
DOCS_BUILD_DEPENDS= sbcl:lang/sbcl \
diff --git a/devel/py-datatest/Makefile b/devel/py-datatest/Makefile
index 9281cd1d6005..80854355733f 100644
--- a/devel/py-datatest/Makefile
+++ b/devel/py-datatest/Makefile
@@ -17,7 +17,7 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-OPTION_DEFINE= OPTIONAL
+OPTIONS_DEFINE= OPTIONAL
OPTIONAL_DESC= Optional dependencies
OPTIONAL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbfread>=0:textproc/py-dbfread@${PY_FLAVOR} \
diff --git a/devel/snorenotify/Makefile b/devel/snorenotify/Makefile
index 4eacaf30b6e7..de8a657c931c 100644
--- a/devel/snorenotify/Makefile
+++ b/devel/snorenotify/Makefile
@@ -10,7 +10,7 @@ MAINTAINER= swills@FreeBSD.org
COMMENT= Multi platform Qt notification framework
DEPRECATED= Unmaintained upstream
-EXPIRATION= 2021-02-18
+EXPIRATION_DATE= 2021-02-18
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/COPYING.LGPL-3
diff --git a/emulators/mgba/Makefile b/emulators/mgba/Makefile
index 43a1a7326c17..5bd5dd644b43 100644
--- a/emulators/mgba/Makefile
+++ b/emulators/mgba/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= mgba
-DISTVERSION= 0.8.3
DISTVERSION= 0.8.4
CATEGORIES= emulators
diff --git a/graphics/libyuv/Makefile b/graphics/libyuv/Makefile
index 21cb13634d10..dcd6b9c31fdf 100644
--- a/graphics/libyuv/Makefile
+++ b/graphics/libyuv/Makefile
@@ -37,7 +37,7 @@ do-fetch:
https://chromium.googlesource.com/libyuv/libyuv.git/+archive/${LIBYUV_HASH}.tar.gz
. if ${USER} == ${MAINTAINER:C/@.*//}
- scp ${DISTDIR}/libyuv-${LIBYUV_HASH} freefall.freebsd.org:public_distfiles/libyuv
+ scp ${DISTDIR}/libyuv-${LIBYUV_HASH} freefall.freebsd.org:public_distfiles/libyuv
. endif
.endif # defined(MAINTAINER_MODE)
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index c36c06faf1d2..6ba939892eac 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -79,7 +79,6 @@ JAVA_BUILD_DEPENDS= ant:devel/apache-ant
PYTHON_BUILD_DEPENDS= ${PYNUMPY}
PYTHON_RUN_DEPENDS= ${PYNUMPY}
PYTHON_USES= python:3.6+
-PYTHON_USE_PYTHON= noflavors
PYTHON_CMAKE_BOOL= BUILD_opencv_python3
LTO_CMAKE_BOOL= ENABLE_THIN_LTO
diff --git a/irc/irssi/Makefile b/irc/irssi/Makefile
index fde3d0e43ebe..31db844a0afb 100644
--- a/irc/irssi/Makefile
+++ b/irc/irssi/Makefile
@@ -53,7 +53,7 @@ TRUECOLOR_MESON_YES= enable-true-color
UTF8PROC_LIB_DEPENDS= libutf8proc.so:textproc/utf8proc
UTF8PROC_MESON_NO= disable-utf8proc
-PERL5_USE_OFF= perl5=build
+PERL_USE_OFF= perl5=build
post-install-PERL-off:
@${RM} -r ${STAGEDIR}${DATADIR}/scripts
diff --git a/mail/mailagent/Makefile b/mail/mailagent/Makefile
index c0343f4bedf9..3e0479e6054a 100644
--- a/mail/mailagent/Makefile
+++ b/mail/mailagent/Makefile
@@ -9,7 +9,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Sophisticated automatic mail-processing tool
LICENSE= ART10
-LICENSE_FILES= ${WRKSRC}/Artistic
+LICENSE_FILE= ${WRKSRC}/Artistic
USES= perl5 tar:bzip2
USE_GITHUB= yes
diff --git a/multimedia/arcan/Makefile b/multimedia/arcan/Makefile
index 8ab39a41627e..1435a7790eeb 100644
--- a/multimedia/arcan/Makefile
+++ b/multimedia/arcan/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= multimedia
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Display Server, Multimedia Framework, Game Engine
-LICENSE= BSD3CLAUSE GPLv2+ LGPL21
+LICENSE= BSD3CLAUSE GPLv2+ LGPL21+
LICENSE_COMB= multi
LICENSE_FILE_BSD3CLAUSE=${WRKSRC:H}/data/distr/LICENSE.BSD
LICENSE_FILE_GPLv2+ = ${WRKSRC:H}/data/distr/LICENSE.GPL
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index 53a7faf5673d..00762766f32c 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -13,8 +13,8 @@ COMMENT= Video editing system
LICENSE= GPLv3+ LGPL3+
LICENSE_COMB= multi
-LICENSE_FILE_GPLv3+= ${WRKSRC}/COPYING
-LICENSE_FILE_LGPL3+= ${WRKSRC}/COPYING.LGPL
+LICENSE_FILE_GPLv3+ = ${WRKSRC}/COPYING
+LICENSE_FILE_LGPL3+ = ${WRKSRC}/COPYING.LGPL
BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto \
analyseplugin:audio/ladspa
diff --git a/multimedia/zoneminder/Makefile b/multimedia/zoneminder/Makefile
index a08710342c79..021d4ab831dc 100644
--- a/multimedia/zoneminder/Makefile
+++ b/multimedia/zoneminder/Makefile
@@ -52,7 +52,6 @@ NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
V4L_BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
V4L_LIB_DEPENDS= libv4l2.so:multimedia/libv4l
-PKGMESSAGE= ${MASTERDIR}/pkg-message
PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
SUB_FILES= pkg-message
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index af21e6c4aa38..087b6f208f6c 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -134,8 +134,8 @@
SUBDIR += nagcon
SUBDIR += nagios
SUBDIR += nagios-certexp-plugin
- SUBDIR += nagios-check_bacula9
SUBDIR += nagios-check_bacula11
+ SUBDIR += nagios-check_bacula9
SUBDIR += nagios-check_clamav
SUBDIR += nagios-check_cpu_usage
SUBDIR += nagios-check_dhcp.pl
diff --git a/net-p2p/jackett/Makefile b/net-p2p/jackett/Makefile
index 767cd8f291ae..1c0e4d4fb571 100644
--- a/net-p2p/jackett/Makefile
+++ b/net-p2p/jackett/Makefile
@@ -17,14 +17,13 @@ RUN_DEPENDS= mono>0:lang/mono
USE_RC_SUBR= jackett
+NO_ARCH= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/Jackett
USERS= jackett
GROUPS= jackett
-NOARCH= yes
-
post-patch:
@${RM} ${WRKSRC}/install_service_macos ${WRKSRC}/install_service_systemd.sh
diff --git a/sysutils/Makefile b/sysutils/Makefile
index df6adafdd077..86961e8a5e2f 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -84,14 +84,14 @@
SUBDIR += backuppc-devel
SUBDIR += backuppc4
SUBDIR += backupuser
- SUBDIR += bacula9-client
- SUBDIR += bacula9-client-static
- SUBDIR += bacula9-docs
- SUBDIR += bacula9-server
SUBDIR += bacula11-client
SUBDIR += bacula11-client-static
SUBDIR += bacula11-docs
SUBDIR += bacula11-server
+ SUBDIR += bacula9-client
+ SUBDIR += bacula9-client-static
+ SUBDIR += bacula9-docs
+ SUBDIR += bacula9-server
SUBDIR += baloo-widgets
SUBDIR += bamf
SUBDIR += bareos-client
@@ -1036,8 +1036,8 @@
SUBDIR += py-pytsk
SUBDIR += py-pywatchman
SUBDIR += py-pyznap
- SUBDIR += py-queuelib
SUBDIR += py-qmk
+ SUBDIR += py-queuelib
SUBDIR += py-ranger
SUBDIR += py-rdiff-backup
SUBDIR += py-resolve-march-native
diff --git a/sysutils/cinnamon-settings-daemon/Makefile b/sysutils/cinnamon-settings-daemon/Makefile
index 7c628bee5dd9..9a8c971e7bfe 100644
--- a/sysutils/cinnamon-settings-daemon/Makefile
+++ b/sysutils/cinnamon-settings-daemon/Makefile
@@ -63,7 +63,6 @@ GLIB_SCHEMAS= org.cinnamon.settings-daemon.enums.xml \
org.cinnamon.settings-daemon.plugins.xrandr.gschema.xml \
org.cinnamon.settings-daemon.plugins.xsettings.gschema.xml
-OPTIONS_SUB= yes
OPTIONS_DEFINE= CUPS SMARTCARD WACOM
OPTIONS_DEFAULT=CUPS SMARTCARD WACOM
OPTIONS_SUB= yes
diff --git a/sysutils/consolekit2/Makefile b/sysutils/consolekit2/Makefile
index 2e78c3469fda..fcc7e1996dce 100644
--- a/sysutils/consolekit2/Makefile
+++ b/sysutils/consolekit2/Makefile
@@ -9,7 +9,6 @@ MASTER_SITES= https://github.com/ConsoleKit2/ConsoleKit2/releases/download/${POR
PKGNAMESUFFIX= 2
DISTNAME= ConsoleKit2-${PORTVERSION}
-MAINTAINER= desktop@FreeBSD.org
# Support for DRM/evdev
PATCH_SITES= https://github.com/myfreeweb/ConsoleKit2/commit/
PATCHFILES= 03eaa9779f2c9c7b0acf0521a5547036bdec2245.patch:-p1 \
diff --git a/sysutils/plasma5-plasma-disks/Makefile b/sysutils/plasma5-plasma-disks/Makefile
index b6aa064dbcaa..9f5c2dc396c3 100644
--- a/sysutils/plasma5-plasma-disks/Makefile
+++ b/sysutils/plasma5-plasma-disks/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE_BSD3CLAUSE= ${WRKSRC}/LICENSES/BSD-3-Clause.txt
LICENSE_FILE_CC0-1.0= ${WRKSRC}/LICENSES/CC0-1.0.txt
LICENSE_FILE_GPLv2= ${WRKSRC}/LICENSES/GPL-2.0-only.txt
LICENSE_FILE_GPLv3= ${WRKSRC}/LICENSES/GPL-3.0-only.txt
-LICENSE_FILE_LGPLv3= ${WRKSRC}/LICENSES/LGPL-3.0-only.txt
+LICENSE_FILE_LGPL3= ${WRKSRC}/LICENSES/LGPL-3.0-only.txt
#LICENSE_FILE_FSF= ${WRKSRC}/LICENSES/FSFAP.txt
#LICENSE_PERMS_KDE-GPL= gpl3
#LICENSE_PERMS_KDE-LGPL= gpl3
diff --git a/sysutils/tracker-miners/Makefile b/sysutils/tracker-miners/Makefile
index 6209e6d7c0fc..21721eff0a74 100644
--- a/sysutils/tracker-miners/Makefile
+++ b/sysutils/tracker-miners/Makefile
@@ -4,7 +4,6 @@
PORTNAME= tracker-miners
PORTVERSION= 2.3.5
PORTREVISION= 6
-PĂ–RTREVISION= 1
CATEGORIES= sysutils gnome
MASTER_SITES= GNOME
diff --git a/textproc/en-hunspell/Makefile b/textproc/en-hunspell/Makefile
index 769a7a2c30e8..296d8119d2a2 100644
--- a/textproc/en-hunspell/Makefile
+++ b/textproc/en-hunspell/Makefile
@@ -41,7 +41,6 @@ COPY= -lh # Use hardlinks rather than copies under stage/
OPTIONS_RADIO= AU CA GB US
OPTIONS_RADIO_AU= AU_STANDARD AU_LARGE
-OPTIONS_RADIO_CA= CA_LARGE CA_STANDARD
OPTIONS_RADIO_CA= CA_STANDARD CA_LARGE
OPTIONS_RADIO_GB= GB_ISE GB_IZE GB_LARGE
OPTIONS_RADIO_US= US_STANDARD US_LARGE
diff --git a/www/neon/Makefile b/www/neon/Makefile
index 16e1358812b2..ddbfbfb98e19 100644
--- a/www/neon/Makefile
+++ b/www/neon/Makefile
@@ -26,7 +26,7 @@ OPTIONS_SINGLE= XML
OPTIONS_SINGLE_XML= EXPAT LIBXML2
CA_BUNDLE_DESC= Enable CA bundle for GnuTLS/OpenSSL
-LIBXML_DESC= libxml2 XML parser support
+LIBXML2_DESC= libxml2 XML parser support
PROXY_DESC= libproxy support
XML_DESC= XML parser library
diff --git a/www/screego/Makefile b/www/screego/Makefile
index 04c1ab82a9b3..dcd97c7d4b1a 100644
--- a/www/screego/Makefile
+++ b/www/screego/Makefile
@@ -1558,8 +1558,6 @@ _YARNRC= ${_YARN_HOME}/yarnrc
_YARN_CMD= ${SETENV} ${_YARN_ENV} ${_YARN_BIN} ${_YARN_FLAGS}
_YARN_CWD= ${WRKSRC}/ui
-OPTIONS_DEFINE= DOCS
-
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "The limit imposed by poudriere(8) for the maximum number of files allowed to be"
diff --git a/www/unit/Makefile b/www/unit/Makefile
index 9d39582ffc5d..c7d8f1dcfa41 100644
--- a/www/unit/Makefile
+++ b/www/unit/Makefile
@@ -29,7 +29,6 @@ OPTIONS_RADIO+= REGEX
OPTIONS_RADIO_REGEX= NOPCRE PCRE PCRE2
DEBUG_DESC= Enable debug logging
-DEVKIT_DESC= Install headers and library
REGEX_DESC= Support regular expressions
NOPCRE_DESC= No support for Regular Expressions
PCRE_DESC= Regular Expressions via devel/pcre
diff --git a/x11/mate-dock-applet/Makefile b/x11/mate-dock-applet/Makefile
index 8377dc9ea7d0..74b7c6dcd668 100644
--- a/x11/mate-dock-applet/Makefile
+++ b/x11/mate-dock-applet/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mate-dock-applet
PORTVERSION= 20.04.0
-PORTREVSION= 1
+PORTREVISION= 1
CATEGORIES= x11 mate
DIST_SUBDIR= mate
@@ -27,7 +27,6 @@ USES= python:3.7+ autoreconf gettext gmake gnome libtool localbase \
USE_GITHUB= yes
GH_ACCOUNT= ubuntu-mate
USE_GNOME= gtk30 libwnck3
-AUTOMAKE_ARGS= --add-missing
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gtk3
INSTALLS_ICONS= yes
diff --git a/x11/py-qt5-opengl/Makefile b/x11/py-qt5-opengl/Makefile
index f7ad65e1f169..802b37e4208c 100644
--- a/x11/py-qt5-opengl/Makefile
+++ b/x11/py-qt5-opengl/Makefile
@@ -26,7 +26,4 @@ API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
DEBUG_CONFIGURE_ON= --debug --trace
-port-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyQt5/QtOpenGl.so
-
.include <bsd.port.mk>