aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-10-12 15:57:51 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-10-12 15:57:51 +0000
commit4da13b8f8e619dad24893ca2f4b4acfb93701d03 (patch)
tree22d06d881d39a3e8bbe4216cf9029a239cf1e2dc
parent68dce24019665a59d03e92f99d93fb7795e467bf (diff)
downloadports-4da13b8f8e619dad24893ca2f4b4acfb93701d03.tar.gz
ports-4da13b8f8e619dad24893ca2f4b4acfb93701d03.zip
Remove WANT_GNOME and HAVE_GNOME.
Approved by: bapt kwm Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12643
Notes
Notes: svn path=/head/; revision=451901
-rw-r--r--CHANGES6
-rw-r--r--Mk/Uses/gnome.mk73
-rw-r--r--Mk/bsd.sanity.mk3
-rw-r--r--audio/xmixer/Makefile1
-rw-r--r--audio/xmms-faad/Makefile1
-rw-r--r--audio/xmp/Makefile1
-rw-r--r--comms/cqrlog/Makefile1
-rw-r--r--databases/sqlrelay/Makefile1
-rw-r--r--deskutils/planner/Makefile1
-rw-r--r--devel/distcc/Makefile1
-rw-r--r--devel/mono-addins/Makefile1
-rw-r--r--devel/pwlib/Makefile1
-rw-r--r--editors/libreoffice/Makefile1
-rw-r--r--emulators/visualboyadvance-m/Makefile1
-rw-r--r--java/classpath/Makefile1
-rw-r--r--java/icedtea-web/Makefile2
-rw-r--r--misc/magicpoint/Makefile1
-rw-r--r--multimedia/gpodder/Makefile1
-rw-r--r--multimedia/mplayer/Makefile.common2
-rw-r--r--multimedia/transcode/Makefile1
-rw-r--r--net-im/libpurple/Makefile4
-rw-r--r--net-im/pidgin/Makefile1
-rw-r--r--net/unison-devel/Makefile1
-rw-r--r--net/unison/Makefile1
-rw-r--r--net/unison232/Makefile1
-rw-r--r--net/unison240/Makefile1
-rw-r--r--net/yate/Makefile1
-rw-r--r--print/ghostscript7-base/Makefile1
-rw-r--r--sysutils/cdrdao/Makefile1
-rw-r--r--sysutils/gkrellm2/Makefile1
-rw-r--r--sysutils/thefish/Makefile1
-rw-r--r--sysutils/xcdroast/Makefile1
-rw-r--r--textproc/uim/Makefile1
-rw-r--r--www/linux-opera/Makefile1
-rw-r--r--www/nginx-devel/Makefile2
-rw-r--r--www/nginx/Makefile2
-rw-r--r--x11-fm/doublecmd/Makefile1
-rw-r--r--x11-themes/gnome-icons-jini/Makefile1
-rw-r--r--x11-themes/gnome-icons/bsd.gnome-icons.mk1
-rw-r--r--x11/eaglemode/Makefile1
-rw-r--r--x11/metisse/Makefile1
-rw-r--r--x11/xvattr/Makefile1
42 files changed, 9 insertions, 119 deletions
diff --git a/CHANGES b/CHANGES
index bb75cb0e9fe9..33077f733ab3 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,12 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20171012:
+AUTHOR: mat@FreeBSD.org
+
+ Remove WANT_GNOME and HAVE_GNOME, they were in disuse, and made useless by
+ options.
+
20171011:
AUTHOR: bapt@FreeBSD.org
diff --git a/Mk/Uses/gnome.mk b/Mk/Uses/gnome.mk
index 3c7d12fc2804..63e3dbd4e244 100644
--- a/Mk/Uses/gnome.mk
+++ b/Mk/Uses/gnome.mk
@@ -477,70 +477,6 @@ USE_GNOME+= gtk-update-icon-cache
# End component definition section
-# This section defines tests for optional software. These work off four
-# types of variables: WANT_GNOME, WITH_GNOME, HAVE_GNOME and USE_GNOME.
-# The logic of this is that a port can WANT support for a package; a user
-# specifies if they want ports compiled WITH certain features; this section
-# tests if we HAVE these features; and the port is then free to USE them.
-
-# The logic of this section is like this:
-#
-# .if defined(WANT_GNOME) && !defined(WITHOUT_GNOME)
-# .for foo in ALL_GNOME_COMPONENTS
-# .if defined(WITH_GNOME)
-# HAVE_GNOME += foo
-# .elif (foo installed)
-# HAVE_GNOME += foo
-# .else
-# Print option message
-# .endif
-# .endfor
-# .endif
-#
-# Although it appears a little more convoluted in the tests.
-
-# Ports can make use of this like so:
-#
-# WANT_GNOME= yes
-#
-# .include <bsd.port.pre.mk>
-#
-# .if ${HAVE_GNOME:Mfoo}!=""
-# ... Do some things ...
-# USE_GNOME= foo
-# .else
-# ... Do some other things ...
-# .endif
-
-# We also check each component to see if it has a desktop requirement. If
-# it does, and its requirement disagrees with the user's chosen desktop,
-# do not add the component to the HAVE_GNOME list.
-
-_USE_GNOME_SAVED:=${USE_GNOME}
-HAVE_GNOME?=
-.if (defined(WANT_GNOME) && !defined(WITHOUT_GNOME))
-. for component in ${_USE_GNOME_ALL}
-. if exists(${${component}_DETECT})
-HAVE_GNOME+= ${component}
-. elif defined(WITH_GNOME)
-. if ${WITH_GNOME}=="yes" || ${WITH_GNOME:M${component}}!="" \
- || ${WITH_GNOME}=="1"
-HAVE_GNOME+= ${component}
-. endif
-. endif
-. endfor
-.elif defined(WITHOUT_GNOME)
-. if ${WITHOUT_GNOME}!="yes" && ${WITHOUT_GNOME}!="1"
-. for component in ${_USE_GNOME_ALL}
-. if ${WITHOUT_GNOME:M${component}}==""
-. if exists(${${component}_DETECT})
-HAVE_GNOME+= ${component}
-. endif
-. endif
-. endfor
-. endif
-.endif
-
.if defined(USE_GNOME)
# First of all expand all USE_GNOME_IMPL recursively
. for component in ${_USE_GNOME_ALL}
@@ -629,15 +565,6 @@ MAKE_ENV+= GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
. endif
.endif
-.if defined(WANT_GNOME)
-USE_GNOME?=
-. if ${_USE_GNOME_SAVED}==${USE_GNOME}
-PLIST_SUB+= GNOME:="@comment " NOGNOME:=""
-. else
-PLIST_SUB+= GNOME:="" NOGNOME:="@comment "
-. endif
-.endif
-
.if defined(USE_GNOME_SUBR)
GNOME_SUBR= ${LOCALBASE}/etc/gnome.subr
RUN_DEPENDS+= ${GNOME_SUBR}:sysutils/gnome_subr
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index cf9d5771e899..ceb155e31391 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -179,7 +179,7 @@ SANITY_UNSUPPORTED= USE_OPENAL USE_FAM USE_MAKESELF USE_ZIP USE_LHA USE_CMAKE \
USE_PYTHON_PREFIX USE_BZIP2 USE_XZ USE_PGSQL NEED_ROOT \
UNIQUENAME LATEST_LINK USE_SQLITE USE_FIREBIRD USE_PHPEXT \
USE_ZENDEXT USE_PHP_BUILD USE_BDB PLIST_DIRSTRY USE_RCORDER \
- USE_OPENSSL
+ USE_OPENSSL WANT_GNOME
SANITY_DEPRECATED= PYTHON_PKGNAMESUFFIX USE_AUTOTOOLS \
USE_MYSQL WANT_MYSQL_VER \
USE_PHPIZE WANT_PHP_CLI WANT_PHP_CGI WANT_PHP_MOD \
@@ -239,6 +239,7 @@ WANT_PHP_MOD_ALT= USES=php:mod
WANT_PHP_WEB_ALT= USES=php:web
WANT_PHP_EMB_ALT= USES=php:embed
USE_RCORDER_ALT= USE_RC_SUBR=${USE_RCORDER}
+WANT_GNOME_ALT= USES=gnome
.for a in ${SANITY_DEPRECATED}
.if defined(${a})
diff --git a/audio/xmixer/Makefile b/audio/xmixer/Makefile
index aea657fcbf48..9076ac3c856c 100644
--- a/audio/xmixer/Makefile
+++ b/audio/xmixer/Makefile
@@ -12,7 +12,6 @@ COMMENT= Audio mixer (gtk and Xlib) for X11R6
WRKSRC= ${WRKDIR}/${PORTNAME}
-WANT_GNOME= yes
GNU_CONFIGURE= yes
ALL_TARGET= ${PROGRAMS}
diff --git a/audio/xmms-faad/Makefile b/audio/xmms-faad/Makefile
index ce901660164f..2ffa1de47260 100644
--- a/audio/xmms-faad/Makefile
+++ b/audio/xmms-faad/Makefile
@@ -21,7 +21,6 @@ WRKSRC_SUBDIR= plugins/xmms/src
USE_GNOME= gtk12
USES= pkgconfig tar:bzip2
-WANT_GNOME= yes
EXTRA_CFLAGS= `xmms-config --cflags`
EXTRA_LDFLAGS= `xmms-config --libs`
diff --git a/audio/xmp/Makefile b/audio/xmp/Makefile
index 35d8993b8f44..e3dcd89fce6d 100644
--- a/audio/xmp/Makefile
+++ b/audio/xmp/Makefile
@@ -16,7 +16,6 @@ LICENSE= GPLv2
LIB_DEPENDS= libxmp.so:audio/libxmp
USES= gmake localbase:ldflags pkgconfig
-WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc
diff --git a/comms/cqrlog/Makefile b/comms/cqrlog/Makefile
index 5da3d6c02faa..cbe339cbd5d9 100644
--- a/comms/cqrlog/Makefile
+++ b/comms/cqrlog/Makefile
@@ -25,7 +25,6 @@ SHEBANG_FILES= tools/cqrlog-apparmor-fix \
USE_FPC= cairo fcl-base fcl-db fcl-image fcl-json fcl-net fcl-web \
fcl-registry rtl-extra fcl-xml mysql numlib openssl pasjpeg x11
-WANT_GNOME= yes
ALL_TARGET= ${PORTNAME}
LAZARUS_VER= 1.6.4
diff --git a/databases/sqlrelay/Makefile b/databases/sqlrelay/Makefile
index 69893261c506..d2a588dc9996 100644
--- a/databases/sqlrelay/Makefile
+++ b/databases/sqlrelay/Makefile
@@ -16,7 +16,6 @@ LIB_DEPENDS= librudiments.so:devel/rudiments \
libkrb5.so:security/krb5 \
libcurl.so:ftp/curl
-WANT_GNOME= yes
USES= gmake libtool pathfix python readline
PATHFIX_MAKEFILEIN= Makefile
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/deskutils/planner/Makefile b/deskutils/planner/Makefile
index 5dbe2c16c7a2..61bbd768a053 100644
--- a/deskutils/planner/Makefile
+++ b/deskutils/planner/Makefile
@@ -16,7 +16,6 @@ USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
shared-mime-info tar:xz
USE_GNOME= gnomeprefix intlhack libgnomeui libgnomeprintui \
libgsf
-WANT_GNOME= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
diff --git a/devel/distcc/Makefile b/devel/distcc/Makefile
index 70b362790dd6..42e69cc4c3ad 100644
--- a/devel/distcc/Makefile
+++ b/devel/distcc/Makefile
@@ -20,7 +20,6 @@ USES= autoreconf alias gmake libtool pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= distcc
GH_TAGNAME= 9a09372
-WANT_GNOME= yes
GROUPS= distcc
USERS= distcc
diff --git a/devel/mono-addins/Makefile b/devel/mono-addins/Makefile
index 32fcb07f40ea..1ceb2422b4eb 100644
--- a/devel/mono-addins/Makefile
+++ b/devel/mono-addins/Makefile
@@ -16,7 +16,6 @@ GH_ACCOUNT= mono
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_MCS=${LOCALBASE}/bin/mcs
USES= autoreconf gmake mono pkgconfig
-WANT_GNOME= yes
OPTIONS_DEFINE= GTK2 GTK3
OPTIONS_DEFAULT=GTK2
diff --git a/devel/pwlib/Makefile b/devel/pwlib/Makefile
index fc725ce69cb2..70f332d62008 100644
--- a/devel/pwlib/Makefile
+++ b/devel/pwlib/Makefile
@@ -25,7 +25,6 @@ WRKSRC= ${WRKDIR}/ptlib_v${PORTVERSION:S/./_/g}
USES= bison gmake ssl
USE_GCC= any
USE_AUTOTOOLS= autoconf
-WANT_GNOME= yes
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 532d50cb66b8..33cc4e0477ef 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -103,7 +103,6 @@ USE_QT4= # empty but required
USE_XORG= xaw xrandr
USES= autoreconf:build bison compiler:c++11-lib cpe gmake jpeg \
perl5 pkgconfig python shared-mime-info tar:xz
-WANT_GNOME= yes
OPTIONS_DEFINE= CUPS GNOME GTK2 GTK3 JAVA KDE4 MMEDIA PGSQL SDK SYSTRAY \
TEST WEBDAV
diff --git a/emulators/visualboyadvance-m/Makefile b/emulators/visualboyadvance-m/Makefile
index 4b5c0f4183dc..ee25f82768fc 100644
--- a/emulators/visualboyadvance-m/Makefile
+++ b/emulators/visualboyadvance-m/Makefile
@@ -35,7 +35,6 @@ DEBUGGER_DESC= Enable the debugger
ASMCORE_DESC= Enable x86 ASM CPU cores (i386 only)
ASMSCALERS_DESC= Enable x86 ASM graphic filters (i386 only)
-WANT_GNOME= yes
DOS2UNIX_REGEX= .*\.(c|cpp|h|ypp)
USE_XORG= x11 xext
USE_GL= gl glu
diff --git a/java/classpath/Makefile b/java/classpath/Makefile
index 7cb9bb707f12..4f06450ac9a5 100644
--- a/java/classpath/Makefile
+++ b/java/classpath/Makefile
@@ -24,7 +24,6 @@ USES= gmake iconv libtool perl5 pkgconfig
USE_LDCONFIG= yes
USE_PERL5= build
USE_XORG= x11 ice xtst xaw xproto xext
-WANT_GNOME= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/java/icedtea-web/Makefile b/java/icedtea-web/Makefile
index 9a546f3123c2..f72397d00aad 100644
--- a/java/icedtea-web/Makefile
+++ b/java/icedtea-web/Makefile
@@ -28,8 +28,6 @@ USE_XORG= x11
USES= desktop-file-utils gmake perl5 pkgconfig shebangfix
SHEBANG_FILES= jrunscript.in launcher/launchers.in
-WANT_GNOME= yes
-
CONFIGURE_ARGS= --with-hamcrest="${HAMCREST_JAR}"
CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}"
CONFIGURE_ARGS+= --with-jre-home="${JAVA_HOME}/jre"
diff --git a/misc/magicpoint/Makefile b/misc/magicpoint/Makefile
index fe08b76caab3..cc938c2ca10d 100644
--- a/misc/magicpoint/Makefile
+++ b/misc/magicpoint/Makefile
@@ -21,7 +21,6 @@ MAKE_JOBS_UNSAFE= yes
USES= imake:env perl5 pkgconfig
USE_PERL5= run
USE_XORG= x11 xext xmu xt sm ice xi xtst
-WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-vflib --enable-locale
CONFIGURE_ENV= mgp_cv_path_perl=${PERL}
diff --git a/multimedia/gpodder/Makefile b/multimedia/gpodder/Makefile
index 130746e05baf..5ce098be6c21 100644
--- a/multimedia/gpodder/Makefile
+++ b/multimedia/gpodder/Makefile
@@ -38,7 +38,6 @@ MAKEFILE= makefile
NO_ARCH= yes
USES= gettext gmake python:-2.7 shebangfix
SHEBANG_FILES= src/gpodder/*.py share/gpodder/examples/*.py share/gpodder/extensions/*.py
-WANT_GNOME= yes
INSTALLS_ICONS= yes
PLIST_SUB+= PORTVERSION=${PORTVERSION}
PORTDOCS= PKG-INFO README
diff --git a/multimedia/mplayer/Makefile.common b/multimedia/mplayer/Makefile.common
index 8d5a3cd3e8b4..37dafebd91b7 100644
--- a/multimedia/mplayer/Makefile.common
+++ b/multimedia/mplayer/Makefile.common
@@ -50,8 +50,6 @@ CONFIGURE_ARGS= --cc="${CC}" \
--disable-real \
--yasm=''
-WANT_GNOME= yes
-
common-post-patch:
@${REINPLACE_CMD} \
-e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|; \
diff --git a/multimedia/transcode/Makefile b/multimedia/transcode/Makefile
index 252303309330..3f9ced624415 100644
--- a/multimedia/transcode/Makefile
+++ b/multimedia/transcode/Makefile
@@ -16,7 +16,6 @@ LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
USE_LDCONFIG= yes
USES= gmake libtool pkgconfig tar:bzip2
-WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-oss
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index 415464303bfc..db3e460b634d 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -28,12 +28,10 @@ INSTALL_TARGET= install-strip
# set these macros themselves.
USES+= iconv python shebangfix
USE_LDCONFIG= yes
-WANT_GNOME= yes
SHEBANG_FILES= libpurple/purple-remote \
libpurple/purple-url-handler
.if defined(PACKAGE_BUILDING)
-.undef WITHOUT_GNOME
WITH_GNOME= yes
.endif
@@ -126,7 +124,7 @@ USE_GNOME+= gconf2
GCONF_SCHEMAS= purple.schemas
.endif
-#.if defined(WITH_GTKUI) && ${HAVE_GNOME:Mevolutiondataserver}!=""
+#.if defined(WITH_GTKUI)
#USE_GNOME+= evolutiondataserver
#PLIST_SUB+= EVO=""
#CONFIGURE_ARGS+= --enable-gevolution
diff --git a/net-im/pidgin/Makefile b/net-im/pidgin/Makefile
index 38e20e0ae2ba..db9368ea420f 100644
--- a/net-im/pidgin/Makefile
+++ b/net-im/pidgin/Makefile
@@ -24,7 +24,6 @@ USES= python:build
USE_LDCONFIG= yes
USE_GNOME= gnomeprefix gtk20 intltool
USE_XORG= xscrnsaver sm
-WANT_GNOME= yes
CONFIGURE_ARGS= --disable-consoleui \
--disable-nm \
--enable-screensaver \
diff --git a/net/unison-devel/Makefile b/net/unison-devel/Makefile
index 5638129de01c..e2b87c3f0ecf 100644
--- a/net/unison-devel/Makefile
+++ b/net/unison-devel/Makefile
@@ -23,7 +23,6 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
USES= gmake
USE_OCAML= yes
NO_OCAML_RUNDEPENDS=yes
-WANT_GNOME= yes
MAKE_ARGS= CFLAGS=""
CONFLICTS= unison-[0-9]* unison-nox11-[0-9]*
diff --git a/net/unison/Makefile b/net/unison/Makefile
index 241d569a5960..7bed7fdc682b 100644
--- a/net/unison/Makefile
+++ b/net/unison/Makefile
@@ -20,7 +20,6 @@ USES= gmake localbase
USE_OCAML= yes
WRKSRC= ${WRKDIR}/src
NO_OCAML_RUNDEPENDS=yes
-WANT_GNOME= yes
CONFLICTS?= unison-devel-[0-9]* unison-nox11-[0-9]*
MAKE_ENV= CLIBS="${LIBS:S/^-/-ccopt -/}" COFLAGS="${CFLAGS:C/ *(-[^ ]*) */ -ccopt \"\1 \"/gW}"
MAKE_JOBS_UNSAFE= yes
diff --git a/net/unison232/Makefile b/net/unison232/Makefile
index f9bcca356887..c2041ff8970f 100644
--- a/net/unison232/Makefile
+++ b/net/unison232/Makefile
@@ -21,7 +21,6 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
USES= gmake
USE_OCAML= yes
NO_OCAML_RUNDEPENDS=yes
-WANT_GNOME= yes
MAKE_ARGS= CFLAGS=""
MAKE_JOBS_UNSAFE= yes
diff --git a/net/unison240/Makefile b/net/unison240/Makefile
index fe73b874a4f9..32103a41347f 100644
--- a/net/unison240/Makefile
+++ b/net/unison240/Makefile
@@ -20,7 +20,6 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
USES= gmake
USE_OCAML= yes
NO_OCAML_RUNDEPENDS=yes
-WANT_GNOME= yes
MAKE_ARGS= CFLAGS=""
MAKE_JOBS_UNSAFE= yes
diff --git a/net/yate/Makefile b/net/yate/Makefile
index 61b85772bffd..ee79f7c7b8a7 100644
--- a/net/yate/Makefile
+++ b/net/yate/Makefile
@@ -26,7 +26,6 @@ SHEBANG_FILES= share/scripts/banbrutes.php \
share/scripts/route.php \
share/scripts/voicemail.php
USE_LDCONFIG= yes
-WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-fdsize \
diff --git a/print/ghostscript7-base/Makefile b/print/ghostscript7-base/Makefile
index 7dcb0cf2ed70..3617262da140 100644
--- a/print/ghostscript7-base/Makefile
+++ b/print/ghostscript7-base/Makefile
@@ -30,7 +30,6 @@ CONFLICTS_INSTALL= \
USES= autoreconf gmake jpeg shebangfix tar:bzip2
USE_LDCONFIG= yes
SHEBANG_FILES= lib/fixmswrd.pl
-WANT_GNOME= yes
# normazile WRKSRC so things like cups-pstoraster may work
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_JOBS_UNSAFE= yes
diff --git a/sysutils/cdrdao/Makefile b/sysutils/cdrdao/Makefile
index 17c794a87c8f..0ee2053f5e36 100644
--- a/sysutils/cdrdao/Makefile
+++ b/sysutils/cdrdao/Makefile
@@ -37,7 +37,6 @@ TOC2MP3_DESC= Build with toc2mp3 (requires audio/lame)
.if ${PORTNAME} == "gcdmaster"
USES+= pkgconfig shared-mime-info
-WANT_GNOME= yes
GCONF_SCHEMAS= gcdmaster.schemas
LIB_DEPENDS+= ${MP3OGG_LIB_DEPENDS} \
libgnomeuimm-2.6.so:x11-toolkits/libgnomeuimm26
diff --git a/sysutils/gkrellm2/Makefile b/sysutils/gkrellm2/Makefile
index 8c4071292472..e289699ab0a3 100644
--- a/sysutils/gkrellm2/Makefile
+++ b/sysutils/gkrellm2/Makefile
@@ -15,7 +15,6 @@ LICENSE= GPLv3
USES= gmake pkgconfig tar:bzip2
USE_RC_SUBR= gkrellmd
-WANT_GNOME= yes
OPTIONS_DEFINE= DOCS CLIENT NLS NTLM OPENSSL
OPTIONS_DEFAULT= CLIENT NTLM OPENSSL
diff --git a/sysutils/thefish/Makefile b/sysutils/thefish/Makefile
index d29d12198e55..dd78b83444ad 100644
--- a/sysutils/thefish/Makefile
+++ b/sysutils/thefish/Makefile
@@ -12,7 +12,6 @@ COMMENT= Gtk+/ncurses rc.conf editor/management tool
LICENSE= BSD2CLAUSE
USES= pkgconfig tar:xz
-WANT_GNOME= yes
OPTIONS_SINGLE= X11
OPTIONS_SINGLE_X11= GTK2
diff --git a/sysutils/xcdroast/Makefile b/sysutils/xcdroast/Makefile
index 1b4626e35eeb..7066e637d550 100644
--- a/sysutils/xcdroast/Makefile
+++ b/sysutils/xcdroast/Makefile
@@ -22,7 +22,6 @@ BUILD_DEPENDS= cdrecord:sysutils/cdrtools
USES= gettext gmake iconv pkgconfig
GNU_CONFIGURE= yes
-WANT_GNOME= yes
CONFIGURE_ENV+= GTK_CONFIG="${GTK_CONFIG}" \
GLIB_CONFIG="${GLIB_CONFIG}"
diff --git a/textproc/uim/Makefile b/textproc/uim/Makefile
index 3bfba79f5e8e..0e9c1fcb9622 100644
--- a/textproc/uim/Makefile
+++ b/textproc/uim/Makefile
@@ -16,7 +16,6 @@ COMMENT?= Input method library
BROKEN_aarch64= Fails to build: The collector has not been ported to this machine/OS combination
USE_LDCONFIG= yes
-WANT_GNOME= yes
USE_GNOME+= glib20 intltool
USES+= gettext gmake iconv libedit libtool pathfix pkgconfig perl5 tar:bzip2
USE_PERL5= build
diff --git a/www/linux-opera/Makefile b/www/linux-opera/Makefile
index b52149e67a1f..7768fc123f9d 100644
--- a/www/linux-opera/Makefile
+++ b/www/linux-opera/Makefile
@@ -24,7 +24,6 @@ RUN_DEPENDS= update-mime-database:misc/shared-mime-info
USES= desktop-file-utils linux shared-mime-info tar:xz
USE_LINUX= gtk2 sqlite3 xorglibs
ONLY_FOR_ARCHS= i386 amd64
-WANT_GNOME= yes
INSTALLS_ICONS= yes
NO_BUILD= yes
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 1028706f4731..ce5d8288df96 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -236,8 +236,6 @@ X11_DESC= graphics/ImageMagick[-nox11] dependency
XSS_DESC= 3rd party xss module
VIDEO_DESC= Video module support
-WANT_GNOME= yes
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11}
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index edd4b1a4a085..12d4e4ba6fa9 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -246,8 +246,6 @@ X11_DESC= graphics/ImageMagick[-nox11] dependency
XSS_DESC= 3rd party xss module
VIDEO_DESC= Video module support
-WANT_GNOME= yes
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11}
diff --git a/x11-fm/doublecmd/Makefile b/x11-fm/doublecmd/Makefile
index 08f6f31d6e01..a9a17fab779f 100644
--- a/x11-fm/doublecmd/Makefile
+++ b/x11-fm/doublecmd/Makefile
@@ -26,7 +26,6 @@ USE_FPC= cairo fcl-base fcl-db fcl-image fcl-json fcl-registry \
fcl-xml iconvenc pasjpeg rtl-extra x11
USE_XORG= x11
DOS2UNIX_FILES= src/dmhelpmanager.pas
-WANT_GNOME= yes
PLIST= ${WRKDIR}/pkg-plist
diff --git a/x11-themes/gnome-icons-jini/Makefile b/x11-themes/gnome-icons-jini/Makefile
index 9a0dd01afe20..d10d8ecd69f5 100644
--- a/x11-themes/gnome-icons-jini/Makefile
+++ b/x11-themes/gnome-icons-jini/Makefile
@@ -12,7 +12,6 @@ COMMENT= Jini Icons for Gnome
NO_BUILD= yes
WRKSRC= ${WRKDIR}
-WANT_GNOME= yes
INSTALLS_ICONS= yes
post-extract:
diff --git a/x11-themes/gnome-icons/bsd.gnome-icons.mk b/x11-themes/gnome-icons/bsd.gnome-icons.mk
index 86bb6ed76548..2484b1e7d679 100644
--- a/x11-themes/gnome-icons/bsd.gnome-icons.mk
+++ b/x11-themes/gnome-icons/bsd.gnome-icons.mk
@@ -9,7 +9,6 @@ NO_ARCH= yes
REASON= Themes may contain artwork not done by the author. \
Keep FreeBSD safe if theme author violated copyrights.
-WANT_GNOME= yes
INSTALLS_ICONS= yes
do-install: icon-do-install
diff --git a/x11/eaglemode/Makefile b/x11/eaglemode/Makefile
index c6c642420e89..ad023965813c 100644
--- a/x11/eaglemode/Makefile
+++ b/x11/eaglemode/Makefile
@@ -20,7 +20,6 @@ USES= compiler:features jpeg perl5 pkgconfig shebangfix tar:bzip2
USE_PERL5= build
USE_XORG= x11 xext xxf86vm
SUB_FILES= eaglemode.sh
-WANT_GNOME= yes
BUILD_ARGS= continue=no
diff --git a/x11/metisse/Makefile b/x11/metisse/Makefile
index 6d4ab24855b8..fac9df80fc80 100644
--- a/x11/metisse/Makefile
+++ b/x11/metisse/Makefile
@@ -44,7 +44,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-fontdir=${LOCALBASE}/share/fonts
USE_LDCONFIG= yes
USE_XORG= xcursor xft xinerama xpm xrender xt xtst
-WANT_GNOME= yes
MAKE_ARGS= METISSE_DOC_DIR="${DOCSDIR}"
INSTALL_TARGET= install-strip
diff --git a/x11/xvattr/Makefile b/x11/xvattr/Makefile
index b9f9d80163f5..4758f5b094c3 100644
--- a/x11/xvattr/Makefile
+++ b/x11/xvattr/Makefile
@@ -12,7 +12,6 @@ MAINTAINER= cy@FreeBSD.org
COMMENT= Getting and setting Xv attributes
USE_XORG= x11 xv
-WANT_GNOME= yes
USES= pkgconfig
PLIST_FILES= bin/${PORTNAME} bin/g${PORTNAME} \