aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2003-09-02 15:45:45 +0000
committerPeter Pentchev <roam@FreeBSD.org>2003-09-02 15:45:45 +0000
commit4df511c24770c0f97791a446e682ecbe38cd31e5 (patch)
tree14530b5e01719c80675468f2823a24adc4b35a0b
parentdd5899bd4d4a710a06e8c3d72009eae50b4887ad (diff)
downloadports-4df511c24770c0f97791a446e682ecbe38cd31e5.tar.gz
ports-4df511c24770c0f97791a446e682ecbe38cd31e5.zip
Update to 2.3.0b, enabling cracklib use and installing docfiles.
PR: 55884 Submitted by: Roman Neuhauser <roman@bellavista.cz>
Notes
Notes: svn path=/head/; revision=88365
-rw-r--r--security/apg/Makefile26
-rw-r--r--security/apg/distinfo2
-rw-r--r--security/apg/files/patch-aa55
-rw-r--r--security/apg/pkg-plist5
4 files changed, 57 insertions, 31 deletions
diff --git a/security/apg/Makefile b/security/apg/Makefile
index 24b7dca42c8f..29cec681657d 100644
--- a/security/apg/Makefile
+++ b/security/apg/Makefile
@@ -6,16 +6,38 @@
#
PORTNAME= apg
-PORTVERSION= 2.1.0
+PORTVERSION= 2.3.0b
CATEGORIES= security
MASTER_SITES= http://www.adel.nursat.kz/apg/download/ \
${MASTER_SITE_PACKETSTORM}
MASTER_SITE_SUBDIR= UNIX/misc
MAINTAINER= roam@FreeBSD.org
-COMMENT= "An automated password generator"
+COMMENT= An automated password generator
+
+.if defined(WITH_CRACKLIB)
+BUILD_DEPENDS= ${LOCALBASE}/lib/crack.a:${PORTSDIR}/security/cracklib
+MAKE_ARGS= -DWITH_CRACKLIB
+.endif
MAN1= apg.1 apgbfm.1
MAN8= apgd.8
+DOCS= APG_TIPS pronun.txt rfc0972.txt rfc1750.txt
+
+post-extract:
+ ${FIND} ${WRKSRC} -type d | ${XARGS} ${CHMOD} u+wx
+ ${FIND} ${WRKSRC} -type f | ${XARGS} ${CHMOD} u+w
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/apg ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/apgbfm ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/apgd ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/doc/man/apg.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/man/apgbfm.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/man/apgd.8 ${MANPREFIX}/man/man8
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/doc/,} ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/security/apg/distinfo b/security/apg/distinfo
index ebd05b405e95..bf40f19e50d6 100644
--- a/security/apg/distinfo
+++ b/security/apg/distinfo
@@ -1 +1 @@
-MD5 (apg-2.1.0.tar.gz) = 402769cce2c5ffef9806993d93c5b56d
+MD5 (apg-2.3.0b.tar.gz) = bd82400a5a731070ce895313576afe24
diff --git a/security/apg/files/patch-aa b/security/apg/files/patch-aa
index 89340e111829..0a259f8641bf 100644
--- a/security/apg/files/patch-aa
+++ b/security/apg/files/patch-aa
@@ -1,6 +1,23 @@
---- Makefile 20 Sep 2002 07:24:50 -0000 1.1.1.4
-+++ Makefile 20 Sep 2002 07:27:21 -0000 1.6
-@@ -1,12 +1,12 @@
+--- Makefile.orig Thu Aug 7 17:40:39 2003
++++ Makefile Sat Aug 23 00:18:35 2003
+@@ -44,10 +44,12 @@
+ # If you want to use cracklib for password quality check then you
+ # must uncomment the folowing 4 lines (you must not do this for WIN32)
+ #
+-#CRACKLIB_DICTPATH = "/usr/local/lib/pw_dict"
+-#STANDALONE_OPTIONS += -DAPG_USE_CRACKLIB '-DCRACKLIB_DICTPATH=${CRACKLIB_DICTPATH}' -I/usr/local/include -L/usr/local/lib
+-#CLISERV_OPTIONS += -DAPG_USE_CRACKLIB '-DCRACKLIB_DICTPATH=${CRACKLIB_DICTPATH}' -I/usr/local/include -L/usr/local/lib
+-#APG_CLIBS += -lcrack
++.if defined(WITH_CRACKLIB)
++CRACKLIB_DICTPATH = "${LOCALBASE}/libdata/cracklib/pw_dict"
++STANDALONE_OPTIONS += -DAPG_USE_CRACKLIB '-DCRACKLIB_DICTPATH=${CRACKLIB_DICTPATH}' -I${LOCALBASE}/include -L${LOCALBASE}/lib
++CLISERV_OPTIONS += -DAPG_USE_CRACKLIB '-DCRACKLIB_DICTPATH=${CRACKLIB_DICTPATH}' -I${LOCALBASE}/include -L${LOCALBASE}/lib
++APG_CLIBS += -lcrack
++.endif
+
+ ##################################################################
+ # Support for ANSI X9.17/SHA1 PRNG
+@@ -60,12 +62,12 @@
##################################################################
# You can modify CC variable if you have compiler other than GCC
# But the code was designed and tested with GCC
@@ -10,35 +27,17 @@
##################################################################
# Compilation flags
# You should comment the line below for AIX+native cc
--FLAGS = -Wall
+-CFLAGS = -Wall
+CFLAGS ?= -Wall
- ##################################################################
- # Libraries
-@@ -37,7 +37,8 @@
- ##################################################################
- # Directories
- # Install dirs
--INSTALL_PREFIX = /usr/local
-+PREFIX ?= /usr/local
-+INSTALL_PREFIX = ${PREFIX}
- APG_BIN_DIR = /bin
- APG_MAN_DIR = /man/man1
- APGD_BIN_DIR = /sbin
-@@ -88,13 +89,13 @@
- cygwin: standalone
-
- apg:
-- ${CC} ${FLAGS} -D${CRYPTED_PASS} -D${USE_SHA} -o ${PROGNAME} ${SOURCES} ${LIBS} ${LIBM}
-+ ${CC} ${CFLAGS} -D${CRYPTED_PASS} -D${USE_SHA} -o ${PROGNAME} ${SOURCES} ${LIBS} ${LIBM}
-
- apgd:
-- ${CC} ${FLAGS} -DCLISERV -D${USE_SHA} -o ${CS_PROGNAME} ${SOURCES} ${CS_LIBS} ${LIBM}
-+ ${CC} ${CFLAGS} -DCLISERV -D${USE_SHA} -o ${CS_PROGNAME} ${SOURCES} ${CS_LIBS} ${LIBM}
+ ####################################################################
+ # If you plan to install APG daemon you should look at lines below #
+@@ -135,7 +137,7 @@
+ ${CC} ${CFLAGS} -DCLISERV ${CLISERV_OPTIONS} -o ${CS_PROGNAME} ${SOURCES} ${APG_CS_CLIBS}
apgbfm:
-- ${CC} ${FLAGS} -o ${BFM_PROGNAME} ${BFM_SOURCES} ${LIBM}
-+ ${CC} ${CFLAGS} -o ${BFM_PROGNAME} ${BFM_SOURCES} ${LIBM}
+- ${CC} ${FLAGS} -DAPGBFM -o ${BFM_PROGNAME} ${BFM_SOURCES} ${APGBFM_CLIBS}
++ ${CC} ${CFLAGS} -DAPGBFM -o ${BFM_PROGNAME} ${BFM_SOURCES} ${APGBFM_CLIBS}
strip:
strip ${PROGNAME}
diff --git a/security/apg/pkg-plist b/security/apg/pkg-plist
index 87f7236ac1a6..cb858afcd8dd 100644
--- a/security/apg/pkg-plist
+++ b/security/apg/pkg-plist
@@ -1,3 +1,8 @@
bin/apg
bin/apgbfm
sbin/apgd
+%%PORTDOCS%%%%DOCSDIR%%/APG_TIPS
+%%PORTDOCS%%%%DOCSDIR%%/pronun.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc0972.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc1750.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%