aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-03 19:45:22 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-03 19:45:22 +0000
commit4e9a20f4b57ab013e7fddd2aeaf33d110b4fca63 (patch)
tree31b7a7ca5e0d286dd0b091909f3f5e594898260b
parent6a4fc9fe83ed53c7d295b67b69884cfd233d0af6 (diff)
Notes
-rw-r--r--www/buku/Makefile31
-rw-r--r--www/buku/distinfo6
-rw-r--r--www/buku/files/patch-setup.py30
-rw-r--r--www/buku/pkg-descr23
4 files changed, 34 insertions, 56 deletions
diff --git a/www/buku/Makefile b/www/buku/Makefile
index 3e2b2c39be91..fa8bd6a94748 100644
--- a/www/buku/Makefile
+++ b/www/buku/Makefile
@@ -2,37 +2,34 @@
# $FreeBSD$
PORTNAME= buku
-PORTVERSION= 4.0
-DISTVERSIONPREFIX= v
+PORTVERSION= 4.3
CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Powerful command-line bookmark manager
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.0:www/py-beautifulsoup@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}cryptography>=1.3.4:security/py-cryptography@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}requests>=2.0.1:www/py-requests@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}urllib3>=1.21.1:net/py-urllib3@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}html5lib>0:www/py-html5lib@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.4.1:www/py-beautifulsoup@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}certifi>=0:security/py-certifi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>=1.2.3:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}html5lib>=1.0.1:www/py-html5lib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urllib3>=1.23:net/py-urllib3@${PY_FLAVOR}
-USES= python:3.4+
-USE_GITHUB= yes
+USES= python:3.5+
USE_PYTHON= autoplist distutils noflavors
NO_ARCH= yes
-GH_ACCOUNT= jarun
-GH_PROJECT= Buku
-
-PLIST_FILES= man/man1/buku.1.gz
+PLIST_FILES= share/man/man1/buku.1.gz
post-extract:
- @${RM} -rf ${WRKSRC}/bukuserver
+ @${RM} -fr ${WRKSRC}/bukuserver
post-install:
- ${INSTALL_MAN} ${WRKSRC}/buku.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/buku.1 ${STAGEDIR}${MANPREFIX}/share/man/man1
.include <bsd.port.mk>
diff --git a/www/buku/distinfo b/www/buku/distinfo
index 98ea8b47176f..c7039ed610bf 100644
--- a/www/buku/distinfo
+++ b/www/buku/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1541143686
-SHA256 (jarun-Buku-v4.0_GH0.tar.gz) = 35a3ebeeb715ec1170360570c3e43cb1308b67a75979ae264aac9961c778d2af
-SIZE (jarun-Buku-v4.0_GH0.tar.gz) = 475436
+TIMESTAMP = 1580746223
+SHA256 (buku-4.3.tar.gz) = d64eb7f192b60252e60cf72649c7d42fb18eb6c08852c288a991d4a0458be381
+SIZE (buku-4.3.tar.gz) = 264480
diff --git a/www/buku/files/patch-setup.py b/www/buku/files/patch-setup.py
index 24f58936204d..70c67a268abe 100644
--- a/www/buku/files/patch-setup.py
+++ b/www/buku/files/patch-setup.py
@@ -1,26 +1,6 @@
---- setup.py.orig 2018-08-30 12:28:10 UTC
+--- setup.py.orig 2020-01-09 21:02:00 UTC
+++ setup.py
-@@ -28,19 +28,6 @@ tests_require = [
- ]
-
-
--server_require = [
-- 'arrow>=0.12.1',
-- 'click>=6.7',
-- 'Flask-Admin==1.5.1',
-- 'Flask-API>=0.6.9',
-- 'Flask-Bootstrap>=3.3.7.1',
-- 'flask-paginate>=0.5.1',
-- 'Flask-WTF>=0.14.2',
-- 'Flask>=0.12',
-- 'requests>=2.18.4',
-- 'Werkzeug>=0.11.15',
--]
--
- setup(
- name='buku',
- version=version,
-@@ -63,11 +50,10 @@ setup(
+@@ -81,7 +81,7 @@ setup(
packages=find_packages(exclude=['tests']),
include_package_data=True,
entry_points={
@@ -28,8 +8,4 @@
+ 'console_scripts': ['buku=buku:main']
},
extras_require={
- 'tests': tests_require,
-- 'server': server_require,
- 'packaging': ['twine>=1.11.0']
- },
- test_suite='tests',
+ 'tests': tests_require + server_require,
diff --git a/www/buku/pkg-descr b/www/buku/pkg-descr
index 669cd36b9912..4e878e67c3ff 100644
--- a/www/buku/pkg-descr
+++ b/www/buku/pkg-descr
@@ -1,11 +1,16 @@
-Powerful bookmark manager written in Python3 and SQLite3. A flexible cmdline
-solution with a private, portable, merge-able database along with browser
-integration.
+buku is a powerful bookmark manager written in Python3 and SQLite3. When I
+started writing it, I couldn't find a flexible command-line solution with a
+private, portable, merge-able database along with seamless GUI integration.
+Hence, buku (after my son's nickname, meaning close to the heart in my
+language).
-buku fetches the title of a bookmarked web page and stores it along with any
-additional comments and tags. You can use your favourite editor to compose and
-update bookmarks. With multiple search options, including regex and a deep scan
-mode (particularly for URLs), it can find any bookmark instantly. Multiple
-search results can be opened in the browser at once.
+buku can auto-import bookmarks from your browser(s) or fetch the title and
+description of a bookmarked url from the web. You can use your favourite editor
+to compose and update bookmarks. With multiple search options, including regex
+and a deep scan mode (particularly for URLs), it can find any bookmark
+instantly. buku can look up the latest snapshot of a broken link on the Wayback
+Machine. There's an Easter egg to revisit random forgotten bookmarks too! Buku
+is too busy to track you: no hidden history, obsolete records, usage analytics
+or homing.
-WWW: https://github.com/jarun/Buku
+WWW: https://github.com/jarun/buku