aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2020-02-11 12:57:42 +0000
committerRenato Botelho <garga@FreeBSD.org>2020-02-11 12:57:42 +0000
commit4ec2641eb1050e50a57f963ef8fabc2625693618 (patch)
tree6afbf1dcc06bbc6388972b4bdf4720b61f21e2c0
parent61d4c8851ea3a4baef5b32d8f5028f5eeb9bb5f0 (diff)
downloadports-4ec2641eb1050e50a57f963ef8fabc2625693618.tar.gz
ports-4ec2641eb1050e50a57f963ef8fabc2625693618.zip
Notes
-rw-r--r--www/sarg/Makefile2
-rw-r--r--www/sarg/distinfo6
-rw-r--r--www/sarg/files/patch-Makefile.in15
-rw-r--r--www/sarg/files/patch-configure.ac10
-rw-r--r--www/sarg/files/patch-decomp.c11
-rw-r--r--www/sarg/files/patch-util.c21
-rw-r--r--www/sarg/pkg-plist7
7 files changed, 50 insertions, 22 deletions
diff --git a/www/sarg/Makefile b/www/sarg/Makefile
index 020f7a4e90b8..bea851d2c40c 100644
--- a/www/sarg/Makefile
+++ b/www/sarg/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sarg
-PORTVERSION= 2.3.11
+PORTVERSION= 2.4.0
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/www/sarg/distinfo b/www/sarg/distinfo
index 2477a7191e96..6d5ecdf6820e 100644
--- a/www/sarg/distinfo
+++ b/www/sarg/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1528577696
-SHA256 (sarg-2.3.11.tar.gz) = d0f8fbefb5fdc716e75c778525d96ac9eef622d3de94da8d70e2bdc7ab81daa2
-SIZE (sarg-2.3.11.tar.gz) = 1346884
+TIMESTAMP = 1581420984
+SHA256 (sarg-2.4.0.tar.gz) = b4ca0f41f6467673b4c65c6798b44a8886f08180c055eb11c37a96dfc28cb5c3
+SIZE (sarg-2.4.0.tar.gz) = 1371812
diff --git a/www/sarg/files/patch-Makefile.in b/www/sarg/files/patch-Makefile.in
index ca0356d4d672..aadbcbbb4e7b 100644
--- a/www/sarg/files/patch-Makefile.in
+++ b/www/sarg/files/patch-Makefile.in
@@ -1,24 +1,25 @@
---- Makefile.in.orig 2015-04-12 14:38:36 UTC
+--- Makefile.in.orig 2017-01-30 12:56:22 UTC
+++ Makefile.in
-@@ -27,11 +27,11 @@ DEFS = $(IBINDIR) $(ISYSCONFDIR)
- LIBS = @LIBS@ -lm
+@@ -27,12 +27,12 @@ DEFS = $(IBINDIR) $(ISYSCONFDIR) $(IFONTDIR) $(
+ LIBS = @LIBS@ @LIBINTL@ -lm
SRCDIR = .
VPATH = .
-INSTALL = cp
+INSTALL = @INSTALL@ -m 644 -S
XSL_MAN_STYLESHEET=@XSL_MAN_STYLESHEET@
XSL_HTML_STYLESHEET=@XSL_HTML_STYLESHEET@
+ EXEEXT = @EXEEXT@
-INSTALL_PROGRAM = $(INSTALL)
+INSTALL_PROGRAM = @INSTALL@ -m 755 -S -s
SRCS = util.c log.c report.c topuser.c email.c sort.c html.c \
- index.c getconf.c usage.c decomp.c ip2name.c ip2name_dns.c \
-@@ -93,14 +93,11 @@ install: all install-po
+ index.c getconf.c usage.c decomp.c ip2name.c ip2name_dns.c \
+@@ -111,14 +111,11 @@ install: all install-po
mkdir -p $(DESTDIR)$(IMAGEDIR); \
fi
- $(INSTALL_PROGRAM) sarg $(DESTDIR)$(bindir)/sarg
-- chmod 755 $(DESTDIR)$(bindir)/sarg
+ $(INSTALL_PROGRAM) sarg$(EXEEXT) $(DESTDIR)$(bindir)/sarg$(EXEEXT);
+- chmod 755 $(DESTDIR)$(bindir)/sarg$(EXEEXT);
- $(INSTALL_PROGRAM) sarg.1 $(DESTDIR)$(man1dir)/sarg.1
- chmod 755 $(DESTDIR)$(man1dir)/sarg.1
+ $(INSTALL) sarg.1 $(DESTDIR)$(man1dir)/sarg.1
diff --git a/www/sarg/files/patch-configure.ac b/www/sarg/files/patch-configure.ac
deleted file mode 100644
index d2ab97be179b..000000000000
--- a/www/sarg/files/patch-configure.ac
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.ac.orig 2018-01-14 19:01:22 UTC
-+++ configure.ac
-@@ -2,6 +2,7 @@ dnl Process this file with autoconf or autoreconf to p
- AC_INIT([sarg],[2.3.11])
- AC_CONFIG_SRCDIR([log.c])
- AC_CONFIG_AUX_DIR(cfgaux)
-+AC_CONFIG_MACRO_DIR([m4])
-
- AC_CANONICAL_HOST
-
diff --git a/www/sarg/files/patch-decomp.c b/www/sarg/files/patch-decomp.c
new file mode 100644
index 000000000000..75800731f088
--- /dev/null
+++ b/www/sarg/files/patch-decomp.c
@@ -0,0 +1,11 @@
+--- decomp.c.orig 2020-02-11 12:34:30 UTC
++++ decomp.c
+@@ -486,7 +486,7 @@ FileObject *decomp(const char *arq)
+ ssize_t nread;
+
+ // guess file type
+- fd=open(arq,O_RDONLY | O_LARGEFILE);
++ fd=open(arq,O_RDONLY);
+ if (fd==-1) {
+ debuga(__FILE__,__LINE__,_("Cannot open file \"%s\": %s\n"),arq,strerror(errno));
+ exit(EXIT_FAILURE);
diff --git a/www/sarg/files/patch-util.c b/www/sarg/files/patch-util.c
new file mode 100644
index 000000000000..b030e98fab20
--- /dev/null
+++ b/www/sarg/files/patch-util.c
@@ -0,0 +1,21 @@
+--- util.c.orig 2020-02-11 12:29:43 UTC
++++ util.c
+@@ -27,6 +27,9 @@
+ // #define LEGACY_MY_ATOLL
+ // #define LEGACY_TESTVALIDUSERCHAR
+
++#include <sys/param.h>
++#include <sys/stat.h>
++
+ #include "include/conf.h"
+ #include "include/defs.h"
+
+@@ -402,7 +405,7 @@ int is_absolute(const char *path)
+
+ int PortableMkDir(const char *path,int mode)
+ {
+-#if defined(__linux__)
++#if defined(__linux__) || defined(__FreeBSD__)
+ int mkerror=mkdir(path,mode);
+ #else //mingw
+ (void)mode;
diff --git a/www/sarg/pkg-plist b/www/sarg/pkg-plist
index f03fa34ec847..62adea631555 100644
--- a/www/sarg/pkg-plist
+++ b/www/sarg/pkg-plist
@@ -14,9 +14,11 @@ man/man1/sarg.1.gz
%%PHP%%etc/sarg/sarg-php/COPYING
%%PHP%%etc/sarg/sarg-php/INSTALL
%%PHP%%etc/sarg/sarg-php/LANGUAGES
-%%PHP%%etc/sarg/sarg-php/language.php
+%%PHP%%etc/sarg/sarg-php/config.php.inc
%%PHP%%etc/sarg/sarg-php/locale/en_EN/LC_MESSAGES/messages.mo
%%PHP%%etc/sarg/sarg-php/locale/en_EN/LC_MESSAGES/messages.po
+%%PHP%%etc/sarg/sarg-php/locale/es/LC_MESSAGES/messages.mo
+%%PHP%%etc/sarg/sarg-php/locale/es/LC_MESSAGES/messages.po
%%PHP%%etc/sarg/sarg-php/locale/fr/LC_MESSAGES/messages.mo
%%PHP%%etc/sarg/sarg-php/locale/fr/LC_MESSAGES/messages.po
%%PHP%%etc/sarg/sarg-php/locale/pt_BR/LC_MESSAGES/messages.mo
@@ -29,6 +31,9 @@ man/man1/sarg.1.gz
%%PHP%%etc/sarg/sarg-php/sarg-squidguard-block2.php
%%PHP%%etc/sarg/sarg-php/style.php
%%PHP%%etc/sarg/sarg-php/translate.this
+%%PHP%%etc/sarg/sarg-php/update-mo.sh
+%%PHP%%etc/sarg/sarg-php/update-po.sh
+%%PHP%%etc/sarg/sarg-php/url_validator.php.inc
etc/sarg/user_limit_block
%%NLS%%share/locale/bg/LC_MESSAGES/sarg.mo
%%NLS%%share/locale/ca/LC_MESSAGES/sarg.mo