aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-02-13 02:44:48 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-02-13 02:44:48 +0000
commit4ec9eee6db2eee233489749db06069aeed583bb7 (patch)
treed7b00b31755d52c762539107730b7241e16db127
parentcc36c74ac326aae5e72985bfaf0efddc96468dcc (diff)
downloadports-4ec9eee6db2eee233489749db06069aeed583bb7.tar.gz
ports-4ec9eee6db2eee233489749db06069aeed583bb7.zip
Notes
-rw-r--r--lang/ghc/bsd.hackage.mk1
-rw-r--r--security/hs-cryptocipher/Makefile22
-rw-r--r--security/hs-cryptocipher/distinfo2
-rw-r--r--security/hs-cryptocipher/pkg-descr3
4 files changed, 28 insertions, 0 deletions
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index f219e600ce2b..05ea83178c28 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -57,6 +57,7 @@ criterion_port= benchmarks/hs-criterion
Crypto_port= security/hs-Crypto
crypto-api_port= security/hs-crypto-api
crypto-pubkey-types_port= security/hs-crypto-pubkey-types
+cryptocipher_port= security/hs-cryptocipher
csv_port= textproc/hs-csv
curl_port= ftp/hs-curl
darcs_port= devel/hs-darcs # executable
diff --git a/security/hs-cryptocipher/Makefile b/security/hs-cryptocipher/Makefile
new file mode 100644
index 000000000000..393ff99e4347
--- /dev/null
+++ b/security/hs-cryptocipher/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: hs-cryptocipher
+# Date created: November 19, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= cryptocipher
+PORTVERSION= 0.3.0
+CATEGORIES= security haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Symmetrical Block, Stream, and PubKey Ciphers
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= cereal crypto-api>=0.5 crypto-pubkey-types primitive tagged \
+ vector>=0.7
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/security/hs-cryptocipher/distinfo b/security/hs-cryptocipher/distinfo
new file mode 100644
index 000000000000..b0b6d48a1b33
--- /dev/null
+++ b/security/hs-cryptocipher/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/cryptocipher-0.3.0.tar.gz) = 3d7a5a8de809c5189ea333c704903e3c160a4c55defaf29bba3adfd5b4fe4b9e
+SIZE (cabal/cryptocipher-0.3.0.tar.gz) = 31665
diff --git a/security/hs-cryptocipher/pkg-descr b/security/hs-cryptocipher/pkg-descr
new file mode 100644
index 000000000000..61d6e70ca041
--- /dev/null
+++ b/security/hs-cryptocipher/pkg-descr
@@ -0,0 +1,3 @@
+Symmetrical Block, Stream, and PubKey Ciphers.
+
+WWW: http://github.com/vincenthz/hs-cryptocipher