aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-03 13:38:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-03 13:38:57 +0000
commit500665890f46cc3d531d94aa9fe13c463c0396d0 (patch)
tree0912773634c409a4eb68102509e5596303251822
parent1631db264b5cad567f2161ae09206b5ecb335cb2 (diff)
- Stage support
Notes
Notes: svn path=/head/; revision=342436
-rw-r--r--editors/bpatch/Makefile5
-rw-r--r--graphics/sage/Makefile3
-rw-r--r--graphics/sage/pkg-plist2
-rw-r--r--x11-servers/x2vnc/Makefile6
4 files changed, 7 insertions, 9 deletions
diff --git a/editors/bpatch/Makefile b/editors/bpatch/Makefile
index 99599c3288c7..a547dc0b4a6f 100644
--- a/editors/bpatch/Makefile
+++ b/editors/bpatch/Makefile
@@ -11,9 +11,8 @@ DISTNAME= ${PORTNAME}
MAINTAINER= joerg@FreeBSD.org
COMMENT= A hex editor that doesn't load the whole file at once
-MAN1= bpatch.1
NO_WRKSUBDIR= yes
-PLIST_FILES= bin/bpatch
+PLIST_FILES= bin/bpatch \
+ man/man1/bpatch.1.gz
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/graphics/sage/Makefile b/graphics/sage/Makefile
index bcca94d434ff..de8cb52c2a9e 100644
--- a/graphics/sage/Makefile
+++ b/graphics/sage/Makefile
@@ -17,11 +17,8 @@ USES= pathfix
USE_LDCONFIG= yes
USE_SDL= sdl
-MAN3= sage.3 sage_init.3
-
CFLAGS+= -I${LOCALBASE}/include
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|g' ${WRKSRC}/configure
diff --git a/graphics/sage/pkg-plist b/graphics/sage/pkg-plist
index cdc5522c953f..b5c91c3a662a 100644
--- a/graphics/sage/pkg-plist
+++ b/graphics/sage/pkg-plist
@@ -8,5 +8,7 @@ include/sage/sage_fptr.h
include/sage/GL.h
include/sage/GLU.h
include/sage/header.h
+man/man3/sage.3.gz
+man/man3/sage_init.3.gz
@dirrm include/sage
libdata/pkgconfig/sage.pc
diff --git a/x11-servers/x2vnc/Makefile b/x11-servers/x2vnc/Makefile
index cf082f49fb87..e5c25bb2fb0f 100644
--- a/x11-servers/x2vnc/Makefile
+++ b/x11-servers/x2vnc/Makefile
@@ -16,8 +16,8 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_XORG= x11 xext xrandr xxf86dga ice xinerama xrandr xrender xscrnsaver sm
-MAN1= x2vnc.1
-PLIST_FILES= bin/x2vnc
-NO_STAGE= yes
+PLIST_FILES= bin/x2vnc \
+ man/man1/x2vnc.1.gz
+
.include <bsd.port.mk>