aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-10-20 21:10:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-10-20 21:10:48 +0000
commit50361d0229cf403a3c71313957b58ca3de48576f (patch)
treeba0669c3e567d4e12d8ae03286d3cddcf7e13264
parent6c756b215e48a76f5752d350caf661ee0ef858c2 (diff)
downloadports-50361d0229cf403a3c71313957b58ca3de48576f.tar.gz
ports-50361d0229cf403a3c71313957b58ca3de48576f.zip
Notes
-rw-r--r--graphics/tif22pnm/Makefile15
-rw-r--r--graphics/tif22pnm/distinfo4
2 files changed, 11 insertions, 8 deletions
diff --git a/graphics/tif22pnm/Makefile b/graphics/tif22pnm/Makefile
index 4ee62f0869dd..d62167174cc8 100644
--- a/graphics/tif22pnm/Makefile
+++ b/graphics/tif22pnm/Makefile
@@ -7,18 +7,17 @@
#
PORTNAME= tif22pnm
-PORTVERSION= 0.11
+PORTVERSION= 0.12
CATEGORIES= graphics
MASTER_SITES= http://www.inf.bme.hu/~pts/
MAINTAINER= ports@FreeBSD.org
COMMENT= Converts TIFF- sampled images to PNM image
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-libtiff-ldir=${LOCALBASE}/lib \
@@ -26,11 +25,15 @@ CONFIGURE_ARGS= --with-libtiff-ldir=${LOCALBASE}/lib \
PLIST_FILES= bin/png22pnm bin/tif22pnm
-post-patch:
- @${REINPLACE_CMD} -e 's| -O2| ${CFLAGS}|g' ${WRKSRC}/do.sh
+TIF22PNM_SRCS= ptspnm.c minigimp.c miniglib.c ptstiff3.c tif22pnm.c
+PNG2PNM_SRCS= png22pnm.c
do-build:
- @(cd ${WRKSRC} ; ${LOCALBASE}/bin/bash do.sh compile)
+ cd ${WRKSRC} \
+ && ${CC} ${CFLAGS} -DNDEBUG -I${LOCALBASE}/include \
+ ${TIF22PNM_SRCS} -o tif22pnm -L${LOCALBASE}/lib -ltiff \
+ && ${CC} ${CFLAGS} -DNDEBUG `pkg-config libpng12 --cflags` \
+ ${PNG2PNM_SRCS} -o png22pnm `pkg-config libpng12 --libs`
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/png22pnm ${PREFIX}/bin
diff --git a/graphics/tif22pnm/distinfo b/graphics/tif22pnm/distinfo
index 9450ce748468..96d13bb13465 100644
--- a/graphics/tif22pnm/distinfo
+++ b/graphics/tif22pnm/distinfo
@@ -1,2 +1,2 @@
-MD5 (tif22pnm-0.11.tar.gz) = 1fde82ce6039e0ca83d7dbaf871ea029
-SIZE (tif22pnm-0.11.tar.gz) = 107002
+MD5 (tif22pnm-0.12.tar.gz) = faeb859e2e01653e6b9fd4db992c02a9
+SIZE (tif22pnm-0.12.tar.gz) = 107567