aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-02-09 01:41:12 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-02-09 01:41:12 +0000
commit5155c246bd427c54c751e13978d954af95437afa (patch)
treeec4cdab34fb371d19352edd4860c5e5030665eb5
parent2a9f95156545144efb605f0fcfe5de5fd759554b (diff)
downloadports-5155c246bd427c54c751e13978d954af95437afa.tar.gz
ports-5155c246bd427c54c751e13978d954af95437afa.zip
Notes
-rw-r--r--databases/grass-i18n/Makefile8
-rw-r--r--databases/grass/Makefile8
-rw-r--r--german/BBBike/Makefile8
-rw-r--r--math/R-letter/Makefile8
-rw-r--r--math/R-project/Makefile8
-rw-r--r--math/R/Makefile8
6 files changed, 42 insertions, 6 deletions
diff --git a/databases/grass-i18n/Makefile b/databases/grass-i18n/Makefile
index 9a6d71f722c2..e09aeaa0b9c2 100644
--- a/databases/grass-i18n/Makefile
+++ b/databases/grass-i18n/Makefile
@@ -58,8 +58,14 @@ CONFIGURE_ARGS= --with-includes=${LOCALBASE}/include \
--with-nls \
--without-motif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Broken pkg-plist"
+.endif
+
post-install:
-(cd ${PREFIX} && ${GREP} -v "@" ${PLIST} | \
${XARGS} ${STRIP_CMD} 2> /dev/null || ${TRUE})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/databases/grass/Makefile b/databases/grass/Makefile
index 9a6d71f722c2..e09aeaa0b9c2 100644
--- a/databases/grass/Makefile
+++ b/databases/grass/Makefile
@@ -58,8 +58,14 @@ CONFIGURE_ARGS= --with-includes=${LOCALBASE}/include \
--with-nls \
--without-motif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Broken pkg-plist"
+.endif
+
post-install:
-(cd ${PREFIX} && ${GREP} -v "@" ${PLIST} | \
${XARGS} ${STRIP_CMD} 2> /dev/null || ${TRUE})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/german/BBBike/Makefile b/german/BBBike/Makefile
index 80c341bcfd7d..7b5b776bda52 100644
--- a/german/BBBike/Makefile
+++ b/german/BBBike/Makefile
@@ -30,6 +30,12 @@ MYDESTDIR= ${PREFIX}/BBBike
PLIST= ${PKGDIR}/pkg-plist.5005
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Broken pkg-plist"
+.endif
+
do-build:
cd ${WRKSRC}/ext && ${MAKE} PERL=${PERL5} all install
cd ${WRKSRC}/ext && ${MAKE} PERL=${PERL5} clean
@@ -54,4 +60,4 @@ do-install:
${LN} -s ${MYDESTDIR}/$f ${PREFIX}/bin/$f
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/R-letter/Makefile b/math/R-letter/Makefile
index f7e9d60d0676..836b3adf9c01 100644
--- a/math/R-letter/Makefile
+++ b/math/R-letter/Makefile
@@ -66,9 +66,15 @@ PAPERSIZE?= letter
MAN1= R.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Broken pkg-plist"
+.endif
+
test check: build
@(cd ${WRKSRC}; ${MAKE} check)
check-all: build
@(cd ${WRKSRC}; ${MAKE} check-all)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/R-project/Makefile b/math/R-project/Makefile
index f7e9d60d0676..836b3adf9c01 100644
--- a/math/R-project/Makefile
+++ b/math/R-project/Makefile
@@ -66,9 +66,15 @@ PAPERSIZE?= letter
MAN1= R.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Broken pkg-plist"
+.endif
+
test check: build
@(cd ${WRKSRC}; ${MAKE} check)
check-all: build
@(cd ${WRKSRC}; ${MAKE} check-all)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/R/Makefile b/math/R/Makefile
index f7e9d60d0676..836b3adf9c01 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -66,9 +66,15 @@ PAPERSIZE?= letter
MAN1= R.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Broken pkg-plist"
+.endif
+
test check: build
@(cd ${WRKSRC}; ${MAKE} check)
check-all: build
@(cd ${WRKSRC}; ${MAKE} check-all)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>